2002-11-20 23:44:05

by Rusty Lynch

[permalink] [raw]
Subject: [Coding style question] XXX_register or register_XXX

Is there an accepted standard on naming for registration functions? If have
a foo
object that other things can register and unregister with, should the
function names be:

int register_foo(&something);
int unregister_foo(&something);

- or -

int foo_register(&something);
int foo_unregister(&something);

-rustyl


2002-11-21 00:38:57

by Halil Demirezen

[permalink] [raw]
Subject: Re: [Coding style question] XXX_register or register_XXX

> Is there an accepted standard on naming for registration functions?
> If have a foo object that other things can register and unregister
> with, should the function names be:
> int foo_register(&something);
> int foo_unregister(&something);

really, that would make the entire kernel code a little
simplier to understand.
On the same way, we can say why there is not an accepted standard on
naming lock functions, such as

spinlock, rwlock and so on..

That would be more efficient to understand the code...
However, where is flexibility?


-hd

2002-11-21 01:01:07

by Robert Love

[permalink] [raw]
Subject: Re: [Coding style question] XXX_register or register_XXX

On Wed, 2002-11-20 at 18:49, Rusty Lynch wrote:

> Is there an accepted standard on naming for registration functions? If have
> a foo object that other things can register and unregister with,
> should the function names be:

I do not think there is an accepted practice here.

> int register_foo(&something);
> int unregister_foo(&something);

I bet this is more common.

> int foo_register(&something);
> int foo_unregister(&something);

But I prefer this - I like there to be a namespace for a given subsystem
and for it to be a prefix.

Robert Love

2002-11-21 01:07:36

by Arnaldo Carvalho de Melo

[permalink] [raw]
Subject: Re: [Coding style question] XXX_register or register_XXX

Em Wed, Nov 20, 2002 at 08:08:28PM -0500, Robert Love escreveu:
> On Wed, 2002-11-20 at 18:49, Rusty Lynch wrote:
> > int foo_register(&something);
> > int foo_unregister(&something);

> But I prefer this - I like there to be a namespace for a given subsystem
> and for it to be a prefix.

100% agreed. Just look at LLC 8) And yes, the big names was procom's fault,
but the way it is structured... I'd love somebody to come up with something
that makes it smaller 8)

- Arnaldo

2002-11-21 03:46:43

by Perez-Gonzalez, Inaky

[permalink] [raw]
Subject: RE: [Coding style question] XXX_register or register_XXX


> int foo_register(&something);
> int foo_unregister(&something);

I prefer this, althought the other one is [maybe more] common.

Inaky Perez-Gonzalez -- Not speaking for Intel - opinions are my own [or my
fault]