2019-07-05 14:51:18

by Markus Elfring

[permalink] [raw]
Subject: [PATCH] mm/slab: One function call less in verify_redzone_free()

From: Markus Elfring <[email protected]>
Date: Fri, 5 Jul 2019 16:40:09 +0200

Avoid an extra function call by using a ternary operator instead of
a conditional statement for a string literal selection.

This issue was detected by using the Coccinelle software.

Signed-off-by: Markus Elfring <[email protected]>
---
mm/slab.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/mm/slab.c b/mm/slab.c
index 9df370558e5d..849b5c276588 100644
--- a/mm/slab.c
+++ b/mm/slab.c
@@ -2701,10 +2701,10 @@ static inline void verify_redzone_free(struct kmem_cache *cache, void *obj)
if (redzone1 == RED_ACTIVE && redzone2 == RED_ACTIVE)
return;

- if (redzone1 == RED_INACTIVE && redzone2 == RED_INACTIVE)
- slab_error(cache, "double free detected");
- else
- slab_error(cache, "memory outside object was overwritten");
+ slab_error(cache,
+ redzone1 == RED_INACTIVE && redzone2 == RED_INACTIVE
+ ? "double free detected"
+ : "memory outside object was overwritten");

pr_err("%px: redzone 1:0x%llx, redzone 2:0x%llx\n",
obj, redzone1, redzone2);
--
2.22.0


Subject: Re: [PATCH] mm/slab: One function call less in verify_redzone_free()

On Fri, 5 Jul 2019, Markus Elfring wrote:

> Avoid an extra function call by using a ternary operator instead of
> a conditional statement for a string literal selection.

Well. I thought the compiler does that on its own? And the tenary operator
makes the code difficult to read.

2019-07-06 22:45:45

by David Rientjes

[permalink] [raw]
Subject: Re: [PATCH] mm/slab: One function call less in verify_redzone_free()

On Fri, 5 Jul 2019, Christopher Lameter wrote:

> On Fri, 5 Jul 2019, Markus Elfring wrote:
>
> > Avoid an extra function call by using a ternary operator instead of
> > a conditional statement for a string literal selection.
>
> Well. I thought the compiler does that on its own? And the tenary operator
> makes the code difficult to read.
>

Right, and I don't understand the changelog: yes, there's one less
function call in the source but functionally there's still a conditional;
this isn't even optimizing DEBUG builds.