struct mtd_blktrans_ops is a type, and mtd_blktrans_ops is a variable.
To improve code clarity it's better to not use the same names,
so we just change the latter.
Cc: David Woodhouse <[email protected]>
Signed-off-by: Ezequiel Garcia <[email protected]>
---
drivers/mtd/mtd_blkdevs.c | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/mtd/mtd_blkdevs.c b/drivers/mtd/mtd_blkdevs.c
index f1f0671..26ef2a7 100644
--- a/drivers/mtd/mtd_blkdevs.c
+++ b/drivers/mtd/mtd_blkdevs.c
@@ -325,7 +325,7 @@ unlock:
return ret;
}
-static const struct block_device_operations mtd_blktrans_ops = {
+static const struct block_device_operations mtd_block_ops = {
.owner = THIS_MODULE,
.open = blktrans_open,
.release = blktrans_release,
@@ -401,7 +401,7 @@ int add_mtd_blktrans_dev(struct mtd_blktrans_dev *new)
gd->private_data = new;
gd->major = tr->major;
gd->first_minor = (new->devnum) << tr->part_bits;
- gd->fops = &mtd_blktrans_ops;
+ gd->fops = &mtd_block_ops;
if (tr->part_bits)
if (new->devnum < 26)
--
1.7.8.6
On Fri, 2012-11-09 at 12:36 -0300, Ezequiel Garcia wrote:
> struct mtd_blktrans_ops is a type, and mtd_blktrans_ops is a variable.
> To improve code clarity it's better to not use the same names,
> so we just change the latter.
>
> Cc: David Woodhouse <[email protected]>
> Signed-off-by: Ezequiel Garcia <[email protected]>
Pushed to l2-mtd.git, thanks!
--
Best Regards,
Artem Bityutskiy