2015-04-28 12:34:54

by Richard Fitzgerald

[permalink] [raw]
Subject: [PATCH 0/1] extcon: arizona: Rename hpdet_ip to make its purpose clearer

I need to do a new version of the WM8998 patches, so
here is the change to extcon-arizona to make the
hpdet_ip version number clearer.

If you can take this change first I will rebase the
WM8998 patches onto this one.

Richard Fitzgerald (1):
extcon: arizona: Rename hpdet_ip to make its purpose clearer

drivers/extcon/extcon-arizona.c | 10 +++++-----
1 files changed, 5 insertions(+), 5 deletions(-)

--
1.7.2.5


2015-04-28 12:34:55

by Richard Fitzgerald

[permalink] [raw]
Subject: [PATCH 1/1] extcon: arizona: Rename hpdet_ip to make its purpose clearer

Renamed to hpdet_ip_version to make it clearer what it does
and that the value in it is simply a version number.

Signed-off-by: Richard Fitzgerald <[email protected]>
---
drivers/extcon/extcon-arizona.c | 10 +++++-----
1 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/extcon/extcon-arizona.c b/drivers/extcon/extcon-arizona.c
index d9e763c..02b181a 100644
--- a/drivers/extcon/extcon-arizona.c
+++ b/drivers/extcon/extcon-arizona.c
@@ -94,7 +94,7 @@ struct arizona_extcon_info {
bool detecting;
int jack_flips;

- int hpdet_ip;
+ int hpdet_ip_version;

struct extcon_dev *edev;
};
@@ -380,7 +380,7 @@ static int arizona_hpdet_read(struct arizona_extcon_info *info)
return ret;
}

- switch (info->hpdet_ip) {
+ switch (info->hpdet_ip_version) {
case 0:
if (!(val & ARIZONA_HP_DONE)) {
dev_err(arizona->dev, "HPDET did not complete: %x\n",
@@ -441,7 +441,7 @@ static int arizona_hpdet_read(struct arizona_extcon_info *info)

default:
dev_warn(arizona->dev, "Unknown HPDET IP revision %d\n",
- info->hpdet_ip);
+ info->hpdet_ip_version);
case 2:
if (!(val & ARIZONA_HP_DONE_B)) {
dev_err(arizona->dev, "HPDET did not complete: %x\n",
@@ -1161,7 +1161,7 @@ static int arizona_extcon_probe(struct platform_device *pdev)
break;
default:
info->micd_clamp = true;
- info->hpdet_ip = 1;
+ info->hpdet_ip_version = 1;
break;
}
break;
@@ -1171,7 +1171,7 @@ static int arizona_extcon_probe(struct platform_device *pdev)
break;
default:
info->micd_clamp = true;
- info->hpdet_ip = 2;
+ info->hpdet_ip_version = 2;
break;
}
break;
--
1.7.2.5

2015-04-28 13:04:33

by Chanwoo Choi

[permalink] [raw]
Subject: Re: [PATCH 1/1] extcon: arizona: Rename hpdet_ip to make its purpose clearer

Hi Richard,

On Tue, Apr 28, 2015 at 9:34 PM, Richard Fitzgerald
<[email protected]> wrote:
> Renamed to hpdet_ip_version to make it clearer what it does
> and that the value in it is simply a version number.
>
> Signed-off-by: Richard Fitzgerald <[email protected]>
> ---
> drivers/extcon/extcon-arizona.c | 10 +++++-----
> 1 files changed, 5 insertions(+), 5 deletions(-)

Looks good to me. I'll apply it on extcon-next tomorrow.

Thanks,
Chanwoo Choi