2020-09-18 07:20:20

by Zengtao (B)

[permalink] [raw]
Subject: [PATCH] net: openswitch: reuse the helper variable to improve the code readablity

In the function ovs_ct_limit_exit, there is already a helper vaibale
which could be reused to improve the readability, so i fix it in this
patch.

Signed-off-by: Zeng Tao <[email protected]>
---
net/openvswitch/conntrack.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/net/openvswitch/conntrack.c b/net/openvswitch/conntrack.c
index a3f1204..e86b960 100644
--- a/net/openvswitch/conntrack.c
+++ b/net/openvswitch/conntrack.c
@@ -1901,8 +1901,8 @@ static void ovs_ct_limit_exit(struct net *net, struct ovs_net *ovs_net)
lockdep_ovsl_is_held())
kfree_rcu(ct_limit, rcu);
}
- kfree(ovs_net->ct_limit_info->limits);
- kfree(ovs_net->ct_limit_info);
+ kfree(info->limits);
+ kfree(info);
}

static struct sk_buff *
--
2.8.1


2020-09-18 21:27:42

by David Miller

[permalink] [raw]
Subject: Re: [PATCH] net: openswitch: reuse the helper variable to improve the code readablity

From: Zeng Tao <[email protected]>
Date: Fri, 18 Sep 2020 15:14:30 +0800

> In the function ovs_ct_limit_exit, there is already a helper vaibale
> which could be reused to improve the readability, so i fix it in this
> patch.
>
> Signed-off-by: Zeng Tao <[email protected]>

Applied, thanks.