2021-08-15 06:53:59

by Muhammad Falak R Wani

[permalink] [raw]
Subject: [PATCH] samples: bpf: offwaketime: define MAX_ENTRIES instead of a magic number

Define MAX_ENTRIES instead of using 10000 as a magic number in various
places.

Signed-off-by: Muhammad Falak R Wani <[email protected]>
---
samples/bpf/offwaketime_kern.c | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/samples/bpf/offwaketime_kern.c b/samples/bpf/offwaketime_kern.c
index 14b792915a9c..4866afd054da 100644
--- a/samples/bpf/offwaketime_kern.c
+++ b/samples/bpf/offwaketime_kern.c
@@ -20,6 +20,7 @@
})

#define MINBLOCK_US 1
+#define MAX_ENTRIES 10000

struct key_t {
char waker[TASK_COMM_LEN];
@@ -32,14 +33,14 @@ struct {
__uint(type, BPF_MAP_TYPE_HASH);
__type(key, struct key_t);
__type(value, u64);
- __uint(max_entries, 10000);
+ __uint(max_entries, MAX_ENTRIES);
} counts SEC(".maps");

struct {
__uint(type, BPF_MAP_TYPE_HASH);
__type(key, u32);
__type(value, u64);
- __uint(max_entries, 10000);
+ __uint(max_entries, MAX_ENTRIES);
} start SEC(".maps");

struct wokeby_t {
@@ -51,14 +52,14 @@ struct {
__uint(type, BPF_MAP_TYPE_HASH);
__type(key, u32);
__type(value, struct wokeby_t);
- __uint(max_entries, 10000);
+ __uint(max_entries, MAX_ENTRIES);
} wokeby SEC(".maps");

struct {
__uint(type, BPF_MAP_TYPE_STACK_TRACE);
__uint(key_size, sizeof(u32));
__uint(value_size, PERF_MAX_STACK_DEPTH * sizeof(u64));
- __uint(max_entries, 10000);
+ __uint(max_entries, MAX_ENTRIES);
} stackmap SEC(".maps");

#define STACKID_FLAGS (0 | BPF_F_FAST_STACK_CMP)
--
2.17.1


2021-08-15 07:24:39

by patchwork-bot+netdevbpf

[permalink] [raw]
Subject: Re: [PATCH] samples: bpf: offwaketime: define MAX_ENTRIES instead of a magic number

Hello:

This patch was applied to bpf/bpf-next.git (refs/heads/master):

On Sun, 15 Aug 2021 12:20:13 +0530 you wrote:
> Define MAX_ENTRIES instead of using 10000 as a magic number in various
> places.
>
> Signed-off-by: Muhammad Falak R Wani <[email protected]>
> ---
> samples/bpf/offwaketime_kern.c | 9 +++++----
> 1 file changed, 5 insertions(+), 4 deletions(-)

Here is the summary with links:
- samples: bpf: offwaketime: define MAX_ENTRIES instead of a magic number
https://git.kernel.org/bpf/bpf-next/c/d1bf7c4d5dea

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html