2022-09-19 22:16:48

by Easwar Hariharan

[permalink] [raw]
Subject: [PATCH] Use PCI_VENDOR_ID_MICROSOFT define instead of magic number

From: Easwar Hariharan <[email protected]>

pci_ids.h already defines PCI_VENDOR_ID_MICROSOFT, and is included via
linux/pci.h. Use the define instead of the magic number.

base-commit: f0880e2cb7e1f8039a048fdd01ce45ab77247221

Easwar Hariharan (1):
hv: Use PCI_VENDOR_ID_MICROSOFT for better discoverability

drivers/hv/vmbus_drv.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

--
1.8.3.1


2022-09-19 22:18:40

by Easwar Hariharan

[permalink] [raw]
Subject: [PATCH] hv: Use PCI_VENDOR_ID_MICROSOFT for better discoverability

From: Easwar Hariharan <[email protected]>

pci_ids.h already defines PCI_VENDOR_ID_MICROSOFT, and is included via
linux/pci.h. Use the define instead of the magic number.

Signed-off-by: Easwar Hariharan <[email protected]>
---
drivers/hv/vmbus_drv.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/hv/vmbus_drv.c b/drivers/hv/vmbus_drv.c
index 3c833ea..f2efb74 100644
--- a/drivers/hv/vmbus_drv.c
+++ b/drivers/hv/vmbus_drv.c
@@ -2052,7 +2052,7 @@ struct hv_device *vmbus_device_create(const guid_t *type,
child_device_obj->channel = channel;
guid_copy(&child_device_obj->dev_type, type);
guid_copy(&child_device_obj->dev_instance, instance);
- child_device_obj->vendor_id = 0x1414; /* MSFT vendor ID */
+ child_device_obj->vendor_id = PCI_VENDOR_ID_MICROSOFT;

return child_device_obj;
}
--
1.8.3.1

2022-09-22 22:47:12

by Michael Kelley (LINUX)

[permalink] [raw]
Subject: RE: [PATCH] hv: Use PCI_VENDOR_ID_MICROSOFT for better discoverability

From: Easwar Hariharan <[email protected]> Sent: Monday, September 19, 2022 3:05 PM
>
> pci_ids.h already defines PCI_VENDOR_ID_MICROSOFT, and is included via
> linux/pci.h. Use the define instead of the magic number.
>
> Signed-off-by: Easwar Hariharan <[email protected]>
> ---
> drivers/hv/vmbus_drv.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/hv/vmbus_drv.c b/drivers/hv/vmbus_drv.c
> index 3c833ea..f2efb74 100644
> --- a/drivers/hv/vmbus_drv.c
> +++ b/drivers/hv/vmbus_drv.c
> @@ -2052,7 +2052,7 @@ struct hv_device *vmbus_device_create(const guid_t *type,
> child_device_obj->channel = channel;
> guid_copy(&child_device_obj->dev_type, type);
> guid_copy(&child_device_obj->dev_instance, instance);
> - child_device_obj->vendor_id = 0x1414; /* MSFT vendor ID */
> + child_device_obj->vendor_id = PCI_VENDOR_ID_MICROSOFT;
>
> return child_device_obj;
> }
> --
> 1.8.3.1

Reviewed-by: Michael Kelley <[email protected]>

2022-09-22 22:58:03

by Michael Kelley (LINUX)

[permalink] [raw]
Subject: RE: [PATCH] hv: Use PCI_VENDOR_ID_MICROSOFT for better discoverability

From: Michael Kelley (LINUX) <[email protected]> Sent: Thursday, September 22, 2022 3:39 PM
>
> From: Easwar Hariharan <[email protected]> Sent: Monday, September
> 19, 2022 3:05 PM
> >
> > pci_ids.h already defines PCI_VENDOR_ID_MICROSOFT, and is included via
> > linux/pci.h. Use the define instead of the magic number.
> >
> > Signed-off-by: Easwar Hariharan <[email protected]>
> > ---
> > drivers/hv/vmbus_drv.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/drivers/hv/vmbus_drv.c b/drivers/hv/vmbus_drv.c
> > index 3c833ea..f2efb74 100644
> > --- a/drivers/hv/vmbus_drv.c
> > +++ b/drivers/hv/vmbus_drv.c
> > @@ -2052,7 +2052,7 @@ struct hv_device *vmbus_device_create(const guid_t
> *type,
> > child_device_obj->channel = channel;
> > guid_copy(&child_device_obj->dev_type, type);
> > guid_copy(&child_device_obj->dev_instance, instance);
> > - child_device_obj->vendor_id = 0x1414; /* MSFT vendor ID */
> > + child_device_obj->vendor_id = PCI_VENDOR_ID_MICROSOFT;
> >
> > return child_device_obj;
> > }
> > --
> > 1.8.3.1
>
> Reviewed-by: Michael Kelley <[email protected]>

Actually, a nit: The short commit message should start with "Drivers: hv:" or
"Drivers: hv: vmbus:". Check the commit history on vmbus_drv.c and you'll
see the standard usage.

Michael

2022-09-23 11:20:44

by Wei Liu

[permalink] [raw]
Subject: Re: [PATCH] hv: Use PCI_VENDOR_ID_MICROSOFT for better discoverability

On Thu, Sep 22, 2022 at 10:43:24PM +0000, Michael Kelley (LINUX) wrote:
> From: Michael Kelley (LINUX) <[email protected]> Sent: Thursday, September 22, 2022 3:39 PM
> >
> > From: Easwar Hariharan <[email protected]> Sent: Monday, September
> > 19, 2022 3:05 PM
> > >
> > > pci_ids.h already defines PCI_VENDOR_ID_MICROSOFT, and is included via
> > > linux/pci.h. Use the define instead of the magic number.
> > >
> > > Signed-off-by: Easwar Hariharan <[email protected]>
> > > ---
> > > drivers/hv/vmbus_drv.c | 2 +-
> > > 1 file changed, 1 insertion(+), 1 deletion(-)
> > >
> > > diff --git a/drivers/hv/vmbus_drv.c b/drivers/hv/vmbus_drv.c
> > > index 3c833ea..f2efb74 100644
> > > --- a/drivers/hv/vmbus_drv.c
> > > +++ b/drivers/hv/vmbus_drv.c
> > > @@ -2052,7 +2052,7 @@ struct hv_device *vmbus_device_create(const guid_t
> > *type,
> > > child_device_obj->channel = channel;
> > > guid_copy(&child_device_obj->dev_type, type);
> > > guid_copy(&child_device_obj->dev_instance, instance);
> > > - child_device_obj->vendor_id = 0x1414; /* MSFT vendor ID */
> > > + child_device_obj->vendor_id = PCI_VENDOR_ID_MICROSOFT;
> > >
> > > return child_device_obj;
> > > }
> > > --
> > > 1.8.3.1
> >
> > Reviewed-by: Michael Kelley <[email protected]>
>
> Actually, a nit: The short commit message should start with "Drivers: hv:" or
> "Drivers: hv: vmbus:". Check the commit history on vmbus_drv.c and you'll
> see the standard usage.

I fixed up the commit message and applied it to hyperv-next. Thanks.

>
> Michael
>