The patch below adds ULL postfixes to three constants in tg3.c .
There's no need to create an int constant and later cast it to u64.
The second case was also incorrect since the constant was too big for an
int.
Please apply
Adrian
--- linux-2.5.73-not-full/drivers/net/tg3.c.old 2003-06-24 19:42:20.000000000 +0200
+++ linux-2.5.73-not-full/drivers/net/tg3.c 2003-06-24 19:43:47.000000000 +0200
@@ -6679,16 +6679,16 @@
}
/* Configure DMA attributes. */
- if (!pci_set_dma_mask(pdev, (u64) 0xffffffffffffffffULL)) {
+ if (!pci_set_dma_mask(pdev, 0xffffffffffffffffULL)) {
pci_using_dac = 1;
if (pci_set_consistent_dma_mask(pdev,
- (u64) 0xffffffffffffffff)) {
+ 0xffffffffffffffffULL)) {
printk(KERN_ERR PFX "Unable to obtain 64 bit DMA "
"for consistent allocations\n");
goto err_out_free_res;
}
} else {
- err = pci_set_dma_mask(pdev, (u64) 0xffffffff);
+ err = pci_set_dma_mask(pdev, 0xffffffffULL);
if (err) {
printk(KERN_ERR PFX "No usable DMA configuration, "
"aborting.\n");
Q: Why not to use something even easier to read (and write), like "~0ULL" or
better yet "UINT64_MAX" (stdint.h)?
> -----Original Message-----
> From: Adrian Bunk [mailto:[email protected]]
> Sent: Tuesday, June 24, 2003 1:48 PM
> To: David S. Miller; Jeff Garzik
> Cc: [email protected]; [email protected];
> [email protected]
> Subject: [2.5 patch] ULL postfixes for tg3.c
>
>
> The patch below adds ULL postfixes to three constants in tg3.c .
>
> There's no need to create an int constant and later cast it to u64.
>
> The second case was also incorrect since the constant was too
> big for an
> int.
>
> Please apply
> Adrian
>
> --- linux-2.5.73-not-full/drivers/net/tg3.c.old
> 2003-06-24 19:42:20.000000000 +0200
> +++ linux-2.5.73-not-full/drivers/net/tg3.c 2003-06-24
> 19:43:47.000000000 +0200
> @@ -6679,16 +6679,16 @@
> }
>
> /* Configure DMA attributes. */
> - if (!pci_set_dma_mask(pdev, (u64) 0xffffffffffffffffULL)) {
> + if (!pci_set_dma_mask(pdev, 0xffffffffffffffffULL)) {
> pci_using_dac = 1;
> if (pci_set_consistent_dma_mask(pdev,
> - (u64)
> 0xffffffffffffffff)) {
> +
> 0xffffffffffffffffULL)) {
> printk(KERN_ERR PFX "Unable to obtain
> 64 bit DMA "
> "for consistent allocations\n");
> goto err_out_free_res;
> }
> } else {
> - err = pci_set_dma_mask(pdev, (u64) 0xffffffff);
> + err = pci_set_dma_mask(pdev, 0xffffffffULL);
> if (err) {
> printk(KERN_ERR PFX "No usable DMA
> configuration, "
> "aborting.\n");
> -
> To unsubscribe from this list: send the line "unsubscribe
> linux-net" in
> the body of a message to [email protected]
> More majordomo info at http://vger.kernel.org/majordomo-info.html
>
On Tue, Jun 24, 2003 at 02:00:07PM -0400, Eble, Dan wrote:
> Q: Why not to use something even easier to read (and write), like "~0ULL" or
> better yet "UINT64_MAX" (stdint.h)?
A: This seems to be an excellent idea.
Linus, what's your opinion on adding constants like UINT64_MAX to
kernel.h and use them where appropriate?
cu
Adrian
--
"Is there not promise of rain?" Ling Tan asked suddenly out
of the darkness. There had been need of rain for many days.
"Only a promise," Lao Er said.
Pearl S. Buck - Dragon Seed
I'll apply this, the INT64_MAX or whatever ideas are just
stupid. We're saying what "bits" the device supports when
it does DMA, so we should pass in a "bit" mask.
On Tue, 2003-06-24 at 22:12, David S. Miller wrote:
> I'll apply this, the INT64_MAX or whatever ideas are just
> stupid. We're saying what "bits" the device supports when
> it does DMA, so we should pass in a "bit" mask.
however it might be a good idea to define a PCI_DMAMASK_64BIT (and 32
bit) with the right values ?
David S. Miller wrote:
> I'll apply this, the INT64_MAX or whatever ideas are just
> stupid. We're saying what "bits" the device supports when
> it does DMA, so we should pass in a "bit" mask.
no need. look what's in the pipe already.