2005-01-23 05:53:09

by Anton Blanchard

[permalink] [raw]
Subject: [PATCH] rename device_init


Rename device_init to make it more unique. Useful when looking through
debug initcall bootlogs. While Im in the area, also make it static.

Signed-off-by: Anton Blanchard <[email protected]>

diff -puN drivers/block/genhd.c~rename_device_init drivers/block/genhd.c
--- gr_work/drivers/block/genhd.c~rename_device_init 2005-01-21 19:37:07.585813607 -0600
+++ gr_work-anton/drivers/block/genhd.c 2005-01-21 19:37:07.596811864 -0600
@@ -300,7 +300,7 @@ static struct kobject *base_probe(dev_t
return NULL;
}

-int __init device_init(void)
+static int __init genhd_device_init(void)
{
bdev_map = kobj_map_init(base_probe, &block_subsys);
blk_dev_init();
@@ -308,7 +308,7 @@ int __init device_init(void)
return 0;
}

-subsys_initcall(device_init);
+subsys_initcall(genhd_device_init);