The git-acpi.patch changed the name of the "id" member of the
acpi_resource structure, but missed the below user. Updating to the new
name.
Signed-off-by: Alex Williamson <[email protected]>
diff -r 6bf6e9fcc962 arch/ia64/kernel/acpi-ext.c
--- a/arch/ia64/kernel/acpi-ext.c Sun Oct 16 22:44:53 2005
+++ b/arch/ia64/kernel/acpi-ext.c Mon Oct 17 14:27:14 2005
@@ -35,7 +35,7 @@
struct acpi_vendor_descriptor *descriptor;
u32 length;
- if (resource->id != ACPI_RSTYPE_VENDOR)
+ if (resource->type != ACPI_RSTYPE_VENDOR)
return AE_OK;
vendor = (struct acpi_resource_vendor *)&resource->data;
Alex wrote:
> - if (resource->id != ACPI_RSTYPE_VENDOR)
> + if (resource->type != ACPI_RSTYPE_VENDOR)
Yup - ia64 *.mm builds much better with this. Thanks.
--
I won't rest till it's the best ...
Programmer, Linux Scalability
Paul Jackson <[email protected]> 1.925.600.0401