2005-11-22 16:33:16

by Jody McIntyre

[permalink] [raw]
Subject: Re: [PATCH] pcilynx.c LIndent fixes

(I'm also sending this to lkml in case people disagree with me or I
missed something. Should we put something like this in CodingStyle as a
warning to future Lindent users?)

Things that Lindent generally screws up on:

On Tue, Nov 22, 2005 at 02:41:38AM +0000, Jens-Michael Hoffmann wrote:

> -MODULE_PARM_DESC(skip_eeprom, "Use generic bus info block instead of serial eeprom (default = 0).");
> -
> +MODULE_PARM_DESC(skip_eeprom,
> + "Use generic bus info block instead of serial eeprom (default = 0).");

String handling. I guess this is difficult to sensibly automate, but
this should really be something like:

MODULE_PARM_DESC(skip_eeprom,
"Use generic bus info block instead of serial eeprom "
"(default = 0).");

> [...]

> static struct i2c_adapter bit_ops = {
> - .id = 0xAA, //FIXME: probably we should get an id in i2c-id.h
> - .client_register = bit_reg,
> - .client_unregister = bit_unreg,
> - .name = "PCILynx I2C",
> + .id = 0xAA, //FIXME: probably we should get an id in i2c-id.h
> + .client_register = bit_reg,
> + .client_unregister = bit_unreg,
> + .name = "PCILynx I2C",
> };

That's not better :) The structure was much more readable before the
change. This is especially apparent with large structures.


Cheers,
Jody