2006-03-30 08:19:27

by Akinobu Mita

[permalink] [raw]
Subject: [patch 0/8] list.h related cleanups

This patch set does:

- Introduce hlist_add_head() and use it
- Use list_add_tail() instead of list_add(A, B.prev)
- Use list_move() instead of the combination of list_del() and list_add()

for readability and micro optimization.
--