2007-11-16 20:06:37

by Mathieu Desnoyers

[permalink] [raw]
Subject: [rfc-patch 0/9] Immediate Values for 2.6.24-rc2-git5

Here are the updated immediate values following comments. The main changes :

- Declares a packed __immediate section to use less space. Declare the "size" as
a char instead of an int.
- Simplified x86 immediate values update, spinning with IRQs disabled instead of
using an lockless update algorithm. Is is simpler, but won't support NMI or
MCE code updates.

This is submitted for another round of comments.

Mathieu

--
Mathieu Desnoyers
Computer Engineering Ph.D. Student, Ecole Polytechnique de Montreal
OpenPGP key fingerprint: 8CD5 52C3 8E3C 4140 715F BA06 3F25 A8FE 3BAE 9A68


2007-11-17 15:49:55

by Borislav Petkov

[permalink] [raw]
Subject: Re: [rfc-patch 0/9] Immediate Values for 2.6.24-rc2-git5

On Fri, Nov 16, 2007 at 03:02:38PM -0500, Mathieu Desnoyers wrote:
Hi,
just a conventions proposal: have you thought of shortening all those
"immediate_foo" prefixes to 'imm_foo', for example? This'll make the
code much more readable, i think.

-
Regards/Gru?,
Boris.

2007-11-18 17:15:30

by Mathieu Desnoyers

[permalink] [raw]
Subject: Re: [rfc-patch 0/9] Immediate Values for 2.6.24-rc2-git5

* Borislav Petkov ([email protected]) wrote:
> On Fri, Nov 16, 2007 at 03:02:38PM -0500, Mathieu Desnoyers wrote:
> Hi,
> just a conventions proposal: have you thought of shortening all those
> "immediate_foo" prefixes to 'imm_foo', for example? This'll make the
> code much more readable, i think.
>

Well, if there are enough supporters of this idea, I'd be happy to
change "immediate_" for "imm_", since it's indeed shorter, easier to
type, and looks better in the code.

Anyone else agrees/disagrees ?

Mathieu

> -
> Regards/Gru?,
> Boris.

--
Mathieu Desnoyers
Computer Engineering Ph.D. Student, Ecole Polytechnique de Montreal
OpenPGP key fingerprint: 8CD5 52C3 8E3C 4140 715F BA06 3F25 A8FE 3BAE 9A68

2007-11-19 15:31:55

by Mathieu Desnoyers

[permalink] [raw]
Subject: Re: [rfc-patch 0/9] Immediate Values for 2.6.24-rc2-git5

* Borislav Petkov ([email protected]) wrote:
> On Fri, Nov 16, 2007 at 03:02:38PM -0500, Mathieu Desnoyers wrote:
> Hi,
> just a conventions proposal: have you thought of shortening all those
> "immediate_foo" prefixes to 'imm_foo', for example? This'll make the
> code much more readable, i think.
>

Hrm, a quick grep in the kernel tree shows me that the imm_* namespace
is already quite clobbered (although I do not detect any imm_read or
imm_set). Although I like the imm_ idea, I would like to make sure we do
not break any existing imm_read or imm_set users.

But since I don't see any, I think it would make sense.

> -
> Regards/Gru?,
> Boris.

--
Mathieu Desnoyers
Computer Engineering Ph.D. Student, Ecole Polytechnique de Montreal
OpenPGP key fingerprint: 8CD5 52C3 8E3C 4140 715F BA06 3F25 A8FE 3BAE 9A68

2007-11-20 05:13:00

by Borislav Petkov

[permalink] [raw]
Subject: Re: [rfc-patch 0/9] Immediate Values for 2.6.24-rc2-git5

On Mon, Nov 19, 2007 at 10:31:39AM -0500, Mathieu Desnoyers wrote:
> * Borislav Petkov ([email protected]) wrote:
> > On Fri, Nov 16, 2007 at 03:02:38PM -0500, Mathieu Desnoyers wrote:
> > Hi,
> > just a conventions proposal: have you thought of shortening all those
> > "immediate_foo" prefixes to 'imm_foo', for example? This'll make the
> > code much more readable, i think.
> >
>
> Hrm, a quick grep in the kernel tree shows me that the imm_* namespace
> is already quite clobbered (although I do not detect any imm_read or
> imm_set).

Right, something called "low level driver for the IOMEGA MatchMaker"
(drivers/scsi/imm.c) has gotten hold of the imm_* prefix already so there might
be a problem later, probably. Nevertheless, you could use the imm_ prefix or
choose some other 3-n letter prefix:

immed_* (3 matches)
imme_* (no matches but dumb)
imd_* (none!)
immv_* (none, v like [v]alues), etc.
...

--
Regards/Gru?,
Boris.

2007-11-20 17:04:22

by Mathieu Desnoyers

[permalink] [raw]
Subject: Re: [rfc-patch 0/9] Immediate Values for 2.6.24-rc2-git5

* Borislav Petkov ([email protected]) wrote:
> On Mon, Nov 19, 2007 at 10:31:39AM -0500, Mathieu Desnoyers wrote:
> > * Borislav Petkov ([email protected]) wrote:
> > > On Fri, Nov 16, 2007 at 03:02:38PM -0500, Mathieu Desnoyers wrote:
> > > Hi,
> > > just a conventions proposal: have you thought of shortening all those
> > > "immediate_foo" prefixes to 'imm_foo', for example? This'll make the
> > > code much more readable, i think.
> > >
> >
> > Hrm, a quick grep in the kernel tree shows me that the imm_* namespace
> > is already quite clobbered (although I do not detect any imm_read or
> > imm_set).
>
> Right, something called "low level driver for the IOMEGA MatchMaker"
> (drivers/scsi/imm.c) has gotten hold of the imm_* prefix already so there might
> be a problem later, probably. Nevertheless, you could use the imm_ prefix or
> choose some other 3-n letter prefix:
>
> immed_* (3 matches)
> imme_* (no matches but dumb)
> imd_* (none!)
> immv_* (none, v like [v]alues), etc.
> ...
>

I'd go for imv_* then, which indeed stands for "IMmediate Values"

> --
> Regards/Gru?,
> Boris.

--
Mathieu Desnoyers
Computer Engineering Ph.D. Student, Ecole Polytechnique de Montreal
OpenPGP key fingerprint: 8CD5 52C3 8E3C 4140 715F BA06 3F25 A8FE 3BAE 9A68