From: audun <[email protected]>
I cleaned up the coding style.
Signed-off-by: Audun Hoem <[email protected]>
---
drivers/staging/frontier/alphatrack.c | 9 ++++++---
1 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/frontier/alphatrack.c b/drivers/staging/frontier/alphatrack.c
index ef7fbf8..9d439fa 100644
--- a/drivers/staging/frontier/alphatrack.c
+++ b/drivers/staging/frontier/alphatrack.c
@@ -88,8 +88,11 @@ MODULE_SUPPORTED_DEVICE("Frontier Designs Alphatrack Control Surface");
static int debug = ALPHATRACK_DEBUG;
/* Use our own dbg macro */
-#define dbg_info(dev, format, arg...) do \
- { if (debug) dev_info(dev , format , ## arg); } while (0)
+#define dbg_info(dev, format, arg...) \
+do {
+ if (debug)
+ dev_info(dev , format , ## arg);
+} while (0)
#define alphatrack_ocmd_info(dev, cmd, format, arg...)
@@ -769,7 +772,7 @@ static int usb_alphatrack_probe(struct usb_interface *intf,
}
dev->write_buffer =
- kmalloc(sizeof(struct alphatrack_ocmd) * true_size, GFP_KERNEL);
+ kmalloc(sizeof(struct alphatrack_ocmd) *true_size, GFP_KERNEL);
if (!dev->write_buffer) {
dev_err(&intf->dev, "Couldn't allocate write_buffer\n");
--
1.7.0.4
On Tue, Nov 02, 2010 at 10:43:44AM +0100, Audun Hoem wrote:
> From: audun <[email protected]>
Minor nit, use your full name here in the From: line.
>
> I cleaned up the coding style.
>
> Signed-off-by: Audun Hoem <[email protected]>
Like you used here, that's the correct thing to put here.
> ---
> drivers/staging/frontier/alphatrack.c | 9 ++++++---
> 1 files changed, 6 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/staging/frontier/alphatrack.c b/drivers/staging/frontier/alphatrack.c
> index ef7fbf8..9d439fa 100644
> --- a/drivers/staging/frontier/alphatrack.c
> +++ b/drivers/staging/frontier/alphatrack.c
> @@ -88,8 +88,11 @@ MODULE_SUPPORTED_DEVICE("Frontier Designs Alphatrack Control Surface");
> static int debug = ALPHATRACK_DEBUG;
>
> /* Use our own dbg macro */
> -#define dbg_info(dev, format, arg...) do \
> - { if (debug) dev_info(dev , format , ## arg); } while (0)
> +#define dbg_info(dev, format, arg...) \
> +do {
> + if (debug)
> + dev_info(dev , format , ## arg);
> +} while (0)
In the future, you can probably just remove this macro and switch the
dev_info() users in the driver to use dev_dbg() as it handles the debug
toggle already. Then you can remove the debug variable as well as the
debugging is handled by the dynamic debug core code in the kernel.
Thanks for the patch, I'll queue it up later and you will get an
automated email when it goes into my tree.
greg k-h
On Tue, Nov 02, 2010 at 10:43:44AM +0100, Audun Hoem wrote:
> From: Audun Hoem <[email protected]>
>
> I cleaned up the coding style.
>
> Signed-off-by: Audun Hoem <[email protected]>
> ---
> drivers/staging/frontier/alphatrack.c | 9 ++++++---
> 1 files changed, 6 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/staging/frontier/alphatrack.c b/drivers/staging/frontier/alphatrack.c
> index ef7fbf8..9d439fa 100644
> --- a/drivers/staging/frontier/alphatrack.c
> +++ b/drivers/staging/frontier/alphatrack.c
> @@ -88,8 +88,11 @@ MODULE_SUPPORTED_DEVICE("Frontier Designs Alphatrack Control Surface");
> static int debug = ALPHATRACK_DEBUG;
>
> /* Use our own dbg macro */
> -#define dbg_info(dev, format, arg...) do \
> - { if (debug) dev_info(dev , format , ## arg); } while (0)
> +#define dbg_info(dev, format, arg...) \
> +do {
> + if (debug)
> + dev_info(dev , format , ## arg);
> +} while (0)
Oops, no, this doesn't work, and it breaks the build. Did you test your
patch after you made it?
(hint, you need to add a few more '\' characters...)
Care to redo this and resend it?
thanks,
greg k-h