2011-03-03 17:52:06

by Andres Salomon

[permalink] [raw]
Subject: [PATCH] mfd-core: rename mfd_shared_cell_{en,dis}able to drop the "shared" part


As requested by Samuel, there's not really any reason to have "shared"
in the name.

This also modifies the only user of the function, as well.

Signed-off-by: Andres Salomon <[email protected]>
---
arch/x86/platform/olpc/olpc-xo1.c | 4 ++--
drivers/mfd/mfd-core.c | 8 ++++----
include/linux/mfd/core.h | 4 ++--
3 files changed, 8 insertions(+), 8 deletions(-)

diff --git a/arch/x86/platform/olpc/olpc-xo1.c b/arch/x86/platform/olpc/olpc-xo1.c
index f415535..9951364 100644
--- a/arch/x86/platform/olpc/olpc-xo1.c
+++ b/arch/x86/platform/olpc/olpc-xo1.c
@@ -63,7 +63,7 @@ static int __devinit olpc_xo1_probe(struct platform_device *pdev)
if (!machine_is_olpc())
return -ENODEV;

- err = mfd_shared_cell_enable(pdev);
+ err = mfd_cell_enable(pdev);
if (err)
return err;

@@ -88,7 +88,7 @@ static int __devinit olpc_xo1_probe(struct platform_device *pdev)

static int __devexit olpc_xo1_remove(struct platform_device *pdev)
{
- mfd_shared_cell_disable(pdev);
+ mfd_cell_disable(pdev);

if (strcmp(pdev->name, "olpc-xo1-pms") == 0)
pms_base = 0;
diff --git a/drivers/mfd/mfd-core.c b/drivers/mfd/mfd-core.c
index bb2264c..79eda02 100644
--- a/drivers/mfd/mfd-core.c
+++ b/drivers/mfd/mfd-core.c
@@ -18,7 +18,7 @@
#include <linux/pm_runtime.h>
#include <linux/slab.h>

-int mfd_shared_cell_enable(struct platform_device *pdev)
+int mfd_cell_enable(struct platform_device *pdev)
{
const struct mfd_cell *cell = mfd_get_cell(pdev);
int err = 0;
@@ -33,9 +33,9 @@ int mfd_shared_cell_enable(struct platform_device *pdev)

return err;
}
-EXPORT_SYMBOL(mfd_shared_cell_enable);
+EXPORT_SYMBOL(mfd_cell_enable);

-int mfd_shared_cell_disable(struct platform_device *pdev)
+int mfd_cell_disable(struct platform_device *pdev)
{
const struct mfd_cell *cell = mfd_get_cell(pdev);
int err = 0;
@@ -53,7 +53,7 @@ int mfd_shared_cell_disable(struct platform_device *pdev)

return err;
}
-EXPORT_SYMBOL(mfd_shared_cell_disable);
+EXPORT_SYMBOL(mfd_cell_disable);

static int mfd_add_device(struct device *parent, int id,
const struct mfd_cell *cell,
diff --git a/include/linux/mfd/core.h b/include/linux/mfd/core.h
index ed99704..1408bf8 100644
--- a/include/linux/mfd/core.h
+++ b/include/linux/mfd/core.h
@@ -59,8 +59,8 @@ struct mfd_cell {
* being called only when a device is first being enabled or no other
* clients are making use of it.
*/
-extern int mfd_shared_cell_enable(struct platform_device *pdev);
-extern int mfd_shared_cell_disable(struct platform_device *pdev);
+extern int mfd_cell_enable(struct platform_device *pdev);
+extern int mfd_cell_disable(struct platform_device *pdev);

/*
* Given a platform device that's been created by mfd_add_devices(), fetch
--
1.7.2.3


2011-03-11 20:37:31

by Samuel Ortiz

[permalink] [raw]
Subject: Re: [PATCH] mfd-core: rename mfd_shared_cell_{en,dis}able to drop the "shared" part

Hi Andres,

On Thu, Mar 03, 2011 at 09:51:58AM -0800, Andres Salomon wrote:
>
> As requested by Samuel, there's not really any reason to have "shared"
> in the name.
>
> This also modifies the only user of the function, as well.
Thanks for following up on this one, patch applied now.

Cheers,
Samuel.

--
Intel Open Source Technology Centre
http://oss.intel.com/