2013-10-07 17:49:54

by Brian Norris

[permalink] [raw]
Subject: Re: [PATCH] mtd: phram: Make phram 64-bit compatible

+ LKML

On Wed, Oct 02, 2013 at 06:42:29PM +0200, Alexander Sverdlin wrote:
> mtd: phram: Make phram 64-bit compatible
>
> phram was 32-bit limited by design. Machines are growing up, but phram
> module is still useful. Update it. The patch is bigger than minimum,
> because simple_strtoul() is obsolete.
>
> Tested on MIPS64 and compile-tested for PPC (32 bit).
>
> Signed-off-by: Alexander Sverdlin <[email protected]>

Pushed to l2-mtd.git. Thanks!

Can this driver use the library memparse() function instead of
open-coding it?

[To answer myself:] I noticed this in drivers/mtd/devices/phram.c, which
prevents us from using memparse():

/* By dwmw2 editorial decree, "ki", "Mi" or "Gi" are to be used. */

Are we (MTD) holding a revolutionary position against the standard
kernel libraries, which recognize [KkMmGg] prefixes, but not [kMG]i
prefixes? Should we extend memparse() to accept either form? Or would
doing so simply pollute the library and not really satisfy anyone?

[After more research:] It looks like this topic may be the subject of
some long-past flame wars. If I am digging up past demons, then I'd
prefer to let sleeping Balrogs lie.

Brian


2013-10-07 18:13:42

by Jörn Engel

[permalink] [raw]
Subject: Re: [PATCH] mtd: phram: Make phram 64-bit compatible

On Mon, 7 October 2013 10:49:43 -0700, Brian Norris wrote:
>
> [After more research:] It looks like this topic may be the subject of
> some long-past flame wars. If I am digging up past demons, then I'd
> prefer to let sleeping Balrogs lie.

Most of the time it is obvious from context whether you want base-1000
or base-1024 numbers. So in the common case the extra letter is plain
annoying. In less common cases it matters a lot and lack of the extra
letter is rather irritating.

One possible solution would be to have three suffixes. Ki for
base-1024, Kd for base-1000 and K for "I don't care, you decide for
me". But I am sure that would simply cause another round of
flamewars.

It is not a hard technical problem. As a result, noone on this list
has the required expertise to solve it.

Jörn

--
Money can buy bandwidth, but latency is forever.
-- John R. Mashey

2013-10-08 07:47:26

by Alexander Sverdlin

[permalink] [raw]
Subject: Re: [PATCH] mtd: phram: Make phram 64-bit compatible

Hi!

On 10/07/2013 07:49 PM, ext Brian Norris wrote:
> Are we (MTD) holding a revolutionary position against the standard
> kernel libraries, which recognize [KkMmGg] prefixes, but not [kMG]i
> prefixes? Should we extend memparse() to accept either form? Or would
> doing so simply pollute the library and not really satisfy anyone?

I was also irritated re-inventing the wheel here, but the problem is --
millions of people out there have their startup scripts and uboot environments
for phram, who expect this just to work with the next kernel upgrade...

--
Best regards,
Alexander Sverdlin.

2013-10-08 16:36:29

by Geert Uytterhoeven

[permalink] [raw]
Subject: Re: [PATCH] mtd: phram: Make phram 64-bit compatible

On Mon, Oct 7, 2013 at 6:53 PM, Jörn Engel <[email protected]> wrote:
> One possible solution would be to have three suffixes. Ki for
> base-1024, Kd for base-1000 and K for "I don't care, you decide for
> me". But I am sure that would simply cause another round of
> flamewars.

Indeed. Why deviate from SI with "Kd" (a new invention)??
That should just be "k".

Gr{oetje,eeting}s,

Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email protected]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds