2019-09-19 05:23:47

by Wei Yang

[permalink] [raw]
Subject: [PATCH 1/2] x86/mm: consolidate bad_area handling to the end

There are totally 7 bad_area[_nosemaphore] error branch in
do_user_addr_fault().

Consolidate all these handling to the end to make the code a little
neat.

BTW, after doing so, function bad_area is not used any more. Remove it.

Signed-off-by: Wei Yang <[email protected]>
---
arch/x86/mm/fault.c | 44 ++++++++++++++++----------------------------
1 file changed, 16 insertions(+), 28 deletions(-)

diff --git a/arch/x86/mm/fault.c b/arch/x86/mm/fault.c
index 9ceacd1156db..9d18b73b5f77 100644
--- a/arch/x86/mm/fault.c
+++ b/arch/x86/mm/fault.c
@@ -933,12 +933,6 @@ __bad_area(struct pt_regs *regs, unsigned long error_code,
__bad_area_nosemaphore(regs, error_code, address, pkey, si_code);
}

-static noinline void
-bad_area(struct pt_regs *regs, unsigned long error_code, unsigned long address)
-{
- __bad_area(regs, error_code, address, 0, SEGV_MAPERR);
-}
-
static inline bool bad_area_access_from_pkeys(unsigned long error_code,
struct vm_area_struct *vma)
{
@@ -1313,19 +1307,14 @@ void do_user_addr_fault(struct pt_regs *regs,
if (unlikely(cpu_feature_enabled(X86_FEATURE_SMAP) &&
!(hw_error_code & X86_PF_USER) &&
!(regs->flags & X86_EFLAGS_AC)))
- {
- bad_area_nosemaphore(regs, hw_error_code, address);
- return;
- }
+ goto bad_area_nosem;

/*
* If we're in an interrupt, have no user context or are running
* in a region with pagefaults disabled then we must not take the fault
*/
- if (unlikely(faulthandler_disabled() || !mm)) {
- bad_area_nosemaphore(regs, hw_error_code, address);
- return;
- }
+ if (unlikely(faulthandler_disabled() || !mm))
+ goto bad_area_nosem;

/*
* It's safe to allow irq's after cr2 has been saved and the
@@ -1385,8 +1374,7 @@ void do_user_addr_fault(struct pt_regs *regs,
* Fault from code in kernel from
* which we do not expect faults.
*/
- bad_area_nosemaphore(regs, hw_error_code, address);
- return;
+ goto bad_area_nosem;
}
retry:
down_read(&mm->mmap_sem);
@@ -1400,20 +1388,14 @@ void do_user_addr_fault(struct pt_regs *regs,
}

vma = find_vma(mm, address);
- if (unlikely(!vma)) {
- bad_area(regs, hw_error_code, address);
- return;
- }
+ if (unlikely(!vma))
+ goto bad_area;
if (likely(vma->vm_start <= address))
goto good_area;
- if (unlikely(!(vma->vm_flags & VM_GROWSDOWN))) {
- bad_area(regs, hw_error_code, address);
- return;
- }
- if (unlikely(expand_stack(vma, address))) {
- bad_area(regs, hw_error_code, address);
- return;
- }
+ if (unlikely(!(vma->vm_flags & VM_GROWSDOWN)))
+ goto bad_area;
+ if (unlikely(expand_stack(vma, address)))
+ goto bad_area;

/*
* Ok, we have a good vm_area for this memory access, so
@@ -1483,6 +1465,12 @@ void do_user_addr_fault(struct pt_regs *regs,
}

check_v8086_mode(regs, address, tsk);
+ return;
+
+bad_area:
+ up_read(&mm->mmap_sem);
+bad_area_nosem:
+ bad_area_nosemaphore(regs, hw_error_code, address);
}
NOKPROBE_SYMBOL(do_user_addr_fault);

--
2.17.1


2019-09-19 06:35:06

by Wei Yang

[permalink] [raw]
Subject: [PATCH 2/2] x86/mm: replace a goto by merging two if clause

There is only one place to use good_area jump, which could be reduced by
merging the following two if clause.

Signed-off-by: Wei Yang <[email protected]>
---
arch/x86/mm/fault.c | 11 +++++------
1 file changed, 5 insertions(+), 6 deletions(-)

diff --git a/arch/x86/mm/fault.c b/arch/x86/mm/fault.c
index 9d18b73b5f77..72ce6c69e195 100644
--- a/arch/x86/mm/fault.c
+++ b/arch/x86/mm/fault.c
@@ -1390,18 +1390,17 @@ void do_user_addr_fault(struct pt_regs *regs,
vma = find_vma(mm, address);
if (unlikely(!vma))
goto bad_area;
- if (likely(vma->vm_start <= address))
- goto good_area;
- if (unlikely(!(vma->vm_flags & VM_GROWSDOWN)))
- goto bad_area;
- if (unlikely(expand_stack(vma, address)))
+ if (likely(vma->vm_start <= address)) {
+ /* good area, do nothing */
+ } else if (unlikely(!(vma->vm_flags & VM_GROWSDOWN)) ||
+ unlikely(expand_stack(vma, address))) {
goto bad_area;
+ }

/*
* Ok, we have a good vm_area for this memory access, so
* we can handle it..
*/
-good_area:
if (unlikely(access_error(hw_error_code, vma))) {
bad_area_access_error(regs, hw_error_code, address, vma);
return;
--
2.17.1

2019-09-24 16:57:47

by Peter Zijlstra

[permalink] [raw]
Subject: Re: [PATCH 2/2] x86/mm: replace a goto by merging two if clause

On Thu, Sep 19, 2019 at 10:08:44AM +0800, Wei Yang wrote:
> There is only one place to use good_area jump, which could be reduced by
> merging the following two if clause.
>
> Signed-off-by: Wei Yang <[email protected]>
> ---
> arch/x86/mm/fault.c | 11 +++++------
> 1 file changed, 5 insertions(+), 6 deletions(-)
>
> diff --git a/arch/x86/mm/fault.c b/arch/x86/mm/fault.c
> index 9d18b73b5f77..72ce6c69e195 100644
> --- a/arch/x86/mm/fault.c
> +++ b/arch/x86/mm/fault.c
> @@ -1390,18 +1390,17 @@ void do_user_addr_fault(struct pt_regs *regs,
> vma = find_vma(mm, address);
> if (unlikely(!vma))
> goto bad_area;
> - if (likely(vma->vm_start <= address))
> - goto good_area;
> - if (unlikely(!(vma->vm_flags & VM_GROWSDOWN)))
> - goto bad_area;
> - if (unlikely(expand_stack(vma, address)))
> + if (likely(vma->vm_start <= address)) {
> + /* good area, do nothing */
> + } else if (unlikely(!(vma->vm_flags & VM_GROWSDOWN)) ||
> + unlikely(expand_stack(vma, address))) {
> goto bad_area;
> + }
>
> /*
> * Ok, we have a good vm_area for this memory access, so
> * we can handle it..
> */
> -good_area:
> if (unlikely(access_error(hw_error_code, vma))) {
> bad_area_access_error(regs, hw_error_code, address, vma);
> return;

I find the old code far easier to read... is there any actual reason to
do this?

2019-09-26 07:53:56

by Wei Yang

[permalink] [raw]
Subject: Re: [PATCH 2/2] x86/mm: replace a goto by merging two if clause

On Mon, Sep 23, 2019 at 11:22:31AM +0200, Peter Zijlstra wrote:
>On Thu, Sep 19, 2019 at 10:08:44AM +0800, Wei Yang wrote:
>> There is only one place to use good_area jump, which could be reduced by
>> merging the following two if clause.
>>
>> Signed-off-by: Wei Yang <[email protected]>
>> ---
>> arch/x86/mm/fault.c | 11 +++++------
>> 1 file changed, 5 insertions(+), 6 deletions(-)
>>
>> diff --git a/arch/x86/mm/fault.c b/arch/x86/mm/fault.c
>> index 9d18b73b5f77..72ce6c69e195 100644
>> --- a/arch/x86/mm/fault.c
>> +++ b/arch/x86/mm/fault.c
>> @@ -1390,18 +1390,17 @@ void do_user_addr_fault(struct pt_regs *regs,
>> vma = find_vma(mm, address);
>> if (unlikely(!vma))
>> goto bad_area;
>> - if (likely(vma->vm_start <= address))
>> - goto good_area;
>> - if (unlikely(!(vma->vm_flags & VM_GROWSDOWN)))
>> - goto bad_area;
>> - if (unlikely(expand_stack(vma, address)))
>> + if (likely(vma->vm_start <= address)) {
>> + /* good area, do nothing */
>> + } else if (unlikely(!(vma->vm_flags & VM_GROWSDOWN)) ||
>> + unlikely(expand_stack(vma, address))) {
>> goto bad_area;
>> + }
>>
>> /*
>> * Ok, we have a good vm_area for this memory access, so
>> * we can handle it..
>> */
>> -good_area:
>> if (unlikely(access_error(hw_error_code, vma))) {
>> bad_area_access_error(regs, hw_error_code, address, vma);
>> return;
>
>I find the old code far easier to read... is there any actual reason to
>do this?

No, just want to make it easy to read.

--
Wei Yang
Help you, Help me

2019-10-01 11:47:48

by Wei Yang

[permalink] [raw]
Subject: Re: [PATCH 2/2] x86/mm: replace a goto by merging two if clause

On Mon, Sep 23, 2019 at 11:22:31AM +0200, Peter Zijlstra wrote:
>On Thu, Sep 19, 2019 at 10:08:44AM +0800, Wei Yang wrote:
>> There is only one place to use good_area jump, which could be reduced by
>> merging the following two if clause.
>>
>> Signed-off-by: Wei Yang <[email protected]>
>> ---
>> arch/x86/mm/fault.c | 11 +++++------
>> 1 file changed, 5 insertions(+), 6 deletions(-)
>>
>> diff --git a/arch/x86/mm/fault.c b/arch/x86/mm/fault.c
>> index 9d18b73b5f77..72ce6c69e195 100644
>> --- a/arch/x86/mm/fault.c
>> +++ b/arch/x86/mm/fault.c
>> @@ -1390,18 +1390,17 @@ void do_user_addr_fault(struct pt_regs *regs,
>> vma = find_vma(mm, address);
>> if (unlikely(!vma))
>> goto bad_area;
>> - if (likely(vma->vm_start <= address))
>> - goto good_area;
>> - if (unlikely(!(vma->vm_flags & VM_GROWSDOWN)))
>> - goto bad_area;
>> - if (unlikely(expand_stack(vma, address)))
>> + if (likely(vma->vm_start <= address)) {
>> + /* good area, do nothing */
>> + } else if (unlikely(!(vma->vm_flags & VM_GROWSDOWN)) ||
>> + unlikely(expand_stack(vma, address))) {
>> goto bad_area;
>> + }
>>
>> /*
>> * Ok, we have a good vm_area for this memory access, so
>> * we can handle it..
>> */
>> -good_area:
>> if (unlikely(access_error(hw_error_code, vma))) {
>> bad_area_access_error(regs, hw_error_code, address, vma);
>> return;
>
>I find the old code far easier to read... is there any actual reason to
>do this?

Hi, Peter,

Do you have some comment for the Patch 1?

--
Wei Yang
Help you, Help me