2020-09-17 07:28:58

by 刘邵华BTD

[permalink] [raw]
Subject: [PATCH] riscv: fix pfn_to_virt err in do_page_fault().

The argument to pfn_to_virt() should be pfn not the value of CSR_SATP.

Signed-off-by: liush <[email protected]>
---
arch/riscv/mm/fault.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/riscv/mm/fault.c b/arch/riscv/mm/fault.c
index 716d64e..9b4e088 100644
--- a/arch/riscv/mm/fault.c
+++ b/arch/riscv/mm/fault.c
@@ -212,7 +212,7 @@ asmlinkage void do_page_fault(struct pt_regs *regs)
* of a task switch.
*/
index = pgd_index(addr);
- pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP)) + index;
+ pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP) & SATP_PPN) + index;
pgd_k = init_mm.pgd + index;

if (!pgd_present(*pgd_k))
--
2.7.4


2020-09-17 08:03:47

by Anup Patel

[permalink] [raw]
Subject: Re: [PATCH] riscv: fix pfn_to_virt err in do_page_fault().

On Thu, Sep 17, 2020 at 12:56 PM liush <[email protected]> wrote:
>
> The argument to pfn_to_virt() should be pfn not the value of CSR_SATP.
>
> Signed-off-by: liush <[email protected]>
> ---
> arch/riscv/mm/fault.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/riscv/mm/fault.c b/arch/riscv/mm/fault.c
> index 716d64e..9b4e088 100644
> --- a/arch/riscv/mm/fault.c
> +++ b/arch/riscv/mm/fault.c
> @@ -212,7 +212,7 @@ asmlinkage void do_page_fault(struct pt_regs *regs)
> * of a task switch.
> */
> index = pgd_index(addr);
> - pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP)) + index;
> + pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP) & SATP_PPN) + index;
> pgd_k = init_mm.pgd + index;
>
> if (!pgd_present(*pgd_k))
> --
> 2.7.4
>

Looks good to me.

Reviewed-by: Anup Patel <[email protected]>

Regards,
Anup

2020-09-17 15:32:07

by Christoph Hellwig

[permalink] [raw]
Subject: Re: [PATCH] riscv: fix pfn_to_virt err in do_page_fault().

On Thu, Sep 17, 2020 at 03:25:49PM +0800, liush wrote:
> The argument to pfn_to_virt() should be pfn not the value of CSR_SATP.
>
> Signed-off-by: liush <[email protected]>
> ---
> arch/riscv/mm/fault.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/riscv/mm/fault.c b/arch/riscv/mm/fault.c
> index 716d64e..9b4e088 100644
> --- a/arch/riscv/mm/fault.c
> +++ b/arch/riscv/mm/fault.c
> @@ -212,7 +212,7 @@ asmlinkage void do_page_fault(struct pt_regs *regs)
> * of a task switch.
> */
> index = pgd_index(addr);
> - pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP)) + index;
> + pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP) & SATP_PPN) + index;

This adds a crazy long line. One nice way to clean this up would be to
add a local pfn variable, as it would also make the code more readable.

2020-09-18 08:18:23

by 刘邵华BTD

[permalink] [raw]
Subject: 回复:[PATCH] riscv: fix pfn_to_virt err in do_page _fault().

Hi Christoph,
> On Thu, Sep 17, 2020 at 03:25:49PM +0800, liush wrote:
> > The argument to pfn_to_virt() should be pfn not the value of CSR_SATP.
> >
> > Signed-off-by: liush <[email protected]>
> > ---
> > arch/riscv/mm/fault.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/arch/riscv/mm/fault.c b/arch/riscv/mm/fault.c
> > index 716d64e..9b4e088 100644
> > --- a/arch/riscv/mm/fault.c
> > +++ b/arch/riscv/mm/fault.c
> > @@ -212,7 +212,7 @@ asmlinkage void do_page_fault(struct pt_regs *regs)
> > * of a task switch.
> > */
> > index = pgd_index(addr);
> > - pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP)) + index;
> > + pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP) & SATP_PPN) + index;

> This adds a crazy long line. One nice way to clean this up would be to
> add a local pfn variable, as it would also make the code more readable.

Thanks, i'll modify it in next revision

2020-09-28 09:35:48

by fuyao

[permalink] [raw]
Subject: Re: 回复:[PATCH ] riscv: fix pfn_to_virt err in do_page_fault().

On Fri, Sep 18, 2020 at 03:43:39PM +0800, 刘邵华BTD wrote:
> Hi Christoph,
> > On Thu, Sep 17, 2020 at 03:25:49PM +0800, liush wrote:
> > > The argument to pfn_to_virt() should be pfn not the value of CSR_SATP.
> > >
> > > Signed-off-by: liush <[email protected]>
> > > ---
> > > arch/riscv/mm/fault.c | 2 +-
> > > 1 file changed, 1 insertion(+), 1 deletion(-)
> > >
> > > diff --git a/arch/riscv/mm/fault.c b/arch/riscv/mm/fault.c
> > > index 716d64e..9b4e088 100644
> > > --- a/arch/riscv/mm/fault.c
> > > +++ b/arch/riscv/mm/fault.c
> > > @@ -212,7 +212,7 @@ asmlinkage void do_page_fault(struct pt_regs *regs)
> > > * of a task switch.
> > > */
> > > index = pgd_index(addr);
> > > - pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP)) + index;
> > > + pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP) & SATP_PPN) + index;
>
> > This adds a crazy long line. One nice way to clean this up would be to
> > add a local pfn variable, as it would also make the code more readable.
>
> Thanks, i'll modify it in next revision

Tested-by: [email protected]

--
<http://www.allwinnertech.com> Allwinnertech Technology