2021-10-11 13:34:43

by Len Baker

[permalink] [raw]
Subject: [PATCH] virt: acrn: Prefer array_syze and struct_size over open coded arithmetic

As noted in the "Deprecated Interfaces, Language Features, Attributes,
and Conventions" documentation [1], size calculations (especially
multiplication) should not be performed in memory allocator (or similar)
function arguments due to the risk of them overflowing. This could lead
to values wrapping around and a smaller allocation being made than the
caller was expecting. Using those allocations could lead to linear
overflows of heap memory and other misbehaviors.

So, use the array_size() helper to do the arithmetic instead of the
argument "count * size" in the vzalloc() function.

Also, take the opportunity to add a flexible array member of struct
vm_memory_region_op to the vm_memory_region_batch structure. And then,
change the code accordingly and use the struct_size() helper to do the
arithmetic instead of the argument "size + size * count" in the kzalloc
function.

This code was detected with the help of Coccinelle and audited and fixed
manually.

[1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments

Signed-off-by: Len Baker <[email protected]>
---
drivers/virt/acrn/acrn_drv.h | 10 ++++++----
drivers/virt/acrn/mm.c | 9 ++++-----
2 files changed, 10 insertions(+), 9 deletions(-)

diff --git a/drivers/virt/acrn/acrn_drv.h b/drivers/virt/acrn/acrn_drv.h
index 1be54efa666c..fcc2e3e5232a 100644
--- a/drivers/virt/acrn/acrn_drv.h
+++ b/drivers/virt/acrn/acrn_drv.h
@@ -48,6 +48,7 @@ struct vm_memory_region_op {
* @reserved: Reserved.
* @regions_num: The number of vm_memory_region_op.
* @regions_gpa: Physical address of a vm_memory_region_op array.
+ * @regions_op: Flexible array of vm_memory_region_op.
*
* HC_VM_SET_MEMORY_REGIONS uses this structure to manage EPT mappings of
* multiple memory regions of a User VM. A &struct vm_memory_region_batch
@@ -55,10 +56,11 @@ struct vm_memory_region_op {
* ACRN Hypervisor.
*/
struct vm_memory_region_batch {
- u16 vmid;
- u16 reserved[3];
- u32 regions_num;
- u64 regions_gpa;
+ u16 vmid;
+ u16 reserved[3];
+ u32 regions_num;
+ u64 regions_gpa;
+ struct vm_memory_region_op regions_op[];
};

/**
diff --git a/drivers/virt/acrn/mm.c b/drivers/virt/acrn/mm.c
index c4f2e15c8a2b..a881742cd48d 100644
--- a/drivers/virt/acrn/mm.c
+++ b/drivers/virt/acrn/mm.c
@@ -168,7 +168,7 @@ int acrn_vm_ram_map(struct acrn_vm *vm, struct acrn_vm_memmap *memmap)

/* Get the page number of the map region */
nr_pages = memmap->len >> PAGE_SHIFT;
- pages = vzalloc(nr_pages * sizeof(struct page *));
+ pages = vzalloc(array_size(nr_pages, sizeof(struct page *)));
if (!pages)
return -ENOMEM;

@@ -220,16 +220,15 @@ int acrn_vm_ram_map(struct acrn_vm *vm, struct acrn_vm_memmap *memmap)
}

/* Prepare the vm_memory_region_batch */
- regions_info = kzalloc(sizeof(*regions_info) +
- sizeof(*vm_region) * nr_regions,
- GFP_KERNEL);
+ regions_info = kzalloc(struct_size(regions_info, regions_op,
+ nr_regions), GFP_KERNEL);
if (!regions_info) {
ret = -ENOMEM;
goto unmap_kernel_map;
}

/* Fill each vm_memory_region_op */
- vm_region = (struct vm_memory_region_op *)(regions_info + 1);
+ vm_region = regions_info->regions_op;
regions_info->vmid = vm->vmid;
regions_info->regions_num = nr_regions;
regions_info->regions_gpa = virt_to_phys(vm_region);
--
2.25.1


2021-10-12 01:37:40

by Fei Li

[permalink] [raw]
Subject: Re: [PATCH] virt: acrn: Prefer array_syze and struct_size over open coded arithmetic

On Mon, Oct 11, 2021 at 12:39:02PM +0200, Len Baker wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, use the array_size() helper to do the arithmetic instead of the
> argument "count * size" in the vzalloc() function.
>
> Also, take the opportunity to add a flexible array member of struct
> vm_memory_region_op to the vm_memory_region_batch structure. And then,
> change the code accordingly and use the struct_size() helper to do the
> arithmetic instead of the argument "size + size * count" in the kzalloc
> function.
>
> This code was detected with the help of Coccinelle and audited and fixed
> manually.
>
> [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Len Baker <[email protected]>

Hi Baker

Thanks for helping us to fix this issue. This patch looks good to me.
Please add Signed-off-by: Fei Li <[email protected]>.
Only two minor comments.


> ---
> drivers/virt/acrn/acrn_drv.h | 10 ++++++----
> drivers/virt/acrn/mm.c | 9 ++++-----
> 2 files changed, 10 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/virt/acrn/acrn_drv.h b/drivers/virt/acrn/acrn_drv.h
> index 1be54efa666c..fcc2e3e5232a 100644
> --- a/drivers/virt/acrn/acrn_drv.h
> +++ b/drivers/virt/acrn/acrn_drv.h
> @@ -48,6 +48,7 @@ struct vm_memory_region_op {
> * @reserved: Reserved.
> * @regions_num: The number of vm_memory_region_op.
> * @regions_gpa: Physical address of a vm_memory_region_op array.
> + * @regions_op: Flexible array of vm_memory_region_op.
One Tab please.
> *
> * HC_VM_SET_MEMORY_REGIONS uses this structure to manage EPT mappings of
> * multiple memory regions of a User VM. A &struct vm_memory_region_batch
> @@ -55,10 +56,11 @@ struct vm_memory_region_op {
> * ACRN Hypervisor.
> */
> struct vm_memory_region_batch {
> - u16 vmid;
> - u16 reserved[3];
> - u32 regions_num;
> - u64 regions_gpa;
> + u16 vmid;
> + u16 reserved[3];
> + u32 regions_num;
> + u64 regions_gpa;
> + struct vm_memory_region_op regions_op[];
Please use Whitespace instead of Tab.
> };
>
> /**
> diff --git a/drivers/virt/acrn/mm.c b/drivers/virt/acrn/mm.c
> index c4f2e15c8a2b..a881742cd48d 100644
> --- a/drivers/virt/acrn/mm.c
> +++ b/drivers/virt/acrn/mm.c
> @@ -168,7 +168,7 @@ int acrn_vm_ram_map(struct acrn_vm *vm, struct acrn_vm_memmap *memmap)
>
> /* Get the page number of the map region */
> nr_pages = memmap->len >> PAGE_SHIFT;
> - pages = vzalloc(nr_pages * sizeof(struct page *));
> + pages = vzalloc(array_size(nr_pages, sizeof(struct page *)));
> if (!pages)
> return -ENOMEM;
>
> @@ -220,16 +220,15 @@ int acrn_vm_ram_map(struct acrn_vm *vm, struct acrn_vm_memmap *memmap)
> }
>
> /* Prepare the vm_memory_region_batch */
> - regions_info = kzalloc(sizeof(*regions_info) +
> - sizeof(*vm_region) * nr_regions,
> - GFP_KERNEL);
> + regions_info = kzalloc(struct_size(regions_info, regions_op,
> + nr_regions), GFP_KERNEL);
> if (!regions_info) {
> ret = -ENOMEM;
> goto unmap_kernel_map;
> }
>
> /* Fill each vm_memory_region_op */
> - vm_region = (struct vm_memory_region_op *)(regions_info + 1);
> + vm_region = regions_info->regions_op;
> regions_info->vmid = vm->vmid;
> regions_info->regions_num = nr_regions;
> regions_info->regions_gpa = virt_to_phys(vm_region);
> --
> 2.25.1
>

2021-10-13 07:31:33

by Kees Cook

[permalink] [raw]
Subject: Re: [PATCH] virt: acrn: Prefer array_syze and struct_size over open coded arithmetic

On Tue, Oct 12, 2021 at 09:34:29AM +0800, Li Fei1 wrote:
> On Mon, Oct 11, 2021 at 12:39:02PM +0200, Len Baker wrote:
> > As noted in the "Deprecated Interfaces, Language Features, Attributes,
> > and Conventions" documentation [1], size calculations (especially
> > multiplication) should not be performed in memory allocator (or similar)
> > function arguments due to the risk of them overflowing. This could lead
> > to values wrapping around and a smaller allocation being made than the
> > caller was expecting. Using those allocations could lead to linear
> > overflows of heap memory and other misbehaviors.
> >
> > So, use the array_size() helper to do the arithmetic instead of the
> > argument "count * size" in the vzalloc() function.
> >
> > Also, take the opportunity to add a flexible array member of struct
> > vm_memory_region_op to the vm_memory_region_batch structure. And then,
> > change the code accordingly and use the struct_size() helper to do the
> > arithmetic instead of the argument "size + size * count" in the kzalloc
> > function.
> >
> > This code was detected with the help of Coccinelle and audited and fixed
> > manually.
> >
> > [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
> >
> > Signed-off-by: Len Baker <[email protected]>
>
> Hi Baker
>
> Thanks for helping us to fix this issue. This patch looks good to me.
> Please add Signed-off-by: Fei Li <[email protected]>.
> Only two minor comments.

For v2, please fix the Subject typo, too. :) "syze" -> "size".

-Kees

--
Kees Cook

2021-10-16 23:17:17

by Len Baker

[permalink] [raw]
Subject: Re: [PATCH] virt: acrn: Prefer array_syze and struct_size over open coded arithmetic

Hi Li,

On Tue, Oct 12, 2021 at 09:34:29AM +0800, Li Fei1 wrote:
> On Mon, Oct 11, 2021 at 12:39:02PM +0200, Len Baker wrote:
> > As noted in the "Deprecated Interfaces, Language Features, Attributes,
> > and Conventions" documentation [1], size calculations (especially
> > multiplication) should not be performed in memory allocator (or similar)
> > function arguments due to the risk of them overflowing. This could lead
> > to values wrapping around and a smaller allocation being made than the
> > caller was expecting. Using those allocations could lead to linear
> > overflows of heap memory and other misbehaviors.
> >
> > So, use the array_size() helper to do the arithmetic instead of the
> > argument "count * size" in the vzalloc() function.
> >
> > Also, take the opportunity to add a flexible array member of struct
> > vm_memory_region_op to the vm_memory_region_batch structure. And then,
> > change the code accordingly and use the struct_size() helper to do the
> > arithmetic instead of the argument "size + size * count" in the kzalloc
> > function.
> >
> > This code was detected with the help of Coccinelle and audited and fixed
> > manually.
> >
> > [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
> >
> > Signed-off-by: Len Baker <[email protected]>
>
> Hi Baker
>
> Thanks for helping us to fix this issue. This patch looks good to me.
> Please add Signed-off-by: Fei Li <[email protected]>.

I can't add the "Signed-off-by" tag by myself. However, if you are in the
path to forward the patch to the mainline (maintainer's tree), you can
add by yourself the "Signed-off-by" tag before send a "pull" to Linus.
See [1] for more information.

[1] https://www.kernel.org/doc/html/latest/process/submitting-patches.html#sign-your-work-the-developer-s-certificate-of-origin

If you don't have a maintainer's tree, you can give (as a maintainer) an
"Acked-by" tag that then I can add to the patch. More info in [2].

[2] https://www.kernel.org/doc/html/latest/process/submitting-patches.html#when-to-use-acked-by-cc-and-co-developed-by

> Only two minor comments.
>
>
> > ---
> > drivers/virt/acrn/acrn_drv.h | 10 ++++++----
> > drivers/virt/acrn/mm.c | 9 ++++-----
> > 2 files changed, 10 insertions(+), 9 deletions(-)
> >
> > diff --git a/drivers/virt/acrn/acrn_drv.h b/drivers/virt/acrn/acrn_drv.h
> > index 1be54efa666c..fcc2e3e5232a 100644
> > --- a/drivers/virt/acrn/acrn_drv.h
> > +++ b/drivers/virt/acrn/acrn_drv.h
> > @@ -48,6 +48,7 @@ struct vm_memory_region_op {
> > * @reserved: Reserved.
> > * @regions_num: The number of vm_memory_region_op.
> > * @regions_gpa: Physical address of a vm_memory_region_op array.
> > + * @regions_op: Flexible array of vm_memory_region_op.
> One Tab please.

Sorry, but if I use only one tab, the parameters description are not all
aligned.

> > *
> > * HC_VM_SET_MEMORY_REGIONS uses this structure to manage EPT mappings of
> > * multiple memory regions of a User VM. A &struct vm_memory_region_batch
> > @@ -55,10 +56,11 @@ struct vm_memory_region_op {
> > * ACRN Hypervisor.
> > */
> > struct vm_memory_region_batch {
> > - u16 vmid;
> > - u16 reserved[3];
> > - u32 regions_num;
> > - u64 regions_gpa;
> > + u16 vmid;
> > + u16 reserved[3];
> > + u32 regions_num;
> > + u64 regions_gpa;
> > + struct vm_memory_region_op regions_op[];
> Please use Whitespace instead of Tab.

Sorry, but I don't understand. Do you prefer something like?:

diff --git a/drivers/virt/acrn/acrn_drv.h b/drivers/virt/acrn/acrn_drv.h
index fcc2e3e5232a..5663c17ad37c 100644
--- a/drivers/virt/acrn/acrn_drv.h
+++ b/drivers/virt/acrn/acrn_drv.h
@@ -56,11 +56,11 @@ struct vm_memory_region_op {
* ACRN Hypervisor.
*/
struct vm_memory_region_batch {
- u16 vmid;
- u16 reserved[3];
- u32 regions_num;
- u64 regions_gpa;
- struct vm_memory_region_op regions_op[];
+ u16 vmid;
+ u16 reserved[3];
+ u32 regions_num;
+ u64 regions_gpa;
+ struct vm_memory_region_op regions_op[];
};

/**

Moreover, for the v2 I will fix the typo "syze->size" in the subject as
suggested Kees ;)

Regards,
Len

2021-10-18 03:48:26

by Fei Li

[permalink] [raw]
Subject: Re: [PATCH] virt: acrn: Prefer array_syze and struct_size over open coded arithmetic

On Fri, Oct 15, 2021 at 05:52:48PM +0200, Len Baker wrote:
> Hi Li,
>
> On Tue, Oct 12, 2021 at 09:34:29AM +0800, Li Fei1 wrote:
> > On Mon, Oct 11, 2021 at 12:39:02PM +0200, Len Baker wrote:
> > > As noted in the "Deprecated Interfaces, Language Features, Attributes,
> > > and Conventions" documentation [1], size calculations (especially
> > > multiplication) should not be performed in memory allocator (or similar)
> > > function arguments due to the risk of them overflowing. This could lead
> > > to values wrapping around and a smaller allocation being made than the
> > > caller was expecting. Using those allocations could lead to linear
> > > overflows of heap memory and other misbehaviors.
> > >
> > > So, use the array_size() helper to do the arithmetic instead of the
> > > argument "count * size" in the vzalloc() function.
> > >
> > > Also, take the opportunity to add a flexible array member of struct
> > > vm_memory_region_op to the vm_memory_region_batch structure. And then,
> > > change the code accordingly and use the struct_size() helper to do the
> > > arithmetic instead of the argument "size + size * count" in the kzalloc
> > > function.
> > >
> > > This code was detected with the help of Coccinelle and audited and fixed
> > > manually.
> > >
> > > [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
> > >
> > > Signed-off-by: Len Baker <[email protected]>
> >
> > Hi Baker
> >
> > Thanks for helping us to fix this issue. This patch looks good to me.
> > Please add Signed-off-by: Fei Li <[email protected]>.
>
> I can't add the "Signed-off-by" tag by myself. However, if you are in the
> path to forward the patch to the mainline (maintainer's tree), you can
> add by yourself the "Signed-off-by" tag before send a "pull" to Linus.
> See [1] for more information.
>
> [1] https://www.kernel.org/doc/html/latest/process/submitting-patches.html#sign-your-work-the-developer-s-certificate-of-origin
>
> If you don't have a maintainer's tree, you can give (as a maintainer) an
> "Acked-by" tag that then I can add to the patch. More info in [2].

Acked-by: Fei Li <[email protected]>

thanks.

>
> [2] https://www.kernel.org/doc/html/latest/process/submitting-patches.html#when-to-use-acked-by-cc-and-co-developed-by
>
> > Only two minor comments.
> >
> >
> > > ---
> > > drivers/virt/acrn/acrn_drv.h | 10 ++++++----
> > > drivers/virt/acrn/mm.c | 9 ++++-----
> > > 2 files changed, 10 insertions(+), 9 deletions(-)
> > >
> > > diff --git a/drivers/virt/acrn/acrn_drv.h b/drivers/virt/acrn/acrn_drv.h
> > > index 1be54efa666c..fcc2e3e5232a 100644
> > > --- a/drivers/virt/acrn/acrn_drv.h
> > > +++ b/drivers/virt/acrn/acrn_drv.h
> > > @@ -48,6 +48,7 @@ struct vm_memory_region_op {
> > > * @reserved: Reserved.
> > > * @regions_num: The number of vm_memory_region_op.
> > > * @regions_gpa: Physical address of a vm_memory_region_op array.
> > > + * @regions_op: Flexible array of vm_memory_region_op.
> > One Tab please.
>
> Sorry, but if I use only one tab, the parameters description are not all
> aligned.
>
> > > *
> > > * HC_VM_SET_MEMORY_REGIONS uses this structure to manage EPT mappings of
> > > * multiple memory regions of a User VM. A &struct vm_memory_region_batch
> > > @@ -55,10 +56,11 @@ struct vm_memory_region_op {
> > > * ACRN Hypervisor.
> > > */
> > > struct vm_memory_region_batch {
> > > - u16 vmid;
> > > - u16 reserved[3];
> > > - u32 regions_num;
> > > - u64 regions_gpa;
> > > + u16 vmid;
> > > + u16 reserved[3];
> > > + u32 regions_num;
> > > + u64 regions_gpa;
> > > + struct vm_memory_region_op regions_op[];
> > Please use Whitespace instead of Tab.
>
> Sorry, but I don't understand. Do you prefer something like?:
>
> diff --git a/drivers/virt/acrn/acrn_drv.h b/drivers/virt/acrn/acrn_drv.h
> index fcc2e3e5232a..5663c17ad37c 100644
> --- a/drivers/virt/acrn/acrn_drv.h
> +++ b/drivers/virt/acrn/acrn_drv.h
> @@ -56,11 +56,11 @@ struct vm_memory_region_op {
> * ACRN Hypervisor.
> */
> struct vm_memory_region_batch {
> - u16 vmid;
> - u16 reserved[3];
> - u32 regions_num;
> - u64 regions_gpa;
> - struct vm_memory_region_op regions_op[];
> + u16 vmid;
> + u16 reserved[3];
> + u32 regions_num;
> + u64 regions_gpa;
> + struct vm_memory_region_op regions_op[];
> };
>
> /**
>
> Moreover, for the v2 I will fix the typo "syze->size" in the subject as
> suggested Kees ;)
>
> Regards,
> Len