2021-12-21 13:20:47

by Xiu Jianfeng

[permalink] [raw]
Subject: [PATCH -next] sched: Use struct_size() helper in task_numa_group()

Make use of struct_size() helper instead of an open-coded calculation.
There is no functional change in this patch.

Link: https://github.com/KSPP/linux/issues/160
Signed-off-by: Xiu Jianfeng <[email protected]>
---
kernel/sched/fair.c | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)

diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
index 095b0aa378df..265e37be0c92 100644
--- a/kernel/sched/fair.c
+++ b/kernel/sched/fair.c
@@ -2437,11 +2437,8 @@ static void task_numa_group(struct task_struct *p, int cpupid, int flags,
int i;

if (unlikely(!deref_curr_numa_group(p))) {
- unsigned int size = sizeof(struct numa_group) +
- NR_NUMA_HINT_FAULT_STATS *
- nr_node_ids * sizeof(unsigned long);
-
- grp = kzalloc(size, GFP_KERNEL | __GFP_NOWARN);
+ grp = kzalloc(struct_size(grp, faults, NR_NUMA_HINT_FAULT_STATS * nr_node_ids),
+ GFP_KERNEL | __GFP_NOWARN);
if (!grp)
return;

--
2.17.1



2022-01-06 16:39:17

by Steven Rostedt

[permalink] [raw]
Subject: Re: [PATCH -next] sched: Use struct_size() helper in task_numa_group()

On Tue, 21 Dec 2021 21:21:38 +0800
Xiu Jianfeng <[email protected]> wrote:

> Make use of struct_size() helper instead of an open-coded calculation.
> There is no functional change in this patch.

I'm all for this clean up, but...

>
> Link: https://github.com/KSPP/linux/issues/160
> Signed-off-by: Xiu Jianfeng <[email protected]>
> ---
> kernel/sched/fair.c | 7 ++-----
> 1 file changed, 2 insertions(+), 5 deletions(-)
>
> diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
> index 095b0aa378df..265e37be0c92 100644
> --- a/kernel/sched/fair.c
> +++ b/kernel/sched/fair.c
> @@ -2437,11 +2437,8 @@ static void task_numa_group(struct task_struct *p, int cpupid, int flags,
> int i;
>
> if (unlikely(!deref_curr_numa_group(p))) {
> - unsigned int size = sizeof(struct numa_group) +
> - NR_NUMA_HINT_FAULT_STATS *
> - nr_node_ids * sizeof(unsigned long);
> -
> - grp = kzalloc(size, GFP_KERNEL | __GFP_NOWARN);
> + grp = kzalloc(struct_size(grp, faults, NR_NUMA_HINT_FAULT_STATS * nr_node_ids),
> + GFP_KERNEL | __GFP_NOWARN);

Ug, the above is so ugly. Why remove the size variable?

unsigned int size = struct_size(grp, faults,
NR_NUMA_HINT_FAULT_STATS * nr_node_ids);

-- Steve


> if (!grp)
> return;
>