Delete the redundant word 'on'.
Signed-off-by: wangjianli <[email protected]>
---
drivers/media/platform/renesas/renesas-ceu.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/media/platform/renesas/renesas-ceu.c b/drivers/media/platform/renesas/renesas-ceu.c
index f70f91b006b7..69723b51e4dc 100644
--- a/drivers/media/platform/renesas/renesas-ceu.c
+++ b/drivers/media/platform/renesas/renesas-ceu.c
@@ -1101,7 +1101,7 @@ static int ceu_open(struct file *file)
return ret;
mutex_lock(&ceudev->mlock);
- /* Causes soft-reset and sensor power on on first open */
+ /* Causes soft-reset and sensor power on first open */
ret = pm_runtime_resume_and_get(ceudev->dev);
mutex_unlock(&ceudev->mlock);
--
2.36.1
Hello wangjianli
On Sun, Aug 21, 2022 at 10:54:35PM +0800, wangjianli wrote:
> Delete the redundant word 'on'.
^ unecessary space, can be fixed when applying maybe ?
>
> Signed-off-by: wangjianli <[email protected]>
Is this your full name ? Should it be spelled with spaces ?
https://www.kernel.org/doc/html/latest/process/submitting-patches.html#developer-s-certificate-of-origin-1-1
I'm sorry to ask, but I'm actually not sure if the signature here
counts as your full name or not
The patch is obviously fine
Acked-by: Jacopo Mondi <[email protected]>
> ---
> drivers/media/platform/renesas/renesas-ceu.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/media/platform/renesas/renesas-ceu.c b/drivers/media/platform/renesas/renesas-ceu.c
> index f70f91b006b7..69723b51e4dc 100644
> --- a/drivers/media/platform/renesas/renesas-ceu.c
> +++ b/drivers/media/platform/renesas/renesas-ceu.c
> @@ -1101,7 +1101,7 @@ static int ceu_open(struct file *file)
> return ret;
>
> mutex_lock(&ceudev->mlock);
> - /* Causes soft-reset and sensor power on on first open */
> + /* Causes soft-reset and sensor power on first open */
> ret = pm_runtime_resume_and_get(ceudev->dev);
> mutex_unlock(&ceudev->mlock);
>
> --
> 2.36.1
>
Hi Wangjianli,
On Sun, Aug 21, 2022 at 4:58 PM wangjianli <[email protected]> wrote:
> Delete the redundant word 'on'.
>
> Signed-off-by: wangjianli <[email protected]>
Thanks for your patch!
> --- a/drivers/media/platform/renesas/renesas-ceu.c
> +++ b/drivers/media/platform/renesas/renesas-ceu.c
> @@ -1101,7 +1101,7 @@ static int ceu_open(struct file *file)
> return ret;
>
> mutex_lock(&ceudev->mlock);
> - /* Causes soft-reset and sensor power on on first open */
> + /* Causes soft-reset and sensor power on first open */
The double "on" is actually correct. Please ask yourself the question:
"When should the sensor be powered on?".
Answer: "On first open".
Personally, I would have written "power-on" instead of "power on"
(cfr. "soft-reset"), so perhaps it's a good idea to make that change,
to prevent the next person looking for double words falling for
this again?
> ret = pm_runtime_resume_and_get(ceudev->dev);
> mutex_unlock(&ceudev->mlock);
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email protected]
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds
Hi Geert
On Mon, Aug 22, 2022 at 10:06:03AM +0200, Geert Uytterhoeven wrote:
> Hi Wangjianli,
>
> On Sun, Aug 21, 2022 at 4:58 PM wangjianli <[email protected]> wrote:
> > Delete the redundant word 'on'.
> >
> > Signed-off-by: wangjianli <[email protected]>
>
> Thanks for your patch!
>
> > --- a/drivers/media/platform/renesas/renesas-ceu.c
> > +++ b/drivers/media/platform/renesas/renesas-ceu.c
> > @@ -1101,7 +1101,7 @@ static int ceu_open(struct file *file)
> > return ret;
> >
> > mutex_lock(&ceudev->mlock);
> > - /* Causes soft-reset and sensor power on on first open */
> > + /* Causes soft-reset and sensor power on first open */
>
> The double "on" is actually correct. Please ask yourself the question:
> "When should the sensor be powered on?".
> Answer: "On first open".
>
So I overlooked this patch so badly, that I didn't get what I meant when I
first wrote this comment ?
> Personally, I would have written "power-on" instead of "power on"
> (cfr. "soft-reset"), so perhaps it's a good idea to make that change,
> to prevent the next person looking for double words falling for
> this again?
>
Wangjianli please ignore my acked-by and follow instead Geert's
suggestion to change this to power-on, if you want to re-submit the
patch.
Thanks Geert for being awake, as I'm clearly not yet.
> > ret = pm_runtime_resume_and_get(ceudev->dev);
> > mutex_unlock(&ceudev->mlock);
>
> Gr{oetje,eeting}s,
>
> Geert
>
> --
> Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email protected]
>
> In personal conversations with technical people, I call myself a hacker. But
> when I'm talking to journalists I just say "programmer" or something like that.
> -- Linus Torvalds