2022-08-16 14:25:07

by Gaosheng Cui

[permalink] [raw]
Subject: [PATCH -next] mtd: ftl: use container_of() rather than cast

The container_of() is much more readable and also safer.

Signed-off-by: Gaosheng Cui <[email protected]>
---
drivers/mtd/ftl.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/mtd/ftl.c b/drivers/mtd/ftl.c
index bec56070039d..7e56c77535e8 100644
--- a/drivers/mtd/ftl.c
+++ b/drivers/mtd/ftl.c
@@ -941,7 +941,7 @@ static int ftl_write(partition_t *part, caddr_t buffer,

static int ftl_getgeo(struct mtd_blktrans_dev *dev, struct hd_geometry *geo)
{
- partition_t *part = (void *)dev;
+ partition_t *part = container_of(dev, struct partition_t, mbd);
u_long sect;

/* Sort of arbitrary: round size down to 4KiB boundary */
@@ -969,7 +969,7 @@ static int ftl_writesect(struct mtd_blktrans_dev *dev,
static int ftl_discardsect(struct mtd_blktrans_dev *dev,
unsigned long sector, unsigned nr_sects)
{
- partition_t *part = (void *)dev;
+ partition_t *part = container_of(dev, struct partition_t, mbd);
uint32_t bsize = 1 << part->header.EraseUnitSize;

pr_debug("FTL erase sector %ld for %d sectors\n",
--
2.25.1


2022-09-19 16:37:37

by Miquel Raynal

[permalink] [raw]
Subject: Re: [PATCH -next] mtd: ftl: use container_of() rather than cast

On Tue, 2022-08-16 at 13:59:10 UTC, Gaosheng Cui wrote:
> The container_of() is much more readable and also safer.
>
> Signed-off-by: Gaosheng Cui <[email protected]>

Applied to https://git.kernel.org/pub/scm/linux/kernel/git/mtd/linux.git mtd/next, thanks.

Miquel