pm8941-misc should be called 'extcon' and pm8941-coincell 'charger'.
Signed-off-by: Luca Weiss <[email protected]>
---
arch/arm/boot/dts/qcom-pm8941.dtsi | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/arm/boot/dts/qcom-pm8941.dtsi b/arch/arm/boot/dts/qcom-pm8941.dtsi
index 33517cccee01..01f14d5f314d 100644
--- a/arch/arm/boot/dts/qcom-pm8941.dtsi
+++ b/arch/arm/boot/dts/qcom-pm8941.dtsi
@@ -27,7 +27,7 @@ pwrkey@800 {
bias-pull-up;
};
- usb_id: misc@900 {
+ usb_id: extcon@900 {
compatible = "qcom,pm8941-misc";
reg = <0x900>;
interrupts = <0x0 0x9 0 IRQ_TYPE_EDGE_BOTH>;
@@ -138,7 +138,7 @@ pm8941_iadc: adc@3600 {
qcom,external-resistor-micro-ohms = <10000>;
};
- pm8941_coincell: coincell@2800 {
+ pm8941_coincell: charger@2800 {
compatible = "qcom,pm8941-coincell";
reg = <0x2800>;
status = "disabled";
--
2.37.3
Hi,
On 25/09/2022 23:02, Luca Weiss wrote:
> pm8941-misc should be called 'extcon' and pm8941-coincell 'charger'.
>
> Signed-off-by: Luca Weiss <[email protected]>
> ---
> arch/arm/boot/dts/qcom-pm8941.dtsi | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/arch/arm/boot/dts/qcom-pm8941.dtsi b/arch/arm/boot/dts/qcom-pm8941.dtsi
> index 33517cccee01..01f14d5f314d 100644
> --- a/arch/arm/boot/dts/qcom-pm8941.dtsi
> +++ b/arch/arm/boot/dts/qcom-pm8941.dtsi
> @@ -27,7 +27,7 @@ pwrkey@800 {
> bias-pull-up;
> };
>
> - usb_id: misc@900 {
> + usb_id: extcon@900 {
> compatible = "qcom,pm8941-misc";
> reg = <0x900>;
> interrupts = <0x0 0x9 0 IRQ_TYPE_EDGE_BOTH>;
> @@ -138,7 +138,7 @@ pm8941_iadc: adc@3600 {
> qcom,external-resistor-micro-ohms = <10000>;
> };
>
> - pm8941_coincell: coincell@2800 {
> + pm8941_coincell: charger@2800 {
> compatible = "qcom,pm8941-coincell";
> reg = <0x2800>;
> status = "disabled";
I think those changes are unrelated and should be split into 2 patches.
Neil
On 25/09/2022 23:02, Luca Weiss wrote:
> pm8941-misc should be called 'extcon' and pm8941-coincell 'charger'.
>
> Signed-off-by: Luca Weiss <[email protected]>
> ---
> arch/arm/boot/dts/qcom-pm8941.dtsi | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/arch/arm/boot/dts/qcom-pm8941.dtsi b/arch/arm/boot/dts/qcom-pm8941.dtsi
> index 33517cccee01..01f14d5f314d 100644
> --- a/arch/arm/boot/dts/qcom-pm8941.dtsi
> +++ b/arch/arm/boot/dts/qcom-pm8941.dtsi
> @@ -27,7 +27,7 @@ pwrkey@800 {
> bias-pull-up;
> };
>
> - usb_id: misc@900 {
> + usb_id: extcon@900 {
Why? extcon is Linux specific name and should not be added to DTS.
Anything requires it?
Best regards,
Krzysztof
On 26/09/2022 11:22, Krzysztof Kozlowski wrote:
> On 25/09/2022 23:02, Luca Weiss wrote:
>> pm8941-misc should be called 'extcon' and pm8941-coincell 'charger'.
>>
>> Signed-off-by: Luca Weiss <[email protected]>
>> ---
>> arch/arm/boot/dts/qcom-pm8941.dtsi | 4 ++--
>> 1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/arch/arm/boot/dts/qcom-pm8941.dtsi b/arch/arm/boot/dts/qcom-pm8941.dtsi
>> index 33517cccee01..01f14d5f314d 100644
>> --- a/arch/arm/boot/dts/qcom-pm8941.dtsi
>> +++ b/arch/arm/boot/dts/qcom-pm8941.dtsi
>> @@ -27,7 +27,7 @@ pwrkey@800 {
>> bias-pull-up;
>> };
>>
>> - usb_id: misc@900 {
>> + usb_id: extcon@900 {
>
> Why? extcon is Linux specific name and should not be added to DTS.
> Anything requires it?
It matches the current dt bindings:
Documentation/devicetree/bindings/mfd/qcom,spmi-pmic.yaml:
<snip>
"extcon@[0-9a-f]+$":
type: object
$ref: /schemas/extcon/qcom,pm8941-misc.yaml#
<snip>
Neil
>
>
> Best regards,
> Krzysztof
>
On 26/09/2022 12:04, Neil Armstrong wrote:
> On 26/09/2022 11:22, Krzysztof Kozlowski wrote:
>>> };
>>>
>>> - usb_id: misc@900 {
>>> + usb_id: extcon@900 {
>>
>> Why? extcon is Linux specific name and should not be added to DTS.
>> Anything requires it?
>
> It matches the current dt bindings:
Then instead maybe let's fix it in the bindings and DTS?
Best regards,
Krzysztof
Hi Krzysztof,
On Montag, 26. September 2022 12:29:11 CEST Krzysztof Kozlowski wrote:
> On 26/09/2022 12:04, Neil Armstrong wrote:
> > On 26/09/2022 11:22, Krzysztof Kozlowski wrote:
> >>> };
> >>>
> >>> - usb_id: misc@900 {
> >>> + usb_id: extcon@900 {
> >>
> >> Why? extcon is Linux specific name and should not be added to DTS.
> >> Anything requires it?
> >
> > It matches the current dt bindings:
> Then instead maybe let's fix it in the bindings and DTS?
What node name do you propose? I doubt "misc" is a better name as it really
doesn't describe anything so I don't really have a suggestion here..
Regards
Luca
>
> Best regards,
> Krzysztof
On 26/09/2022 12:29, Krzysztof Kozlowski wrote:
> On 26/09/2022 12:04, Neil Armstrong wrote:
>> On 26/09/2022 11:22, Krzysztof Kozlowski wrote:
>>>> };
>>>>
>>>> - usb_id: misc@900 {
>>>> + usb_id: extcon@900 {
>>>
>>> Why? extcon is Linux specific name and should not be added to DTS.
>>> Anything requires it?
>>
>> It matches the current dt bindings:
>
> Then instead maybe let's fix it in the bindings and DTS?
Yes it would be preferable
>
> Best regards,
> Krzysztof
>
Neil
On 25.09.2022 23:02, Luca Weiss wrote:
> pm8941-misc should be called 'extcon' and pm8941-coincell 'charger'.
>
> Signed-off-by: Luca Weiss <[email protected]>
> ---
Reviewed-by: Konrad Dybcio <[email protected]>
Konrad
> arch/arm/boot/dts/qcom-pm8941.dtsi | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/arch/arm/boot/dts/qcom-pm8941.dtsi b/arch/arm/boot/dts/qcom-pm8941.dtsi
> index 33517cccee01..01f14d5f314d 100644
> --- a/arch/arm/boot/dts/qcom-pm8941.dtsi
> +++ b/arch/arm/boot/dts/qcom-pm8941.dtsi
> @@ -27,7 +27,7 @@ pwrkey@800 {
> bias-pull-up;
> };
>
> - usb_id: misc@900 {
> + usb_id: extcon@900 {
> compatible = "qcom,pm8941-misc";
> reg = <0x900>;
> interrupts = <0x0 0x9 0 IRQ_TYPE_EDGE_BOTH>;
> @@ -138,7 +138,7 @@ pm8941_iadc: adc@3600 {
> qcom,external-resistor-micro-ohms = <10000>;
> };
>
> - pm8941_coincell: coincell@2800 {
> + pm8941_coincell: charger@2800 {
> compatible = "qcom,pm8941-coincell";
> reg = <0x2800>;
> status = "disabled";
On 26/09/2022 17:07, Luca Weiss wrote:
> Hi Krzysztof,
>
> On Montag, 26. September 2022 12:29:11 CEST Krzysztof Kozlowski wrote:
>> On 26/09/2022 12:04, Neil Armstrong wrote:
>>> On 26/09/2022 11:22, Krzysztof Kozlowski wrote:
>>>>> };
>>>>>
>>>>> - usb_id: misc@900 {
>>>>> + usb_id: extcon@900 {
>>>>
>>>> Why? extcon is Linux specific name and should not be added to DTS.
>>>> Anything requires it?
>>>
>>> It matches the current dt bindings:
>> Then instead maybe let's fix it in the bindings and DTS?
>
> What node name do you propose? I doubt "misc" is a better name as it really
> doesn't describe anything so I don't really have a suggestion here..
>
Some manufacturers call it a muic (Micro-USB IC), but maybe just
usb-detect? The role of this device is accessory and cable detection.
Best regards,
Krzysztof