2023-08-02 12:14:47

by Tony Lindgren

[permalink] [raw]
Subject: [PATCH] serial: core: Fix serial_base_match() after fixing controller port name

While fixing DEVNAME to be more usable, I broke serial_base_match() as
the ctrl and port prefix for device seemed unnecessary.

Let's fix the issue by checking against dev->type and drv->name.

Fixes: 1ef2c2df1199 ("serial: core: Fix serial core controller port name to show controller id")
Reported-by: kernel test robot <[email protected]>
Signed-off-by: Tony Lindgren <[email protected]>
---
drivers/tty/serial/serial_base.h | 3 +++
drivers/tty/serial/serial_base_bus.c | 10 ++++++++--
drivers/tty/serial/serial_ctrl.c | 2 +-
drivers/tty/serial/serial_port.c | 2 +-
4 files changed, 13 insertions(+), 4 deletions(-)

diff --git a/drivers/tty/serial/serial_base.h b/drivers/tty/serial/serial_base.h
--- a/drivers/tty/serial/serial_base.h
+++ b/drivers/tty/serial/serial_base.h
@@ -6,6 +6,9 @@
* Author: Tony Lindgren <[email protected]>
*/

+#define SERIAL_BASE_CTRL_NAME "ctrl"
+#define SERIAL_BASE_PORT_NAME "port"
+
#define to_serial_base_ctrl_device(d) container_of((d), struct serial_ctrl_device, dev)
#define to_serial_base_port_device(d) container_of((d), struct serial_port_device, dev)

diff --git a/drivers/tty/serial/serial_base_bus.c b/drivers/tty/serial/serial_base_bus.c
--- a/drivers/tty/serial/serial_base_bus.c
+++ b/drivers/tty/serial/serial_base_bus.c
@@ -29,9 +29,15 @@ static const struct device_type serial_port_type = {

static int serial_base_match(struct device *dev, struct device_driver *drv)
{
- int len = strlen(drv->name);
+ if (dev->type == &serial_ctrl_type &&
+ !strncmp(SERIAL_BASE_CTRL_NAME, drv->name, 4))
+ return 1;

- return !strncmp(dev_name(dev), drv->name, len);
+ if (dev->type == &serial_port_type &&
+ !strncmp(SERIAL_BASE_PORT_NAME, drv->name, 4))
+ return 1;
+
+ return 0;
}

static struct bus_type serial_base_bus_type = {
diff --git a/drivers/tty/serial/serial_ctrl.c b/drivers/tty/serial/serial_ctrl.c
--- a/drivers/tty/serial/serial_ctrl.c
+++ b/drivers/tty/serial/serial_ctrl.c
@@ -47,7 +47,7 @@ void serial_ctrl_unregister_port(struct uart_driver *drv, struct uart_port *port
}

static struct device_driver serial_ctrl_driver = {
- .name = "ctrl",
+ .name = SERIAL_BASE_CTRL_NAME,
.suppress_bind_attrs = true,
.probe = serial_ctrl_probe,
.remove = serial_ctrl_remove,
diff --git a/drivers/tty/serial/serial_port.c b/drivers/tty/serial/serial_port.c
--- a/drivers/tty/serial/serial_port.c
+++ b/drivers/tty/serial/serial_port.c
@@ -83,7 +83,7 @@ void uart_remove_one_port(struct uart_driver *drv, struct uart_port *port)
EXPORT_SYMBOL(uart_remove_one_port);

static struct device_driver serial_port_driver = {
- .name = "port",
+ .name = SERIAL_BASE_PORT_NAME,
.suppress_bind_attrs = true,
.probe = serial_port_probe,
.remove = serial_port_remove,
--
2.41.0


2023-08-02 14:13:14

by Greg Kroah-Hartman

[permalink] [raw]
Subject: Re: [PATCH] serial: core: Fix serial_base_match() after fixing controller port name

On Wed, Aug 02, 2023 at 02:48:43PM +0300, Tony Lindgren wrote:
> While fixing DEVNAME to be more usable, I broke serial_base_match() as
> the ctrl and port prefix for device seemed unnecessary.
>
> Let's fix the issue by checking against dev->type and drv->name.
>
> Fixes: 1ef2c2df1199 ("serial: core: Fix serial core controller port name to show controller id")
> Reported-by: kernel test robot <[email protected]>
> Signed-off-by: Tony Lindgren <[email protected]>
> ---
> drivers/tty/serial/serial_base.h | 3 +++
> drivers/tty/serial/serial_base_bus.c | 10 ++++++++--
> drivers/tty/serial/serial_ctrl.c | 2 +-
> drivers/tty/serial/serial_port.c | 2 +-
> 4 files changed, 13 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/tty/serial/serial_base.h b/drivers/tty/serial/serial_base.h
> --- a/drivers/tty/serial/serial_base.h
> +++ b/drivers/tty/serial/serial_base.h
> @@ -6,6 +6,9 @@
> * Author: Tony Lindgren <[email protected]>
> */
>
> +#define SERIAL_BASE_CTRL_NAME "ctrl"
> +#define SERIAL_BASE_PORT_NAME "port"
> +
> #define to_serial_base_ctrl_device(d) container_of((d), struct serial_ctrl_device, dev)
> #define to_serial_base_port_device(d) container_of((d), struct serial_port_device, dev)
>
> diff --git a/drivers/tty/serial/serial_base_bus.c b/drivers/tty/serial/serial_base_bus.c
> --- a/drivers/tty/serial/serial_base_bus.c
> +++ b/drivers/tty/serial/serial_base_bus.c
> @@ -29,9 +29,15 @@ static const struct device_type serial_port_type = {
>
> static int serial_base_match(struct device *dev, struct device_driver *drv)
> {
> - int len = strlen(drv->name);
> + if (dev->type == &serial_ctrl_type &&
> + !strncmp(SERIAL_BASE_CTRL_NAME, drv->name, 4))

maybe:
!strncmp(SERIAL_BASE_CTRL_NAME, drv->name, strlen(SERIAL_BASE_CTRL_NAME))

as "4" is a magic number :)


thanks,

greg k-h

2023-08-02 19:12:45

by Mark Brown

[permalink] [raw]
Subject: Re: [PATCH] serial: core: Fix serial_base_match() after fixing controller port name

On Wed, Aug 02, 2023 at 02:48:43PM +0300, Tony Lindgren wrote:
> While fixing DEVNAME to be more usable, I broke serial_base_match() as
> the ctrl and port prefix for device seemed unnecessary.
>
> Let's fix the issue by checking against dev->type and drv->name.

This fixes boot on at least i.MX8MP-EVK:

Tested-by: Mark Brown <[email protected]>


Attachments:
(No filename) (359.00 B)
signature.asc (499.00 B)
Download all attachments

2023-08-02 22:22:16

by Andy Shevchenko

[permalink] [raw]
Subject: Re: [PATCH] serial: core: Fix serial_base_match() after fixing controller port name

On Wed, Aug 02, 2023 at 03:48:26PM +0200, Greg Kroah-Hartman wrote:
> On Wed, Aug 02, 2023 at 02:48:43PM +0300, Tony Lindgren wrote:
> > While fixing DEVNAME to be more usable, I broke serial_base_match() as
> > the ctrl and port prefix for device seemed unnecessary.
> >
> > Let's fix the issue by checking against dev->type and drv->name.

...

> > + !strncmp(SERIAL_BASE_CTRL_NAME, drv->name, 4))
>
> maybe:
> !strncmp(SERIAL_BASE_CTRL_NAME, drv->name, strlen(SERIAL_BASE_CTRL_NAME))
>
> as "4" is a magic number :)

str_has_prefix() hides that.

--
With Best Regards,
Andy Shevchenko



2023-08-03 06:59:59

by Jiri Slaby

[permalink] [raw]
Subject: Re: [PATCH] serial: core: Fix serial_base_match() after fixing controller port name

On 02. 08. 23, 13:48, Tony Lindgren wrote:
> While fixing DEVNAME to be more usable, I broke serial_base_match() as
> the ctrl and port prefix for device seemed unnecessary.

It's not completely clear to me what you are actually fixing. Please
elaborate in more detail.

> Let's fix the issue by checking against dev->type and drv->name.
>
> Fixes: 1ef2c2df1199 ("serial: core: Fix serial core controller port name to show controller id")


> Reported-by: kernel test robot <[email protected]>

Then we are missing a Link here.

> Signed-off-by: Tony Lindgren <[email protected]>
> ---
> drivers/tty/serial/serial_base.h | 3 +++
> drivers/tty/serial/serial_base_bus.c | 10 ++++++++--
> drivers/tty/serial/serial_ctrl.c | 2 +-
> drivers/tty/serial/serial_port.c | 2 +-
> 4 files changed, 13 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/tty/serial/serial_base.h b/drivers/tty/serial/serial_base.h
> --- a/drivers/tty/serial/serial_base.h
> +++ b/drivers/tty/serial/serial_base.h
> @@ -6,6 +6,9 @@
> * Author: Tony Lindgren <[email protected]>
> */
>
> +#define SERIAL_BASE_CTRL_NAME "ctrl"
> +#define SERIAL_BASE_PORT_NAME "port"

Could you make those char[] instead? The compiler/linker will hopefully
(will it?) de-dup the occurrences, but the arrays would look cleaner and
safer from this POV.

> #define to_serial_base_ctrl_device(d) container_of((d), struct serial_ctrl_device, dev)
> #define to_serial_base_port_device(d) container_of((d), struct serial_port_device, dev)
>
> diff --git a/drivers/tty/serial/serial_base_bus.c b/drivers/tty/serial/serial_base_bus.c
> --- a/drivers/tty/serial/serial_base_bus.c
> +++ b/drivers/tty/serial/serial_base_bus.c
> @@ -29,9 +29,15 @@ static const struct device_type serial_port_type = {
>
> static int serial_base_match(struct device *dev, struct device_driver *drv)
> {
> - int len = strlen(drv->name);
> + if (dev->type == &serial_ctrl_type &&
> + !strncmp(SERIAL_BASE_CTRL_NAME, drv->name, 4))
> + return 1;
>
> - return !strncmp(dev_name(dev), drv->name, len);
> + if (dev->type == &serial_port_type &&
> + !strncmp(SERIAL_BASE_PORT_NAME, drv->name, 4))
> + return 1;
> +
> + return 0;
> }
>
> static struct bus_type serial_base_bus_type = {
> diff --git a/drivers/tty/serial/serial_ctrl.c b/drivers/tty/serial/serial_ctrl.c
> --- a/drivers/tty/serial/serial_ctrl.c
> +++ b/drivers/tty/serial/serial_ctrl.c
> @@ -47,7 +47,7 @@ void serial_ctrl_unregister_port(struct uart_driver *drv, struct uart_port *port
> }
>
> static struct device_driver serial_ctrl_driver = {
> - .name = "ctrl",
> + .name = SERIAL_BASE_CTRL_NAME,
> .suppress_bind_attrs = true,
> .probe = serial_ctrl_probe,
> .remove = serial_ctrl_remove,
> diff --git a/drivers/tty/serial/serial_port.c b/drivers/tty/serial/serial_port.c
> --- a/drivers/tty/serial/serial_port.c
> +++ b/drivers/tty/serial/serial_port.c
> @@ -83,7 +83,7 @@ void uart_remove_one_port(struct uart_driver *drv, struct uart_port *port)
> EXPORT_SYMBOL(uart_remove_one_port);
>
> static struct device_driver serial_port_driver = {
> - .name = "port",
> + .name = SERIAL_BASE_PORT_NAME,
> .suppress_bind_attrs = true,
> .probe = serial_port_probe,
> .remove = serial_port_remove,

--
js
suse labs


2023-08-03 07:08:14

by Tony Lindgren

[permalink] [raw]
Subject: Re: [PATCH] serial: core: Fix serial_base_match() after fixing controller port name

* Jiri Slaby <[email protected]> [230803 05:13]:
> On 02. 08. 23, 13:48, Tony Lindgren wrote:
> > @@ -6,6 +6,9 @@
> > * Author: Tony Lindgren <[email protected]>
> > */
> > +#define SERIAL_BASE_CTRL_NAME "ctrl"
> > +#define SERIAL_BASE_PORT_NAME "port"
>
> Could you make those char[] instead? The compiler/linker will hopefully
> (will it?) de-dup the occurrences, but the arrays would look cleaner and
> safer from this POV.

Heh yeah so we already have that in serial_ctrl_type.name and
serial_port_type.name so let's just check against those for a
minimal fix.

Regards,

Tony

2023-08-03 08:11:30

by Anders Roxell

[permalink] [raw]
Subject: Re: [PATCH] serial: core: Fix serial_base_match() after fixing controller port name

On 2023-08-02 14:48, Tony Lindgren wrote:
> While fixing DEVNAME to be more usable, I broke serial_base_match() as
> the ctrl and port prefix for device seemed unnecessary.
>
> Let's fix the issue by checking against dev->type and drv->name.
>
> Fixes: 1ef2c2df1199 ("serial: core: Fix serial core controller port name to show controller id")
> Reported-by: kernel test robot <[email protected]>
> Signed-off-by: Tony Lindgren <[email protected]>

This fixes boot on e850-96.

Tested-by: Anders Roxell <[email protected]>