2024-02-12 10:35:48

by Onkarnarth

[permalink] [raw]
Subject: [PATCH v2 1/2] ACPI: use %pe for better readability of errors while printing

From: Onkarnath <[email protected]>

As %pe is already introduced, it's better to use it in place of (%ld) for
printing errors in logs. It would enhance readability of logs.

Signed-off-by: Maninder Singh <[email protected]>
Signed-off-by: Onkarnath <[email protected]>
Reviewed-by: Stanislaw Gruszka <[email protected]>
Reviewed-by: Bjorn Helgaas <[email protected]>
---
v1->v2: Updated subject line as per file history & corrected spellings
in description.

drivers/acpi/acpi_processor.c | 2 +-
drivers/acpi/acpi_watchdog.c | 2 +-
drivers/acpi/pci_slot.c | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/acpi/acpi_processor.c b/drivers/acpi/acpi_processor.c
index 4fe2ef54088c..2ddd36a21850 100644
--- a/drivers/acpi/acpi_processor.c
+++ b/drivers/acpi/acpi_processor.c
@@ -161,7 +161,7 @@ static void cpufreq_add_device(const char *name)

pdev = platform_device_register_simple(name, PLATFORM_DEVID_NONE, NULL, 0);
if (IS_ERR(pdev))
- pr_info("%s device creation failed: %ld\n", name, PTR_ERR(pdev));
+ pr_info("%s device creation failed: %pe\n", name, pdev);
}

#ifdef CONFIG_X86
diff --git a/drivers/acpi/acpi_watchdog.c b/drivers/acpi/acpi_watchdog.c
index 8e9e001da38f..14b24157799c 100644
--- a/drivers/acpi/acpi_watchdog.c
+++ b/drivers/acpi/acpi_watchdog.c
@@ -179,7 +179,7 @@ void __init acpi_watchdog_init(void)
pdev = platform_device_register_simple("wdat_wdt", PLATFORM_DEVID_NONE,
resources, nresources);
if (IS_ERR(pdev))
- pr_err("Device creation failed: %ld\n", PTR_ERR(pdev));
+ pr_err("Device creation failed: %pe\n", pdev);

kfree(resources);

diff --git a/drivers/acpi/pci_slot.c b/drivers/acpi/pci_slot.c
index d6cb2c27a23b..741bcc9d6d6a 100644
--- a/drivers/acpi/pci_slot.c
+++ b/drivers/acpi/pci_slot.c
@@ -111,7 +111,7 @@ register_slot(acpi_handle handle, u32 lvl, void *context, void **rv)
snprintf(name, sizeof(name), "%llu", sun);
pci_slot = pci_create_slot(pci_bus, device, name, NULL);
if (IS_ERR(pci_slot)) {
- pr_err("pci_create_slot returned %ld\n", PTR_ERR(pci_slot));
+ pr_err("pci_create_slot returned %pe\n", pci_slot);
kfree(slot);
return AE_OK;
}
--
2.25.1



2024-02-12 10:35:56

by Onkarnarth

[permalink] [raw]
Subject: [PATCH v2 2/2] cpufreq/schedutil: print errors with %pe for better readability of logs

From: Onkarnath <[email protected]>

Instead of printing errros as a number(%ld), it's better to print in string
format for better readability of logs.

Signed-off-by: Onkarnath <[email protected]>
Reviewed-by: Stanislaw Gruszka <[email protected]>
Reviewed-by: Valentin Schneider <[email protected]>
---
v1->v2: Updated subject as per file history

kernel/sched/cpufreq_schedutil.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/kernel/sched/cpufreq_schedutil.c b/kernel/sched/cpufreq_schedutil.c
index eece6244f9d2..2c42eaa56fa3 100644
--- a/kernel/sched/cpufreq_schedutil.c
+++ b/kernel/sched/cpufreq_schedutil.c
@@ -671,7 +671,7 @@ static int sugov_kthread_create(struct sugov_policy *sg_policy)
"sugov:%d",
cpumask_first(policy->related_cpus));
if (IS_ERR(thread)) {
- pr_err("failed to create sugov thread: %ld\n", PTR_ERR(thread));
+ pr_err("failed to create sugov thread: %pe\n", thread);
return PTR_ERR(thread);
}

--
2.25.1


2024-02-12 19:29:44

by Bjorn Helgaas

[permalink] [raw]
Subject: Re: [PATCH v2 1/2] ACPI: use %pe for better readability of errors while printing

On Mon, Feb 12, 2024 at 03:54:03PM +0530, Onkarnarth wrote:
> From: Onkarnath <[email protected]>
>
> As %pe is already introduced, it's better to use it in place of (%ld) for
> printing errors in logs. It would enhance readability of logs.
>
> Signed-off-by: Maninder Singh <[email protected]>
> Signed-off-by: Onkarnath <[email protected]>
> Reviewed-by: Stanislaw Gruszka <[email protected]>
> Reviewed-by: Bjorn Helgaas <[email protected]>

This tag is wrong. I provided some feedback, but that's not the same
as providing a "Reviewed-by" tag. "Reviewed-by" has a very specific
meaning and the reviewer must provide it explicitly; details here:

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/submitting-patches.rst?id=v6.7#n544

Bjorn