2024-06-04 15:23:17

by Qais Yousef

[permalink] [raw]
Subject: [PATCH v5 0/2] Clean up usage of rt_task()

Make rt_task() return true only for RT class and add new realtime_task() to
return true for RT and DL classes to avoid some confusion the old API can
cause.

No functional changes intended in patch 1. Patch 2 cleans up the return type as
suggested by Steve.

Changes since v4:

* Simplify return of rt/realtime_prio() as the explicit true/false was
not necessary (Metin).

Changes since v3:

* Make sure the 'new' bool functions return true/false instead of 1/0.
* Drop patch 2 about hrtimer usage of realtime_task() as ongoing
discussion on v1 indicates its scope outside of this simple cleanup.

Changes since v2:

* Fix one user that should use realtime_task() but remained using
rt_task() (Sebastian)
* New patch to convert all hrtimer users to use realtime_task_policy()
(Sebastian)
* Add a new patch to convert return type to bool (Steve)
* Rebase on tip/sched/core and handle a conflict with code shuffle to
syscalls.c
* Add Reviewed-by Steve

Changes since v1:

* Use realtime_task_policy() instead task_has_realtime_policy() (Peter)
* Improve commit message readability about replace some rt_task()
users.

v1 discussion: https://lore.kernel.org/lkml/[email protected]/
v2 discussion: https://lore.kernel.org/lkml/[email protected]/
v3 discussion: https://lore.kernel.org/lkml/[email protected]/
v4 discussion: https://lore.kernel.org/lkml/[email protected]/

Qais Yousef (2):
sched/rt: Clean up usage of rt_task()
sched/rt, dl: Convert functions to return bool

fs/bcachefs/six.c | 2 +-
fs/select.c | 2 +-
include/linux/ioprio.h | 2 +-
include/linux/sched/deadline.h | 14 ++++++-------
include/linux/sched/prio.h | 1 +
include/linux/sched/rt.h | 33 +++++++++++++++++++++++++------
kernel/locking/rtmutex.c | 4 ++--
kernel/locking/rwsem.c | 4 ++--
kernel/locking/ww_mutex.h | 2 +-
kernel/sched/core.c | 4 ++--
kernel/sched/syscalls.c | 2 +-
kernel/time/hrtimer.c | 6 +++---
kernel/trace/trace_sched_wakeup.c | 2 +-
mm/page-writeback.c | 4 ++--
mm/page_alloc.c | 2 +-
15 files changed, 53 insertions(+), 31 deletions(-)

--
2.34.1



Subject: Re: [PATCH v5 0/2] Clean up usage of rt_task()

On 2024-06-04 15:42:26 [+0100], Qais Yousef wrote:
> Make rt_task() return true only for RT class and add new realtime_task() to
> return true for RT and DL classes to avoid some confusion the old API can
> cause.

Reviewed-by: Sebastian Andrzej Siewior <[email protected]>

Sebastian