2024-02-09 18:42:52

by Gustavo A. R. Silva

[permalink] [raw]
Subject: Re: [PATCH] irqchip/bcm-6345-l1: Prefer struct_size over open coded arithmetic



On 2/9/24 12:16, Erick Archer wrote:
> This is an effort to get rid of all multiplications from allocation
> functions in order to prevent integer overflows [1].
>
> As the cpu variable is a pointer to "struct bcm6345_l1_cpu" and this
> structure ends in a flexible array:
>
> struct bcm6345_l1_cpu {
> [...]
> u32 enable_cache[];
> };
>
> the preferred way in the kernel is to use the struct_size() helper to
> do the arithmetic instead of the argument "size + count * size" in the
> kzalloc() function.
>
> This way, the code is more readable and more safer.
>
> Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/162 [2]
> Signed-off-by: Erick Archer <[email protected]>

LGTM:

Reviewed-by: Gustavo A. R. Silva <[email protected]>

Thanks
--
Gustavo

> ---
> drivers/irqchip/irq-bcm6345-l1.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/irqchip/irq-bcm6345-l1.c b/drivers/irqchip/irq-bcm6345-l1.c
> index 9745a119d0e6..eb02d203c963 100644
> --- a/drivers/irqchip/irq-bcm6345-l1.c
> +++ b/drivers/irqchip/irq-bcm6345-l1.c
> @@ -242,7 +242,7 @@ static int __init bcm6345_l1_init_one(struct device_node *dn,
> else if (intc->n_words != n_words)
> return -EINVAL;
>
> - cpu = intc->cpus[idx] = kzalloc(sizeof(*cpu) + n_words * sizeof(u32),
> + cpu = intc->cpus[idx] = kzalloc(struct_size(cpu, enable_cache, n_words),
> GFP_KERNEL);
> if (!cpu)
> return -ENOMEM;
> --
> 2.25.1
>
>