Remove the CONFIG_ prefix from the select statement for MFD_CROS_EC.
Fixes: 2fa2b980e3fe1 ("mfd / platform: cros_ec: Rename config to a better name")
Reported-by: Randy Dunlap <[email protected]>
Signed-off-by: Enric Balletbo i Serra <[email protected]>
---
drivers/platform/chrome/Kconfig | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/platform/chrome/Kconfig b/drivers/platform/chrome/Kconfig
index 15fc8b8a2db8..5ae6c49f553d 100644
--- a/drivers/platform/chrome/Kconfig
+++ b/drivers/platform/chrome/Kconfig
@@ -7,7 +7,7 @@ config MFD_CROS_EC
tristate "Platform support for Chrome hardware (transitional)"
select CHROME_PLATFORMS
select CROS_EC
- select CONFIG_MFD_CROS_EC_DEV
+ select MFD_CROS_EC_DEV
depends on X86 || ARM || ARM64 || COMPILE_TEST
help
This is a transitional Kconfig option and will be removed after
--
2.25.1
On Thu, Mar 05, 2020 at 11:28:38AM +0100, Enric Balletbo i Serra wrote:
> Remove the CONFIG_ prefix from the select statement for MFD_CROS_EC.
>
Acked-by: Andy Shevchenko <[email protected]>
> Fixes: 2fa2b980e3fe1 ("mfd / platform: cros_ec: Rename config to a better name")
> Reported-by: Randy Dunlap <[email protected]>
> Signed-off-by: Enric Balletbo i Serra <[email protected]>
> ---
>
> drivers/platform/chrome/Kconfig | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/platform/chrome/Kconfig b/drivers/platform/chrome/Kconfig
> index 15fc8b8a2db8..5ae6c49f553d 100644
> --- a/drivers/platform/chrome/Kconfig
> +++ b/drivers/platform/chrome/Kconfig
> @@ -7,7 +7,7 @@ config MFD_CROS_EC
> tristate "Platform support for Chrome hardware (transitional)"
> select CHROME_PLATFORMS
> select CROS_EC
> - select CONFIG_MFD_CROS_EC_DEV
> + select MFD_CROS_EC_DEV
> depends on X86 || ARM || ARM64 || COMPILE_TEST
> help
> This is a transitional Kconfig option and will be removed after
> --
> 2.25.1
>
--
With Best Regards,
Andy Shevchenko
On 3/5/20 2:28 AM, Enric Balletbo i Serra wrote:
> Remove the CONFIG_ prefix from the select statement for MFD_CROS_EC.
>
> Fixes: 2fa2b980e3fe1 ("mfd / platform: cros_ec: Rename config to a better name")
> Reported-by: Randy Dunlap <[email protected]>
> Signed-off-by: Enric Balletbo i Serra <[email protected]>
Acked-by: Randy Dunlap <[email protected]>
Thanks.
> ---
>
> drivers/platform/chrome/Kconfig | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/platform/chrome/Kconfig b/drivers/platform/chrome/Kconfig
> index 15fc8b8a2db8..5ae6c49f553d 100644
> --- a/drivers/platform/chrome/Kconfig
> +++ b/drivers/platform/chrome/Kconfig
> @@ -7,7 +7,7 @@ config MFD_CROS_EC
> tristate "Platform support for Chrome hardware (transitional)"
> select CHROME_PLATFORMS
> select CROS_EC
> - select CONFIG_MFD_CROS_EC_DEV
> + select MFD_CROS_EC_DEV
> depends on X86 || ARM || ARM64 || COMPILE_TEST
> help
> This is a transitional Kconfig option and will be removed after
>
--
~Randy
On 5/3/20 16:54, Randy Dunlap wrote:
> On 3/5/20 2:28 AM, Enric Balletbo i Serra wrote:
>> Remove the CONFIG_ prefix from the select statement for MFD_CROS_EC.
>>
>> Fixes: 2fa2b980e3fe1 ("mfd / platform: cros_ec: Rename config to a better name")
>> Reported-by: Randy Dunlap <[email protected]>
>> Signed-off-by: Enric Balletbo i Serra <[email protected]>
>
> Acked-by: Randy Dunlap <[email protected]>
>
Queued for 5.7.
> Thanks.
>
>> ---
>>
>> drivers/platform/chrome/Kconfig | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/drivers/platform/chrome/Kconfig b/drivers/platform/chrome/Kconfig
>> index 15fc8b8a2db8..5ae6c49f553d 100644
>> --- a/drivers/platform/chrome/Kconfig
>> +++ b/drivers/platform/chrome/Kconfig
>> @@ -7,7 +7,7 @@ config MFD_CROS_EC
>> tristate "Platform support for Chrome hardware (transitional)"
>> select CHROME_PLATFORMS
>> select CROS_EC
>> - select CONFIG_MFD_CROS_EC_DEV
>> + select MFD_CROS_EC_DEV
>> depends on X86 || ARM || ARM64 || COMPILE_TEST
>> help
>> This is a transitional Kconfig option and will be removed after
>>
>
>