2020-09-21 13:15:11

by Mikko Perttunen

[permalink] [raw]
Subject: Re: [PATCH -next] gpu: host1x: simplify the return expression of host1x_cdma_init()

On 9/21/20 4:10 PM, Qinglang Miao wrote:
> Simplify the return expression.
>
> Signed-off-by: Qinglang Miao <[email protected]>
> ---
> drivers/gpu/host1x/cdma.c | 8 +-------
> 1 file changed, 1 insertion(+), 7 deletions(-)
>
> diff --git a/drivers/gpu/host1x/cdma.c b/drivers/gpu/host1x/cdma.c
> index e8d3fda91..08a0f9e10 100644
> --- a/drivers/gpu/host1x/cdma.c
> +++ b/drivers/gpu/host1x/cdma.c
> @@ -448,8 +448,6 @@ void host1x_cdma_update_sync_queue(struct host1x_cdma *cdma,
> */
> int host1x_cdma_init(struct host1x_cdma *cdma)
> {
> - int err;
> -
> mutex_init(&cdma->lock);
> init_completion(&cdma->complete);
>
> @@ -459,11 +457,7 @@ int host1x_cdma_init(struct host1x_cdma *cdma)
> cdma->running = false;
> cdma->torndown = false;
>
> - err = host1x_pushbuffer_init(&cdma->push_buffer);
> - if (err)
> - return err;
> -
> - return 0;
> + return host1x_pushbuffer_init(&cdma->push_buffer);

IMHO, this makes it less readable since now it kind of looks like
host1x_pushbuffer_init is returning some meaningful value, instead of
the code just handling error values in a sequence.

Mikko

> }
>
> /*
>


2020-09-21 13:31:59

by Thierry Reding

[permalink] [raw]
Subject: Re: [PATCH -next] gpu: host1x: simplify the return expression of host1x_cdma_init()

On Mon, Sep 21, 2020 at 04:12:20PM +0300, Mikko Perttunen wrote:
> On 9/21/20 4:10 PM, Qinglang Miao wrote:
> > Simplify the return expression.
> >
> > Signed-off-by: Qinglang Miao <[email protected]>
> > ---
> > drivers/gpu/host1x/cdma.c | 8 +-------
> > 1 file changed, 1 insertion(+), 7 deletions(-)
> >
> > diff --git a/drivers/gpu/host1x/cdma.c b/drivers/gpu/host1x/cdma.c
> > index e8d3fda91..08a0f9e10 100644
> > --- a/drivers/gpu/host1x/cdma.c
> > +++ b/drivers/gpu/host1x/cdma.c
> > @@ -448,8 +448,6 @@ void host1x_cdma_update_sync_queue(struct host1x_cdma *cdma,
> > */
> > int host1x_cdma_init(struct host1x_cdma *cdma)
> > {
> > - int err;
> > -
> > mutex_init(&cdma->lock);
> > init_completion(&cdma->complete);
> > @@ -459,11 +457,7 @@ int host1x_cdma_init(struct host1x_cdma *cdma)
> > cdma->running = false;
> > cdma->torndown = false;
> > - err = host1x_pushbuffer_init(&cdma->push_buffer);
> > - if (err)
> > - return err;
> > -
> > - return 0;
> > + return host1x_pushbuffer_init(&cdma->push_buffer);
>
> IMHO, this makes it less readable since now it kind of looks like
> host1x_pushbuffer_init is returning some meaningful value, instead of the
> code just handling error values in a sequence.

Agreed. Collapsing the error handling like this also makes adding code
to the bottom of this function more complicated than necessary.

Thierry


Attachments:
(No filename) (1.40 kB)
signature.asc (849.00 B)
Download all attachments

2020-09-22 03:10:34

by Qinglang Miao

[permalink] [raw]
Subject: Re: [PATCH -next] gpu: host1x: simplify the return expression of host1x_cdma_init()



在 2020/9/21 21:12, Mikko Perttunen 写道:
> On 9/21/20 4:10 PM, Qinglang Miao wrote:
>> Simplify the return expression.
>>
>> Signed-off-by: Qinglang Miao <[email protected]>
>> ---
>>   drivers/gpu/host1x/cdma.c | 8 +-------
>>   1 file changed, 1 insertion(+), 7 deletions(-)
>>
>> diff --git a/drivers/gpu/host1x/cdma.c b/drivers/gpu/host1x/cdma.c
>> index e8d3fda91..08a0f9e10 100644
>> --- a/drivers/gpu/host1x/cdma.c
>> +++ b/drivers/gpu/host1x/cdma.c
>> @@ -448,8 +448,6 @@ void host1x_cdma_update_sync_queue(struct
>> host1x_cdma *cdma,
>>    */
>>   int host1x_cdma_init(struct host1x_cdma *cdma)
>>   {
>> -    int err;
>> -
>>       mutex_init(&cdma->lock);
>>       init_completion(&cdma->complete);
>> @@ -459,11 +457,7 @@ int host1x_cdma_init(struct host1x_cdma *cdma)
>>       cdma->running = false;
>>       cdma->torndown = false;
>> -    err = host1x_pushbuffer_init(&cdma->push_buffer);
>> -    if (err)
>> -        return err;
>> -
>> -    return 0;
>> +    return host1x_pushbuffer_init(&cdma->push_buffer);
>
> IMHO, this makes it less readable since now it kind of looks like
> host1x_pushbuffer_init is returning some meaningful value, instead of
> the code just handling error values in a sequence.
>
> Mikko
>
Hi Mikko,

It sounds resonable, thanks for your reply.

>>   }
>>   /*
>>
> .