Carlos Aguiar wrote:
> +int mmc_key_instantiate(struct key *key, const void *data, size_t datalen)
>
static
> +int mmc_key_match(const struct key *key, const void *description)
>
static
> +void mmc_key_destroy(struct key *key)
>
static
> @@ -335,6 +403,15 @@ static int __init mmc_init(void)
> ret = class_register(&mmc_host_class);
> if (ret)
> bus_unregister(&mmc_bus_type);
> +#ifdef CONFIG_MMC_PASSWORDS
> + else {
> + ret = register_key_type(&mmc_key_type);
> + if (ret) {
> + class_unregister(&mmc_host_class);
> + bus_unregister(&mmc_bus_type);
> + }
> + }
> +#endif
> }
> return ret;
> }
>
We're starting to get a bit of code duplication here. Perhaps an error
handling section at the end of the function would be better.
Rgds
--
-- Pierre Ossman
Linux kernel, MMC maintainer http://www.kernel.org
PulseAudio, core developer http://pulseaudio.org
rdesktop, core developer http://www.rdesktop.org