2010-07-15 18:51:24

by Peter Huewe

[permalink] [raw]
Subject: [PATCH 11/25] block: Convert pci_table entries to PCI_VDEVICE (if PCI_ANY_ID is used)

From: Peter Huewe <[email protected]>

This patch converts pci_table entries, where .subvendor=PCI_ANY_ID and
.subdevice=PCI_ANY_ID, .class=0 and .class_mask=0, to use the
PCI_VDEVICE macro, and thus improves readability.

Signed-off-by: Peter Huewe <[email protected]>
---
drivers/block/sx8.c | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/block/sx8.c b/drivers/block/sx8.c
index b70f0fc..15745e4 100644
--- a/drivers/block/sx8.c
+++ b/drivers/block/sx8.c
@@ -410,8 +410,8 @@ static void carm_remove_one (struct pci_dev *pdev);
static int carm_bdev_getgeo(struct block_device *bdev, struct hd_geometry *geo);

static const struct pci_device_id carm_pci_tbl[] = {
- { PCI_VENDOR_ID_PROMISE, 0x8000, PCI_ANY_ID, PCI_ANY_ID, 0, 0, },
- { PCI_VENDOR_ID_PROMISE, 0x8002, PCI_ANY_ID, PCI_ANY_ID, 0, 0, },
+ { PCI_VDEVICE(PROMISE, 0x8000), },
+ { PCI_VDEVICE(PROMISE, 0x8002), },
{ } /* terminate list */
};
MODULE_DEVICE_TABLE(pci, carm_pci_tbl);
--
1.7.1


2010-07-15 19:03:15

by Alexey Dobriyan

[permalink] [raw]
Subject: Re: [PATCH 11/25] block: Convert pci_table entries to PCI_VDEVICE (if PCI_ANY_ID is used)

On Thu, Jul 15, 2010 at 08:51:17PM +0200, Peter Huewe wrote:
> This patch converts pci_table entries, where .subvendor=PCI_ANY_ID and
> .subdevice=PCI_ANY_ID, .class=0 and .class_mask=0, to use the
> PCI_VDEVICE macro, and thus improves readability.

Well, it doesn't improve readability, and ## usage prevents grepping and
long term plan to switch to numbers instead of PCI_VENDOR_ID_*,
but whatever.

> - { PCI_VENDOR_ID_PROMISE, 0x8000, PCI_ANY_ID, PCI_ANY_ID, 0, 0, },
> - { PCI_VENDOR_ID_PROMISE, 0x8002, PCI_ANY_ID, PCI_ANY_ID, 0, 0, },
> + { PCI_VDEVICE(PROMISE, 0x8000), },
> + { PCI_VDEVICE(PROMISE, 0x8002), },

2010-07-16 00:51:24

by Jeff Garzik

[permalink] [raw]
Subject: Re: [PATCH 11/25] block: Convert pci_table entries to PCI_VDEVICE (if PCI_ANY_ID is used)

On 07/15/2010 03:03 PM, Alexey Dobriyan wrote:
> On Thu, Jul 15, 2010 at 08:51:17PM +0200, Peter Huewe wrote:
>> This patch converts pci_table entries, where .subvendor=PCI_ANY_ID and
>> .subdevice=PCI_ANY_ID, .class=0 and .class_mask=0, to use the
>> PCI_VDEVICE macro, and thus improves readability.
>
> Well, it doesn't improve readability, and ## usage prevents grepping and
> long term plan to switch to numbers instead of PCI_VENDOR_ID_*,
> but whatever.
>
>> - { PCI_VENDOR_ID_PROMISE, 0x8000, PCI_ANY_ID, PCI_ANY_ID, 0, 0, },
>> - { PCI_VENDOR_ID_PROMISE, 0x8002, PCI_ANY_ID, PCI_ANY_ID, 0, 0, },
>> + { PCI_VDEVICE(PROMISE, 0x8000), },
>> + { PCI_VDEVICE(PROMISE, 0x8002), },

Switching to use hex numbers for _device ids_ is encouraged, because
history has proven its pointless to create named constants for
single-use ids. However, using named constants for PCI vendor ids makes
a lot of sense.

Jeff