2012-02-03 15:06:32

by Jan Beulich

[permalink] [raw]
Subject: [PATCH] x86: eliminate TICKET_MASK

The definition of it being questionable already (unnecessarily
including a cast), and it being used in a single place that can be
written shorter without it, remove this #define.

Along the same lines, simplify __ticket_spin_is_locked()'s main
expression, which was the more convoluted way because of needs that
went away with the recent type changes by Jeremy.

This is pure cleanup, no functional change intended.

Signed-off-by: Jan Beulich <[email protected]>
Cc: Jeremy Fitzhardinge <[email protected]>

---
arch/x86/include/asm/spinlock.h | 4 ++--
arch/x86/include/asm/spinlock_types.h | 1 -
2 files changed, 2 insertions(+), 3 deletions(-)

--- 3.3-rc2/arch/x86/include/asm/spinlock.h
+++ 3.3-rc2-x86-ticket-mask/arch/x86/include/asm/spinlock.h
@@ -88,14 +88,14 @@ static inline int __ticket_spin_is_locke
{
struct __raw_tickets tmp = ACCESS_ONCE(lock->tickets);

- return !!(tmp.tail ^ tmp.head);
+ return tmp.tail != tmp.head;
}

static inline int __ticket_spin_is_contended(arch_spinlock_t *lock)
{
struct __raw_tickets tmp = ACCESS_ONCE(lock->tickets);

- return ((tmp.tail - tmp.head) & TICKET_MASK) > 1;
+ return (__ticket_t)(tmp.tail - tmp.head) > 1;
}

#ifndef CONFIG_PARAVIRT_SPINLOCKS
--- 3.3-rc2/arch/x86/include/asm/spinlock_types.h
+++ 3.3-rc2-x86-ticket-mask/arch/x86/include/asm/spinlock_types.h
@@ -16,7 +16,6 @@ typedef u32 __ticketpair_t;
#endif

#define TICKET_SHIFT (sizeof(__ticket_t) * 8)
-#define TICKET_MASK ((__ticket_t)((1 << TICKET_SHIFT) - 1))

typedef struct arch_spinlock {
union {



2012-02-03 19:36:29

by Jeremy Fitzhardinge

[permalink] [raw]
Subject: Re: [PATCH] x86: eliminate TICKET_MASK

On 02/03/2012 07:06 AM, Jan Beulich wrote:
> The definition of it being questionable already (unnecessarily
> including a cast), and it being used in a single place that can be
> written shorter without it, remove this #define.
>
> Along the same lines, simplify __ticket_spin_is_locked()'s main
> expression, which was the more convoluted way because of needs that
> went away with the recent type changes by Jeremy.
>
> This is pure cleanup, no functional change intended.

That looks reasonable to me.

> Signed-off-by: Jan Beulich <[email protected]>
> Cc: Jeremy Fitzhardinge <[email protected]>
>
> ---
> arch/x86/include/asm/spinlock.h | 4 ++--
> arch/x86/include/asm/spinlock_types.h | 1 -
> 2 files changed, 2 insertions(+), 3 deletions(-)
>
> --- 3.3-rc2/arch/x86/include/asm/spinlock.h
> +++ 3.3-rc2-x86-ticket-mask/arch/x86/include/asm/spinlock.h
> @@ -88,14 +88,14 @@ static inline int __ticket_spin_is_locke
> {
> struct __raw_tickets tmp = ACCESS_ONCE(lock->tickets);
>
> - return !!(tmp.tail ^ tmp.head);
> + return tmp.tail != tmp.head;
> }
>
> static inline int __ticket_spin_is_contended(arch_spinlock_t *lock)
> {
> struct __raw_tickets tmp = ACCESS_ONCE(lock->tickets);
>
> - return ((tmp.tail - tmp.head) & TICKET_MASK) > 1;
> + return (__ticket_t)(tmp.tail - tmp.head) > 1;
> }

Yes. I only left these unchanged the first time around because I didn't
want to inadvertently change them, but my intent was to make them more
straightforward like this.

>
> #ifndef CONFIG_PARAVIRT_SPINLOCKS
> --- 3.3-rc2/arch/x86/include/asm/spinlock_types.h
> +++ 3.3-rc2-x86-ticket-mask/arch/x86/include/asm/spinlock_types.h
> @@ -16,7 +16,6 @@ typedef u32 __ticketpair_t;
> #endif
>
> #define TICKET_SHIFT (sizeof(__ticket_t) * 8)
> -#define TICKET_MASK ((__ticket_t)((1 << TICKET_SHIFT) - 1))
>
> typedef struct arch_spinlock {
> union {
>
>
>

Acked-by: Jeremy Fitzhardinge <[email protected]>

Thanks,
J

2012-02-07 19:41:42

by Jan Beulich

[permalink] [raw]
Subject: [tip:x86/asm] x86/spinlocks: Eliminate TICKET_MASK

Commit-ID: 7931d493051ea9b09e4fddee2dc40b2eb88d62b9
Gitweb: http://git.kernel.org/tip/7931d493051ea9b09e4fddee2dc40b2eb88d62b9
Author: Jan Beulich <[email protected]>
AuthorDate: Fri, 3 Feb 2012 15:06:26 +0000
Committer: Ingo Molnar <[email protected]>
CommitDate: Tue, 7 Feb 2012 10:09:54 +0100

x86/spinlocks: Eliminate TICKET_MASK

The definition of it being questionable already (unnecessarily
including a cast), and it being used in a single place that can
be written shorter without it, remove this #define.

Along the same lines, simplify __ticket_spin_is_locked()'s main
expression, which was the more convoluted way because of needs
that went away with the recent type changes by Jeremy.

This is pure cleanup, no functional change intended.

Signed-off-by: Jan Beulich <[email protected]>
Acked-by: Jeremy Fitzhardinge <[email protected]>
Cc: Linus Torvalds <[email protected]>
Cc: Andrew Morton <[email protected]>
Cc: Peter Zijlstra <[email protected]>
Link: http://lkml.kernel.org/r/[email protected]
Signed-off-by: Ingo Molnar <[email protected]>
---
arch/x86/include/asm/spinlock.h | 4 ++--
arch/x86/include/asm/spinlock_types.h | 1 -
2 files changed, 2 insertions(+), 3 deletions(-)

diff --git a/arch/x86/include/asm/spinlock.h b/arch/x86/include/asm/spinlock.h
index a82c2bf..76bfa2c 100644
--- a/arch/x86/include/asm/spinlock.h
+++ b/arch/x86/include/asm/spinlock.h
@@ -88,14 +88,14 @@ static inline int __ticket_spin_is_locked(arch_spinlock_t *lock)
{
struct __raw_tickets tmp = ACCESS_ONCE(lock->tickets);

- return !!(tmp.tail ^ tmp.head);
+ return tmp.tail != tmp.head;
}

static inline int __ticket_spin_is_contended(arch_spinlock_t *lock)
{
struct __raw_tickets tmp = ACCESS_ONCE(lock->tickets);

- return ((tmp.tail - tmp.head) & TICKET_MASK) > 1;
+ return (__ticket_t)(tmp.tail - tmp.head) > 1;
}

#ifndef CONFIG_PARAVIRT_SPINLOCKS
diff --git a/arch/x86/include/asm/spinlock_types.h b/arch/x86/include/asm/spinlock_types.h
index 8ebd5df..ad0ad07 100644
--- a/arch/x86/include/asm/spinlock_types.h
+++ b/arch/x86/include/asm/spinlock_types.h
@@ -16,7 +16,6 @@ typedef u32 __ticketpair_t;
#endif

#define TICKET_SHIFT (sizeof(__ticket_t) * 8)
-#define TICKET_MASK ((__ticket_t)((1 << TICKET_SHIFT) - 1))

typedef struct arch_spinlock {
union {