2012-06-06 12:01:48

by Axel Lin

[permalink] [raw]
Subject: [PATCH v2] regulator: palmas: Slightly code change for better readability

It's a little bit hard to read that the "else" case means id == PALMAS_REG_SMPS10.

if (id != PALMAS_REG_SMPS10){
do something for the cases id != PALMAS_REG_SMPS10;
} else {
do something for the case id == PALMAS_REG_SMPS10;
}

This patch changes above syntax to switch statement.

Signed-off-by: Axel Lin <[email protected]>
---
drivers/regulator/palmas-regulator.c | 28 ++++++++++++++++------------
1 file changed, 16 insertions(+), 12 deletions(-)

diff --git a/drivers/regulator/palmas-regulator.c b/drivers/regulator/palmas-regulator.c
index b4e10b0..112436b 100644
--- a/drivers/regulator/palmas-regulator.c
+++ b/drivers/regulator/palmas-regulator.c
@@ -517,7 +517,15 @@ static int palmas_smps_init(struct palmas *palmas, int id,
if (ret)
return ret;

- if (id != PALMAS_REG_SMPS10) {
+ switch (id) {
+ case PALMAS_REG_SMPS10:
+ if (reg_init->mode_sleep) {
+ reg &= ~PALMAS_SMPS10_CTRL_MODE_SLEEP_MASK;
+ reg |= reg_init->mode_sleep <<
+ PALMAS_SMPS10_CTRL_MODE_SLEEP_SHIFT;
+ }
+ break;
+ default:
if (reg_init->warm_reset)
reg |= PALMAS_SMPS12_CTRL_WR_S;

@@ -529,14 +537,8 @@ static int palmas_smps_init(struct palmas *palmas, int id,
reg |= reg_init->mode_sleep <<
PALMAS_SMPS12_CTRL_MODE_SLEEP_SHIFT;
}
- } else {
- if (reg_init->mode_sleep) {
- reg &= ~PALMAS_SMPS10_CTRL_MODE_SLEEP_MASK;
- reg |= reg_init->mode_sleep <<
- PALMAS_SMPS10_CTRL_MODE_SLEEP_SHIFT;
- }
-
}
+
ret = palmas_smps_write(palmas, addr, reg);
if (ret)
return ret;
@@ -660,10 +662,8 @@ static __devinit int palmas_probe(struct platform_device *pdev)
pmic->desc[id].name = palmas_regs_info[id].name;
pmic->desc[id].id = id;

- if (id != PALMAS_REG_SMPS10) {
- pmic->desc[id].ops = &palmas_ops_smps;
- pmic->desc[id].n_voltages = PALMAS_SMPS_NUM_VOLTAGES;
- } else {
+ switch (id) {
+ case PALMAS_REG_SMPS10:
pmic->desc[id].n_voltages = PALMAS_SMPS10_NUM_VOLTAGES;
pmic->desc[id].ops = &palmas_ops_smps10;
pmic->desc[id].vsel_reg = PALMAS_SMPS10_CTRL;
@@ -672,6 +672,10 @@ static __devinit int palmas_probe(struct platform_device *pdev)
pmic->desc[id].enable_mask = SMPS10_BOOST_EN;
pmic->desc[id].min_uV = 3750000;
pmic->desc[id].uV_step = 1250000;
+ break;
+ default:
+ pmic->desc[id].ops = &palmas_ops_smps;
+ pmic->desc[id].n_voltages = PALMAS_SMPS_NUM_VOLTAGES;
}

pmic->desc[id].type = REGULATOR_VOLTAGE;
--
1.7.9.5



2012-06-06 14:43:52

by Graeme Gregory

[permalink] [raw]
Subject: Re: [PATCH v2] regulator: palmas: Slightly code change for better readability

Acked-by: Graeme Gregory <[email protected]>

On 06/06/12 13:01, Axel Lin wrote:
> It's a little bit hard to read that the "else" case means id == PALMAS_REG_SMPS10.
>
> if (id != PALMAS_REG_SMPS10){
> do something for the cases id != PALMAS_REG_SMPS10;
> } else {
> do something for the case id == PALMAS_REG_SMPS10;
> }
>
> This patch changes above syntax to switch statement.
>
> Signed-off-by: Axel Lin <[email protected]>
> ---
> drivers/regulator/palmas-regulator.c | 28 ++++++++++++++++------------
> 1 file changed, 16 insertions(+), 12 deletions(-)
>
> diff --git a/drivers/regulator/palmas-regulator.c b/drivers/regulator/palmas-regulator.c
> index b4e10b0..112436b 100644
> --- a/drivers/regulator/palmas-regulator.c
> +++ b/drivers/regulator/palmas-regulator.c
> @@ -517,7 +517,15 @@ static int palmas_smps_init(struct palmas *palmas, int id,
> if (ret)
> return ret;
>
> - if (id != PALMAS_REG_SMPS10) {
> + switch (id) {
> + case PALMAS_REG_SMPS10:
> + if (reg_init->mode_sleep) {
> + reg &= ~PALMAS_SMPS10_CTRL_MODE_SLEEP_MASK;
> + reg |= reg_init->mode_sleep <<
> + PALMAS_SMPS10_CTRL_MODE_SLEEP_SHIFT;
> + }
> + break;
> + default:
> if (reg_init->warm_reset)
> reg |= PALMAS_SMPS12_CTRL_WR_S;
>
> @@ -529,14 +537,8 @@ static int palmas_smps_init(struct palmas *palmas, int id,
> reg |= reg_init->mode_sleep <<
> PALMAS_SMPS12_CTRL_MODE_SLEEP_SHIFT;
> }
> - } else {
> - if (reg_init->mode_sleep) {
> - reg &= ~PALMAS_SMPS10_CTRL_MODE_SLEEP_MASK;
> - reg |= reg_init->mode_sleep <<
> - PALMAS_SMPS10_CTRL_MODE_SLEEP_SHIFT;
> - }
> -
> }
> +
> ret = palmas_smps_write(palmas, addr, reg);
> if (ret)
> return ret;
> @@ -660,10 +662,8 @@ static __devinit int palmas_probe(struct platform_device *pdev)
> pmic->desc[id].name = palmas_regs_info[id].name;
> pmic->desc[id].id = id;
>
> - if (id != PALMAS_REG_SMPS10) {
> - pmic->desc[id].ops = &palmas_ops_smps;
> - pmic->desc[id].n_voltages = PALMAS_SMPS_NUM_VOLTAGES;
> - } else {
> + switch (id) {
> + case PALMAS_REG_SMPS10:
> pmic->desc[id].n_voltages = PALMAS_SMPS10_NUM_VOLTAGES;
> pmic->desc[id].ops = &palmas_ops_smps10;
> pmic->desc[id].vsel_reg = PALMAS_SMPS10_CTRL;
> @@ -672,6 +672,10 @@ static __devinit int palmas_probe(struct platform_device *pdev)
> pmic->desc[id].enable_mask = SMPS10_BOOST_EN;
> pmic->desc[id].min_uV = 3750000;
> pmic->desc[id].uV_step = 1250000;
> + break;
> + default:
> + pmic->desc[id].ops = &palmas_ops_smps;
> + pmic->desc[id].n_voltages = PALMAS_SMPS_NUM_VOLTAGES;
> }
>
> pmic->desc[id].type = REGULATOR_VOLTAGE;

2012-06-08 00:55:09

by Mark Brown

[permalink] [raw]
Subject: Re: [PATCH v2] regulator: palmas: Slightly code change for better readability

On Wed, Jun 06, 2012 at 08:01:38PM +0800, Axel Lin wrote:
> It's a little bit hard to read that the "else" case means id == PALMAS_REG_SMPS10.

Applied, thanks.


Attachments:
(No filename) (161.00 B)
signature.asc (836.00 B)
Digital signature
Download all attachments