2013-03-18 02:52:27

by zhangwei(Jovi)

[permalink] [raw]
Subject: [PATCH 2/2] relay: move FIX_SIZE macro into relay.c

It's better to place FIX_SIZE macro in relay.c, instead of relay.h

Signed-off-by: zhangwei(Jovi) <[email protected]>
---
include/linux/relay.h | 3 ---
kernel/relay.c | 3 +++
2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/include/linux/relay.h b/include/linux/relay.h
index 91cacc3..d7c8359 100644
--- a/include/linux/relay.h
+++ b/include/linux/relay.h
@@ -20,9 +20,6 @@
#include <linux/poll.h>
#include <linux/kref.h>

-/* Needs a _much_ better name... */
-#define FIX_SIZE(x) ((((x) - 1) & PAGE_MASK) + PAGE_SIZE)
-
/*
* Tracks changes to rchan/rchan_buf structs
*/
diff --git a/kernel/relay.c b/kernel/relay.c
index d21006c..4c2959b 100644
--- a/kernel/relay.c
+++ b/kernel/relay.c
@@ -550,6 +550,9 @@ static int __cpuinit relay_hotcpu_callback(struct notifier_block *nb,
return NOTIFY_OK;
}

+/* Needs a _much_ better name... */
+#define FIX_SIZE(x) ((((x) - 1) & PAGE_MASK) + PAGE_SIZE)
+
/**
* relay_open - create a new relay channel
* @base_filename: base name of files to create, %NULL for buffering only
--
1.7.9.7


2013-03-18 20:19:43

by Andrew Morton

[permalink] [raw]
Subject: Re: [PATCH 2/2] relay: move FIX_SIZE macro into relay.c

On Mon, 18 Mar 2013 10:51:54 +0800 "zhangwei(Jovi)" <[email protected]> wrote:

> +/* Needs a _much_ better name... */
> +#define FIX_SIZE(x) ((((x) - 1) & PAGE_MASK) + PAGE_SIZE)
> +

Gad. That's the same as PAGE_ALIGN(), is it not?

2013-03-20 09:24:55

by zhangwei(Jovi)

[permalink] [raw]
Subject: Re: [PATCH 2/2] relay: move FIX_SIZE macro into relay.c

On 2013/3/19 4:19, Andrew Morton wrote:
> On Mon, 18 Mar 2013 10:51:54 +0800 "zhangwei(Jovi)" <[email protected]> wrote:
>
>> +/* Needs a _much_ better name... */
>> +#define FIX_SIZE(x) ((((x) - 1) & PAGE_MASK) + PAGE_SIZE)
>> +
>
> Gad. That's the same as PAGE_ALIGN(), is it not?
>
Indeed, I will post another patch to change this, base on -mm.
Thanks.

.jovi