2013-05-06 14:07:18

by y

[permalink] [raw]
Subject: [PATCH 1/1] ktime: Use macro NSEC_PER_USEC instead of a magic number

From: Liu Ying <[email protected]>

We've got the macro NSEC_PER_USEC defined in header file
include/linux/time.h. To make the code decent, this patch
replaces the magic number 1000 to convert bewteen a time
value in microseconds and one in nanoseconds with the
macro NSEC_PER_USEC.

Signed-off-by: Liu Ying <[email protected]>
Cc: David S. Miller <[email protected]>
Cc: Daniel Borkmann <[email protected]>
Cc: Thomas Gleixner <[email protected]>
Cc: John Stultz <[email protected]>
---
include/linux/ktime.h | 7 ++++---
1 files changed, 4 insertions(+), 3 deletions(-)

diff --git a/include/linux/ktime.h b/include/linux/ktime.h
index bbca128..5de963d 100644
--- a/include/linux/ktime.h
+++ b/include/linux/ktime.h
@@ -229,7 +229,8 @@ static inline ktime_t timespec_to_ktime(const struct timespec ts)
static inline ktime_t timeval_to_ktime(const struct timeval tv)
{
return (ktime_t) { .tv = { .sec = (s32)tv.tv_sec,
- .nsec = (s32)tv.tv_usec * 1000 } };
+ .nsec = (s32)tv.tv_usec *
+ (s32)NSEC_PER_USEC} };
}

/**
@@ -320,12 +321,12 @@ static inline s64 ktime_us_delta(const ktime_t later, const ktime_t earlier)

static inline ktime_t ktime_add_us(const ktime_t kt, const u64 usec)
{
- return ktime_add_ns(kt, usec * 1000);
+ return ktime_add_ns(kt, usec * NSEC_PER_USEC);
}

static inline ktime_t ktime_sub_us(const ktime_t kt, const u64 usec)
{
- return ktime_sub_ns(kt, usec * 1000);
+ return ktime_sub_ns(kt, usec * NSEC_PER_USEC);
}

extern ktime_t ktime_add_safe(const ktime_t lhs, const ktime_t rhs);
--
1.7.1


2013-05-07 08:15:24

by Daniel Borkmann

[permalink] [raw]
Subject: Re: [PATCH 1/1] ktime: Use macro NSEC_PER_USEC instead of a magic number

On 05/06/2013 02:42 PM, [email protected] wrote:
> From: Liu Ying <[email protected]>

Nitpick:

If you only have 1 patch, then you don't need "1/1" in the subject.
The term magic number here might be a little exaggerated, not so
magic actually. :-)

But, in general I agree that we could do that also since it is used
elsewhere in the same header file. Thus, this might be more consistent.

> We've got the macro NSEC_PER_USEC defined in header file
> include/linux/time.h. To make the code decent, this patch
> replaces the magic number 1000 to convert bewteen a time
> value in microseconds and one in nanoseconds with the
> macro NSEC_PER_USEC.
>
> Signed-off-by: Liu Ying <[email protected]>
> Cc: David S. Miller <[email protected]>
> Cc: Daniel Borkmann <[email protected]>
> Cc: Thomas Gleixner <[email protected]>
> Cc: John Stultz <[email protected]>
> ---
> include/linux/ktime.h | 7 ++++---
> 1 files changed, 4 insertions(+), 3 deletions(-)
>
> diff --git a/include/linux/ktime.h b/include/linux/ktime.h
> index bbca128..5de963d 100644
> --- a/include/linux/ktime.h
> +++ b/include/linux/ktime.h
> @@ -229,7 +229,8 @@ static inline ktime_t timespec_to_ktime(const struct timespec ts)
> static inline ktime_t timeval_to_ktime(const struct timeval tv)
> {
> return (ktime_t) { .tv = { .sec = (s32)tv.tv_sec,
> - .nsec = (s32)tv.tv_usec * 1000 } };
> + .nsec = (s32)tv.tv_usec *
> + (s32)NSEC_PER_USEC} };

Nitpick: Likely, this could be reduced to one cast only.

Otherwise looks good.

> }
>
> /**
> @@ -320,12 +321,12 @@ static inline s64 ktime_us_delta(const ktime_t later, const ktime_t earlier)
>
> static inline ktime_t ktime_add_us(const ktime_t kt, const u64 usec)
> {
> - return ktime_add_ns(kt, usec * 1000);
> + return ktime_add_ns(kt, usec * NSEC_PER_USEC);
> }
>
> static inline ktime_t ktime_sub_us(const ktime_t kt, const u64 usec)
> {
> - return ktime_sub_ns(kt, usec * 1000);
> + return ktime_sub_ns(kt, usec * NSEC_PER_USEC);
> }
>
> extern ktime_t ktime_add_safe(const ktime_t lhs, const ktime_t rhs);
>

2013-05-07 09:12:41

by Daniel Borkmann

[permalink] [raw]
Subject: Re: [PATCH 1/1] ktime: Use macro NSEC_PER_USEC instead of a magic number

On 05/07/2013 11:08 AM, Liu Ying wrote:
> 2013/5/7 Liu Ying <[email protected]>
>> 2013/5/7 Daniel Borkmann <[email protected]>
>>> On 05/06/2013 02:42 PM, [email protected] wrote:
>>>> From: Liu Ying <[email protected]>

>>> If you only have 1 patch, then you don't need "1/1" in the subject.
>>> The term magic number here might be a little exaggerated, not so
>>> magic actually. :-)
>>>
>> Thanks. I will update this. How about turning "magic number" to "immediate
>> number"?

Maybe like ``ktime: Use macro NSEC_PER_USEC where appropriate''.