Use more appropriate NUMA_NO_NODE instead of -1
Signed-off-by: Jianguo Wu <[email protected]>
---
mm/mempolicy.c | 10 +++++-----
1 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/mm/mempolicy.c b/mm/mempolicy.c
index 4baf12e..4f73025 100644
--- a/mm/mempolicy.c
+++ b/mm/mempolicy.c
@@ -1083,7 +1083,7 @@ int do_migrate_pages(struct mm_struct *mm, const nodemask_t *from,
tmp = *from;
while (!nodes_empty(tmp)) {
int s,d;
- int source = -1;
+ int source = NUMA_NO_NODE;
int dest = 0;
for_each_node_mask(s, tmp) {
@@ -1118,7 +1118,7 @@ int do_migrate_pages(struct mm_struct *mm, const nodemask_t *from,
if (!node_isset(dest, tmp))
break;
}
- if (source == -1)
+ if (source == NUMA_NO_NODE)
break;
node_clear(source, tmp);
@@ -1765,7 +1765,7 @@ static unsigned offset_il_node(struct mempolicy *pol,
unsigned nnodes = nodes_weight(pol->v.nodes);
unsigned target;
int c;
- int nid = -1;
+ int nid = NUMA_NO_NODE;
if (!nnodes)
return numa_node_id();
@@ -1802,11 +1802,11 @@ static inline unsigned interleave_nid(struct mempolicy *pol,
/*
* Return the bit number of a random bit set in the nodemask.
- * (returns -1 if nodemask is empty)
+ * (returns NUMA_NO_NOD if nodemask is empty)
*/
int node_random(const nodemask_t *maskp)
{
- int w, bit = -1;
+ int w, bit = NUMA_NO_NODE;
w = nodes_weight(*maskp);
if (w)
--
1.7.1
(9/16/13 8:53 AM), Jianguo Wu wrote:
> Use more appropriate NUMA_NO_NODE instead of -1
>
> Signed-off-by: Jianguo Wu <[email protected]>
> ---
> mm/mempolicy.c | 10 +++++-----
> 1 files changed, 5 insertions(+), 5 deletions(-)
I think this patch don't make any functional change, right?
Acked-by: KOSAKI Motohiro <[email protected]>
> @@ -1802,11 +1802,11 @@ static inline unsigned interleave_nid(struct mempolicy *pol,
>
> /*
> * Return the bit number of a random bit set in the nodemask.
> - * (returns -1 if nodemask is empty)
> + * (returns NUMA_NO_NOD if nodemask is empty)
s/NUMA_NO_NOD/NUMA_NO_NODE/
> */
> int node_random(const nodemask_t *maskp)
> {
> - int w, bit = -1;
> + int w, bit = NUMA_NO_NODE;
>
> w = nodes_weight(*maskp);
> if (w)
>
On 2013/9/17 0:19, KOSAKI Motohiro wrote:
> (9/16/13 8:53 AM), Jianguo Wu wrote:
>> Use more appropriate NUMA_NO_NODE instead of -1
>>
>> Signed-off-by: Jianguo Wu <[email protected]>
>> ---
>> mm/mempolicy.c | 10 +++++-----
>> 1 files changed, 5 insertions(+), 5 deletions(-)
>
> I think this patch don't make any functional change, right?
>
Yes.
> Acked-by: KOSAKI Motohiro <[email protected]>
Thanks for your ack.
>
>
>
>
On 2013/9/17 4:26, Cody P Schafer wrote:
>
>> @@ -1802,11 +1802,11 @@ static inline unsigned interleave_nid(struct mempolicy *pol,
>>
>> /*
>> * Return the bit number of a random bit set in the nodemask.
>> - * (returns -1 if nodemask is empty)
>> + * (returns NUMA_NO_NOD if nodemask is empty)
>
> s/NUMA_NO_NOD/NUMA_NO_NODE/
>
Thanks, I will resent this.
>> */
>> int node_random(const nodemask_t *maskp)
>> {
>> - int w, bit = -1;
>> + int w, bit = NUMA_NO_NODE;
>>
>> w = nodes_weight(*maskp);
>> if (w)
>>
>
>
>