2014-10-01 18:08:08

by Mark Brown

[permalink] [raw]
Subject: Re: [RFC][PATCH 1/4] regulator: Add helper function to get "poweroff-source" property

On Tue, Sep 30, 2014 at 05:29:43PM +0000, Romain Perier wrote:

> +/**
> + * of_get_regulator_poweroff_source - Get poweroff-source for given device_node
> + * @np: Pointer to the given device_node
> + *
> + * return true if present false otherwise
> + */
> +bool of_get_regulator_poweroff_source(const struct device_node *np)
> +{
> + return of_property_read_bool(np, "poweroff-source");
> +}
> +EXPORT_SYMBOL_GPL(of_get_regulator_poweroff_source);

This isn't really a regulator specific thing - it's common for the
actual implementation to be to simply cut power but it could be
something that doesn't look like a regulator doing it like a system
monitor. I'd rename this to something like is_system_poweroff_source().

You probably also want to CC the DT maintainers on this and add some
documentation of this as a standard property, not entirely sure where
exactly but I'm sure the DT people could advise.


Attachments:
(No filename) (912.00 B)
signature.asc (473.00 B)
Digital signature
Download all attachments

2014-10-02 17:40:18

by Romain Perier

[permalink] [raw]
Subject: Re: [RFC][PATCH 1/4] regulator: Add helper function to get "poweroff-source" property

Adding the corresponding drivers and DT maintainers to the loop (parts
of the kernel which use this property)

Le 01/10/2014 20:07, Mark Brown a ?crit :
> On Tue, Sep 30, 2014 at 05:29:43PM +0000, Romain Perier wrote:
>
>> +/**
>> + * of_get_regulator_poweroff_source - Get poweroff-source for given device_node
>> + * @np: Pointer to the given device_node
>> + *
>> + * return true if present false otherwise
>> + */
>> +bool of_get_regulator_poweroff_source(const struct device_node *np)
>> +{
>> + return of_property_read_bool(np, "poweroff-source");
>> +}
>> +EXPORT_SYMBOL_GPL(of_get_regulator_poweroff_source);
> This isn't really a regulator specific thing - it's common for the
> actual implementation to be to simply cut power but it could be
> something that doesn't look like a regulator doing it like a system
> monitor. I'd rename this to something like is_system_poweroff_source().
>
> You probably also want to CC the DT maintainers on this and add some
> documentation of this as a standard property, not entirely sure where
> exactly but I'm sure the DT people could advise.