On 2023/9/4 18:56, Andy Shevchenko wrote:
> On Mon, Sep 04, 2023 at 08:48:04AM +0000, Xingui Yang wrote:
>> Use DEFINE_SHOW_STORE_ATTRIBUTE helper for read-write file to reduce some
>> duplicated code and delete unused macros.
>
>> Signed-off-by: Luo Jiaxing <[email protected]>
>> Signed-off-by: Xingui Yang <[email protected]>
>
> Same comments as per previous patch.
>
> ...
>
>> -/*
>> - * Helper macros for setting up debugfs entries.
>> - * _name: The name of the debugfs entry
>> - * _ctx_struct: The context that was passed when creating the debugfs file
>> - *
>> - * QLA_DFS_SETUP_RD could be used when there is only a show function.
>> - * - show function take the name qla_dfs_<sysfs-name>_show
>> - *
>> - * QLA_DFS_SETUP_RW could be used when there are both show and write functions.
>> - * - show function take the name qla_dfs_<sysfs-name>_show
>> - * - write function take the name qla_dfs_<sysfs-name>_write
>> - *
>> - * To have a new debugfs entry, do:
>> - * 1. Create a "struct dentry *" in the appropriate structure in the format
>> - * dfs_<sysfs-name>
>> - * 2. Setup debugfs entries using QLA_DFS_SETUP_RD / QLA_DFS_SETUP_RW
>> - * 3. Create debugfs file in qla2x00_dfs_setup() using QLA_DFS_CREATE_FILE
>> - * or QLA_DFS_ROOT_CREATE_FILE
>> - * 4. Remove debugfs file in qla2x00_dfs_remove() using QLA_DFS_REMOVE_FILE
>> - * or QLA_DFS_ROOT_REMOVE_FILE
>> - *
>> - * Example for creating "TEST" sysfs file:
>> - * 1. struct qla_hw_data { ... struct dentry *dfs_TEST; }
>> - * 2. QLA_DFS_SETUP_RD(TEST, scsi_qla_host_t);
>> - * 3. In qla2x00_dfs_setup():
>> - * QLA_DFS_CREATE_FILE(ha, TEST, 0600, ha->dfs_dir, vha);
>> - * 4. In qla2x00_dfs_remove():
>> - * QLA_DFS_REMOVE_FILE(ha, TEST);
>> - */
>
> I believe this comment (in some form) has to be preserved.
> Try to rewrite it using reference to the new macro.
Thanks for your reply, I checked and these macros aren't being called
anywhere else, so I decided to delete them all. Of course, maybe this
macro will be used in the future, and I can resubmit another version
based on your suggestion.
Thanks.
Xingui
>
> Otherwise looks good to me.
>