2022-09-21 10:12:58

by Daniel Lezcano

[permalink] [raw]
Subject: [PATCH v4 02/30] thermal/sysfs: Do not make get_trip_hyst optional

The get_trip_hyst() ops is optional. It results all around the thermal
framework code a check against the ops pointer and different action
adding more complexity and making the code less readable and
understandable.

A zero hysteresis value is perfectly valid, so instead of adding more
circumvolutions in the code, create unconditionnaly the hysteresis and
use the thermal_zone_get_trip() function which returns a zero
hysteresis if the get_trip_hyst() is not defined.

Signed-off-by: Daniel Lezcano <[email protected]>
---
drivers/thermal/thermal_sysfs.c | 25 +++++++++----------------
1 file changed, 9 insertions(+), 16 deletions(-)

diff --git a/drivers/thermal/thermal_sysfs.c b/drivers/thermal/thermal_sysfs.c
index 75f6b151a58b..18cdd7cd0008 100644
--- a/drivers/thermal/thermal_sysfs.c
+++ b/drivers/thermal/thermal_sysfs.c
@@ -424,23 +424,20 @@ static int create_trip_attrs(struct thermal_zone_device *tz, int mask)
return -ENOMEM;
}

- if (tz->ops->get_trip_hyst) {
- tz->trip_hyst_attrs = kcalloc(tz->num_trips,
- sizeof(*tz->trip_hyst_attrs),
- GFP_KERNEL);
- if (!tz->trip_hyst_attrs) {
- kfree(tz->trip_type_attrs);
- kfree(tz->trip_temp_attrs);
- return -ENOMEM;
- }
+ tz->trip_hyst_attrs = kcalloc(tz->num_trips,
+ sizeof(*tz->trip_hyst_attrs),
+ GFP_KERNEL);
+ if (!tz->trip_hyst_attrs) {
+ kfree(tz->trip_type_attrs);
+ kfree(tz->trip_temp_attrs);
+ return -ENOMEM;
}

attrs = kcalloc(tz->num_trips * 3 + 1, sizeof(*attrs), GFP_KERNEL);
if (!attrs) {
kfree(tz->trip_type_attrs);
kfree(tz->trip_temp_attrs);
- if (tz->ops->get_trip_hyst)
- kfree(tz->trip_hyst_attrs);
+ kfree(tz->trip_hyst_attrs);
return -ENOMEM;
}

@@ -473,9 +470,6 @@ static int create_trip_attrs(struct thermal_zone_device *tz, int mask)
}
attrs[indx + tz->num_trips] = &tz->trip_temp_attrs[indx].attr.attr;

- /* create Optional trip hyst attribute */
- if (!tz->ops->get_trip_hyst)
- continue;
snprintf(tz->trip_hyst_attrs[indx].name, THERMAL_NAME_LENGTH,
"trip_point_%d_hyst", indx);

@@ -512,8 +506,7 @@ static void destroy_trip_attrs(struct thermal_zone_device *tz)

kfree(tz->trip_type_attrs);
kfree(tz->trip_temp_attrs);
- if (tz->ops->get_trip_hyst)
- kfree(tz->trip_hyst_attrs);
+ kfree(tz->trip_hyst_attrs);
kfree(tz->trips_attribute_group.attrs);
}

--
2.34.1


2022-09-23 14:34:09

by Zhang, Rui

[permalink] [raw]
Subject: Re: [PATCH v4 02/30] thermal/sysfs: Do not make get_trip_hyst optional

On Wed, 2022-09-21 at 11:42 +0200, Daniel Lezcano wrote:
> The get_trip_hyst() ops is optional. It results all around the
> thermal
> framework code a check against the ops pointer and different action
> adding more complexity and making the code less readable and
> understandable.
>
> A zero hysteresis value is perfectly valid, so instead of adding more
> circumvolutions in the code, create unconditionnaly the hysteresis
> and
> use the thermal_zone_get_trip() function which returns a zero
> hysteresis if the get_trip_hyst() is not defined.

I think an alternative way is to use the .is_visible() callback to make
this cleanup transparent to userspace.

With this, we can remove the
if (tz->ops->set_trip_hyst)check in create_trip_attrs() as well.

But you make the cal. :)

thanks,
rui


2022-09-26 15:58:32

by Daniel Lezcano

[permalink] [raw]
Subject: Re: [PATCH v4 02/30] thermal/sysfs: Do not make get_trip_hyst optional

On 23/09/2022 16:19, Zhang Rui wrote:
> On Wed, 2022-09-21 at 11:42 +0200, Daniel Lezcano wrote:
>> The get_trip_hyst() ops is optional. It results all around the
>> thermal
>> framework code a check against the ops pointer and different action
>> adding more complexity and making the code less readable and
>> understandable.
>>
>> A zero hysteresis value is perfectly valid, so instead of adding more
>> circumvolutions in the code, create unconditionnaly the hysteresis
>> and
>> use the thermal_zone_get_trip() function which returns a zero
>> hysteresis if the get_trip_hyst() is not defined.
>
> I think an alternative way is to use the .is_visible() callback to make
> this cleanup transparent to userspace.

This would apply for the group not per trip point file, no?


> With this, we can remove the
> if (tz->ops->set_trip_hyst)check in create_trip_attrs() as well.
>
> But you make the cal. :)
>
> thanks,
> rui
>
>


--
<http://www.linaro.org/> Linaro.org │ Open source software for ARM SoCs

Follow Linaro: <http://www.facebook.com/pages/Linaro> Facebook |
<http://twitter.com/#!/linaroorg> Twitter |
<http://www.linaro.org/linaro-blog/> Blog