2022-07-24 07:06:01

by wangjianli

[permalink] [raw]
Subject: [PATCH] powerpc/kvm: fix repeated words in comments Delete the redundant word 'that'.

Signed-off-by: wangjianli <[email protected]>
---
arch/powerpc/kvm/book3s_64_mmu_hv.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/powerpc/kvm/book3s_64_mmu_hv.c b/arch/powerpc/kvm/book3s_64_mmu_hv.c
index 514fd45c1994..73c6db20cd8a 100644
--- a/arch/powerpc/kvm/book3s_64_mmu_hv.c
+++ b/arch/powerpc/kvm/book3s_64_mmu_hv.c
@@ -1601,7 +1601,7 @@ long kvm_vm_ioctl_resize_hpt_commit(struct kvm *kvm,
* is valid, it is written to the HPT as if an H_ENTER with the
* exact flag set was done. When the invalid count is non-zero
* in the header written to the stream, the kernel will make
- * sure that that many HPTEs are invalid, and invalidate them
+ * sure that many HPTEs are invalid, and invalidate them
* if not.
*/

--
2.36.1


2022-07-25 06:54:43

by Michael Ellerman

[permalink] [raw]
Subject: Re: [PATCH] powerpc/kvm: fix repeated words in comments Delete the redundant word 'that'.

wangjianli <[email protected]> writes:
> Signed-off-by: wangjianli <[email protected]>
> ---
> arch/powerpc/kvm/book3s_64_mmu_hv.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/powerpc/kvm/book3s_64_mmu_hv.c b/arch/powerpc/kvm/book3s_64_mmu_hv.c
> index 514fd45c1994..73c6db20cd8a 100644
> --- a/arch/powerpc/kvm/book3s_64_mmu_hv.c
> +++ b/arch/powerpc/kvm/book3s_64_mmu_hv.c
> @@ -1601,7 +1601,7 @@ long kvm_vm_ioctl_resize_hpt_commit(struct kvm *kvm,
> * is valid, it is written to the HPT as if an H_ENTER with the
> * exact flag set was done. When the invalid count is non-zero
> * in the header written to the stream, the kernel will make
> - * sure that that many HPTEs are invalid, and invalidate them
> + * sure that many HPTEs are invalid, and invalidate them
> * if not.

The existing wording is correct:

"the kernel will make sure that ... that many HPTEs are invalid"

cheers

2022-07-25 07:20:46

by Julia Lawall

[permalink] [raw]
Subject: Re: [PATCH] powerpc/kvm: fix repeated words in comments Delete the redundant word 'that'.



On Mon, 25 Jul 2022, Michael Ellerman wrote:

> wangjianli <[email protected]> writes:
> > Signed-off-by: wangjianli <[email protected]>
> > ---
> > arch/powerpc/kvm/book3s_64_mmu_hv.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/arch/powerpc/kvm/book3s_64_mmu_hv.c b/arch/powerpc/kvm/book3s_64_mmu_hv.c
> > index 514fd45c1994..73c6db20cd8a 100644
> > --- a/arch/powerpc/kvm/book3s_64_mmu_hv.c
> > +++ b/arch/powerpc/kvm/book3s_64_mmu_hv.c
> > @@ -1601,7 +1601,7 @@ long kvm_vm_ioctl_resize_hpt_commit(struct kvm *kvm,
> > * is valid, it is written to the HPT as if an H_ENTER with the
> > * exact flag set was done. When the invalid count is non-zero
> > * in the header written to the stream, the kernel will make
> > - * sure that that many HPTEs are invalid, and invalidate them
> > + * sure that many HPTEs are invalid, and invalidate them
> > * if not.
>
> The existing wording is correct:
>
> "the kernel will make sure that ... that many HPTEs are invalid"

Maybe it would be better as "that the number of invalid HPTEs is the same
as the invalid count"?

julia

2022-07-25 10:49:25

by Michael Ellerman

[permalink] [raw]
Subject: Re: [PATCH] powerpc/kvm: fix repeated words in comments Delete the redundant word 'that'.

Julia Lawall <[email protected]> writes:
> On Mon, 25 Jul 2022, Michael Ellerman wrote:
>> wangjianli <[email protected]> writes:
>> > diff --git a/arch/powerpc/kvm/book3s_64_mmu_hv.c b/arch/powerpc/kvm/book3s_64_mmu_hv.c
>> > index 514fd45c1994..73c6db20cd8a 100644
>> > --- a/arch/powerpc/kvm/book3s_64_mmu_hv.c
>> > +++ b/arch/powerpc/kvm/book3s_64_mmu_hv.c
>> > @@ -1601,7 +1601,7 @@ long kvm_vm_ioctl_resize_hpt_commit(struct kvm *kvm,
>> > * is valid, it is written to the HPT as if an H_ENTER with the
>> > * exact flag set was done. When the invalid count is non-zero
>> > * in the header written to the stream, the kernel will make
>> > - * sure that that many HPTEs are invalid, and invalidate them
>> > + * sure that many HPTEs are invalid, and invalidate them
>> > * if not.
>>
>> The existing wording is correct:
>>
>> "the kernel will make sure that ... that many HPTEs are invalid"
>
> Maybe it would be better as "that the number of invalid HPTEs is the same
> as the invalid count"?

That doesn't read quite right, I think because if the number of invalid
HPTEs doesn't match the invalid count, the code will invalidate HPTEs so
that the number matches.

So maybe:

When the invalid count is non-zero in the header written to the stream,
the kernel will make sure that number of HPTEs are invalid, or
invalidate them if not.

cheers