> The ax25_dev is managed by reference counting, so it should not be
> deallocated directly by kfree() in ax25_dev_free(), replace it with
> ax25_dev_put() instead.
You repeated a wording mistake in the summary phrase from a previous cover letter.
Please avoid confusion about desired code replacements.
How do you think about to append parentheses to involved function names?
Would you find the following change description a bit nicer?
The object “ax25_dev” is managed by reference counting.
Thus it should not be directly released by a kfree() call in ax25_dev_free().
Replace it with a ax25_dev_put() call instead.
Would you like to extend patch version descriptions (or changelogs) accordingly?
Regards,
Markus
On Fri, May 03, 2024 at 07:36:54AM +0200, Markus Elfring wrote:
> > The ax25_dev is managed by reference counting, so it should not be
> > deallocated directly by kfree() in ax25_dev_free(), replace it with
> > ax25_dev_put() instead.
>
> You repeated a wording mistake in the summary phrase from a previous cover letter.
Yeah. That's true. The subject should be changed to:
Subject: [PATCH] ax25: change kfree() in ax25_dev_free() to ax25_dev_put()
Another option would be:
Subject: [PATCH] ax25: use ax25_dev_put() in ax25_dev_free()
Otherwise the commit message is okay as-is.
regards,
dan carpenter