2020-09-16 16:04:34

by Qian Cai

[permalink] [raw]
Subject: Re: [RFC] autonuma: Migrate on fault among multiple bound nodes

On Wed, 2020-09-16 at 08:59 +0800, Huang Ying wrote:
> static int apply_policy_zone(struct mempolicy *policy, enum zone_type zone)
> @@ -2474,11 +2481,13 @@ int mpol_misplaced(struct page *page, struct
> vm_area_struct *vma, unsigned long
> int thisnid = cpu_to_node(thiscpu);
> int polnid = NUMA_NO_NODE;
> int ret = -1;
> + bool moron;

Are you really going to use that name those days?


2020-09-16 19:15:31

by David Hildenbrand

[permalink] [raw]
Subject: Re: [RFC] autonuma: Migrate on fault among multiple bound nodes

On 16.09.20 15:39, Qian Cai wrote:
> On Wed, 2020-09-16 at 08:59 +0800, Huang Ying wrote:
>> static int apply_policy_zone(struct mempolicy *policy, enum zone_type zone)
>> @@ -2474,11 +2481,13 @@ int mpol_misplaced(struct page *page, struct
>> vm_area_struct *vma, unsigned long
>> int thisnid = cpu_to_node(thiscpu);
>> int polnid = NUMA_NO_NODE;
>> int ret = -1;
>> + bool moron;
>
> Are you really going to use that name those days?
>
>

include/uapi/linux/mempolicy.h:#define MPOL_F_MORON (1 << 4) /*
Migrate On protnone Reference On Node */

Not commenting the decision for that name. It's uapi ... and naming the
variable like the uapi flag seems to be a sane thing to do ... hmmm ...

--
Thanks,

David / dhildenb

2020-09-17 03:15:04

by Matthew Wilcox

[permalink] [raw]
Subject: Re: [RFC] autonuma: Migrate on fault among multiple bound nodes

On Wed, Sep 16, 2020 at 05:29:41PM +0200, David Hildenbrand wrote:
> On 16.09.20 15:39, Qian Cai wrote:
> > On Wed, 2020-09-16 at 08:59 +0800, Huang Ying wrote:
> >> static int apply_policy_zone(struct mempolicy *policy, enum zone_type zone)
> >> @@ -2474,11 +2481,13 @@ int mpol_misplaced(struct page *page, struct
> >> vm_area_struct *vma, unsigned long
> >> int thisnid = cpu_to_node(thiscpu);
> >> int polnid = NUMA_NO_NODE;
> >> int ret = -1;
> >> + bool moron;
> >
> > Are you really going to use that name those days?
> >
> >
>
> include/uapi/linux/mempolicy.h:#define MPOL_F_MORON (1 << 4) /*
> Migrate On protnone Reference On Node */
>
> Not commenting the decision for that name. It's uapi ... and naming the
> variable like the uapi flag seems to be a sane thing to do ... hmmm ...

Perhaps we could migrate to mopron / MPOL_F_MOPRON?