2014-10-23 16:22:54

by Fabian Frédérick

[permalink] [raw]
Subject: [PATCH 1/1 net-next] Bluetooth: fix shadow warning in hci_disconnect()

use cpr for hci_cp_read_clock_offset instead of cp
(already defined above).

Signed-off-by: Fabian Frederick <[email protected]>
---
net/bluetooth/hci_conn.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/net/bluetooth/hci_conn.c b/net/bluetooth/hci_conn.c
index b9517bd..6151e09 100644
--- a/net/bluetooth/hci_conn.c
+++ b/net/bluetooth/hci_conn.c
@@ -141,10 +141,10 @@ int hci_disconnect(struct hci_conn *conn, __u8 reason)
*/
if (conn->type == ACL_LINK && conn->role == HCI_ROLE_MASTER) {
struct hci_dev *hdev = conn->hdev;
- struct hci_cp_read_clock_offset cp;
+ struct hci_cp_read_clock_offset cpr;

- cp.handle = cpu_to_le16(conn->handle);
- hci_send_cmd(hdev, HCI_OP_READ_CLOCK_OFFSET, sizeof(cp), &cp);
+ cpr.handle = cpu_to_le16(conn->handle);
+ hci_send_cmd(hdev, HCI_OP_READ_CLOCK_OFFSET, sizeof(cpr), &cpr);
}

conn->state = BT_DISCONN;
--
1.9.3


2014-10-23 16:29:18

by Marcel Holtmann

[permalink] [raw]
Subject: Re: [PATCH 1/1 net-next] Bluetooth: fix shadow warning in hci_disconnect()

Hi Fabian,

> use cpr for hci_cp_read_clock_offset instead of cp
> (already defined above).
>
> Signed-off-by: Fabian Frederick <[email protected]>
> ---
> net/bluetooth/hci_conn.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/net/bluetooth/hci_conn.c b/net/bluetooth/hci_conn.c
> index b9517bd..6151e09 100644
> --- a/net/bluetooth/hci_conn.c
> +++ b/net/bluetooth/hci_conn.c
> @@ -141,10 +141,10 @@ int hci_disconnect(struct hci_conn *conn, __u8 reason)
> */
> if (conn->type == ACL_LINK && conn->role == HCI_ROLE_MASTER) {
> struct hci_dev *hdev = conn->hdev;
> - struct hci_cp_read_clock_offset cp;
> + struct hci_cp_read_clock_offset cpr;
>
> - cp.handle = cpu_to_le16(conn->handle);
> - hci_send_cmd(hdev, HCI_OP_READ_CLOCK_OFFSET, sizeof(cp), &cp);
> + cpr.handle = cpu_to_le16(conn->handle);
> + hci_send_cmd(hdev, HCI_OP_READ_CLOCK_OFFSET, sizeof(cpr), &cpr);

valid change, but I do not like cpr as variable name. We need to come up with a better one. There are other places in the code where we had the same thing. Please have a look there.

Regards

Marcel

2014-10-23 17:30:58

by Fabian Frédérick

[permalink] [raw]
Subject: Re: [PATCH 1/1 net-next] Bluetooth: fix shadow warning in hci_disconnect()



> On 23 October 2014 at 18:29 Marcel Holtmann <[email protected]> wrote:
>
>
> Hi Fabian,
>
> > use cpr for hci_cp_read_clock_offset instead of cp
> > (already defined above).
> >
> > Signed-off-by: Fabian Frederick <[email protected]>
> > ---
> > net/bluetooth/hci_conn.c | 6 +++---
> > 1 file changed, 3 insertions(+), 3 deletions(-)
> >
> > diff --git a/net/bluetooth/hci_conn.c b/net/bluetooth/hci_conn.c
> > index b9517bd..6151e09 100644
> > --- a/net/bluetooth/hci_conn.c
> > +++ b/net/bluetooth/hci_conn.c
> > @@ -141,10 +141,10 @@ int hci_disconnect(struct hci_conn *conn, __u8 reason)
> >      */
> >     if (conn->type == ACL_LINK && conn->role == HCI_ROLE_MASTER) {
> >             struct hci_dev *hdev = conn->hdev;
> > -           struct hci_cp_read_clock_offset cp;
> > +           struct hci_cp_read_clock_offset cpr;
> >
> > -           cp.handle = cpu_to_le16(conn->handle);
> > -           hci_send_cmd(hdev, HCI_OP_READ_CLOCK_OFFSET, sizeof(cp), &cp);
> > +           cpr.handle = cpu_to_le16(conn->handle);
> > +           hci_send_cmd(hdev, HCI_OP_READ_CLOCK_OFFSET, sizeof(cpr), &cpr);
>
> valid change, but I do not like cpr as variable name. We need to come up with
> a better one. There are other places in the code where we had the same thing.
> Please have a look there.
>
> Regards
>
> Marcel
>

Hi Marcel,

  Maybe read_cp (like commit c1f23a2bfc89 with struct hci_cp_auth_requested
auth_cp) ?

Regards,
Fabian

2014-10-23 22:09:43

by Marcel Holtmann

[permalink] [raw]
Subject: Re: [PATCH 1/1 net-next] Bluetooth: fix shadow warning in hci_disconnect()

Hi Fabian,

>>> use cpr for hci_cp_read_clock_offset instead of cp
>>> (already defined above).
>>>
>>> Signed-off-by: Fabian Frederick <[email protected]>
>>> ---
>>> net/bluetooth/hci_conn.c | 6 +++---
>>> 1 file changed, 3 insertions(+), 3 deletions(-)
>>>
>>> diff --git a/net/bluetooth/hci_conn.c b/net/bluetooth/hci_conn.c
>>> index b9517bd..6151e09 100644
>>> --- a/net/bluetooth/hci_conn.c
>>> +++ b/net/bluetooth/hci_conn.c
>>> @@ -141,10 +141,10 @@ int hci_disconnect(struct hci_conn *conn, __u8 reason)
>>> */
>>> if (conn->type == ACL_LINK && conn->role == HCI_ROLE_MASTER) {
>>> struct hci_dev *hdev = conn->hdev;
>>> - struct hci_cp_read_clock_offset cp;
>>> + struct hci_cp_read_clock_offset cpr;
>>>
>>> - cp.handle = cpu_to_le16(conn->handle);
>>> - hci_send_cmd(hdev, HCI_OP_READ_CLOCK_OFFSET, sizeof(cp), &cp);
>>> + cpr.handle = cpu_to_le16(conn->handle);
>>> + hci_send_cmd(hdev, HCI_OP_READ_CLOCK_OFFSET, sizeof(cpr), &cpr);
>>
>> valid change, but I do not like cpr as variable name. We need to come up with
>> a better one. There are other places in the code where we had the same thing.
>> Please have a look there.
>
> Maybe read_cp (like commit c1f23a2bfc89 with struct hci_cp_auth_requested
> auth_cp) ?

lets use clkoff_cp unless someone comes up with a better name.

Regards

Marcel