2011-04-08 12:25:14

by Wanlong Gao

[permalink] [raw]
Subject: [PATCH] INPUT:Change a more clearly name for the input handlers' table

From: Wanlong Gao <[email protected]>

Change the input handlers' table name to input_handler_table for
making more clearly sense .

Signed-off-by: Wanlong Gao <[email protected]>
---
drivers/input/input.c | 10 +++++-----
1 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/input/input.c b/drivers/input/input.c
index d6e8bd8..00511dc 100644
--- a/drivers/input/input.c
+++ b/drivers/input/input.c
@@ -45,7 +45,7 @@ static LIST_HEAD(input_handler_list);
*/
static DEFINE_MUTEX(input_mutex);

-static struct input_handler *input_table[8];
+static struct input_handler *input_handler_table[8];

static inline int is_event_supported(unsigned int code,
unsigned long *bm, unsigned int max)
@@ -1893,11 +1893,11 @@ int input_register_handler(struct input_handler *handler)
INIT_LIST_HEAD(&handler->h_list);

if (handler->fops != NULL) {
- if (input_table[handler->minor >> 5]) {
+ if (input_handler_table[handler->minor >> 5]) {
retval = -EBUSY;
goto out;
}
- input_table[handler->minor >> 5] = handler;
+ input_handler_table[handler->minor >> 5] = handler;
}

list_add_tail(&handler->node, &input_handler_list);
@@ -1933,7 +1933,7 @@ void input_unregister_handler(struct input_handler *handler)
list_del_init(&handler->node);

if (handler->fops != NULL)
- input_table[handler->minor >> 5] = NULL;
+ input_handler_table[handler->minor >> 5] = NULL;

input_wakeup_procfs_readers();

@@ -2062,7 +2062,7 @@ static int input_open_file(struct inode *inode, struct file *file)
return err;

/* No load-on-demand here? */
- handler = input_table[iminor(inode) >> 5];
+ handler = input_handler_table[iminor(inode) >> 5];
if (handler)
new_fops = fops_get(handler->fops);

--
1.7.3


2011-04-12 06:24:22

by Dmitry Torokhov

[permalink] [raw]
Subject: Re: [PATCH] INPUT:Change a more clearly name for the input handlers' table

On Fri, Apr 08, 2011 at 08:23:44PM +0800, [email protected] wrote:
> From: Wanlong Gao <[email protected]>
>
> Change the input handlers' table name to input_handler_table for
> making more clearly sense .
>

Sorry but I think the old name is fine. I'd rather see this table
removed altogether and character devices pushed down into input handlers
themselves.

Thanks.

--
Dmitry

2011-04-12 12:01:10

by Wanlong Gao

[permalink] [raw]
Subject: Re: [PATCH] INPUT:Change a more clearly name for the input handlers' table

On 4/12/11, Dmitry Torokhov <[email protected]> wrote:
> On Fri, Apr 08, 2011 at 08:23:44PM +0800, [email protected] wrote:
>> From: Wanlong Gao <[email protected]>
>>
>> Change the input handlers' table name to input_handler_table for
>> making more clearly sense .
>>
>
> Sorry but I think the old name is fine. I'd rather see this table
> removed altogether and character devices pushed down into input handlers
> themselves.
If so , it will be a really hard work .
Thanks a lot.
>
> Thanks.
>
> --
> Dmitry
>