From: Tina Ruchandani <[email protected]>
Date: Thu, 29 Oct 2015 21:08:16 -0700
> @@ -45,7 +46,7 @@ static u_int *debug;
> static LIST_HEAD(iclock_list);
> static DEFINE_RWLOCK(iclock_lock);
> static u16 iclock_count; /* counter of last clock */
> -static struct timeval iclock_tv; /* time stamp of last clock */
> +static ktime_t iclock_tv; /* time stamp of last clock */
> static int iclock_tv_valid; /* already received one timestamp */
It only makes sense for this variable to be named "iclock_tv" when
it is of type "timeval". And therefore it is confusing to keep
using this variable name after changing it's type to "ktime_t".
Therefore please adjust the variable name appropriately, thanks.
>
> Therefore please adjust the variable name appropriately, thanks.
David,
Thanks for the feedback, I will send out a v3.