2023-01-30 20:51:15

by andrey.konovalov

[permalink] [raw]
Subject: [PATCH 10/18] lib/stackdepot: rename init_stack_slab

From: Andrey Konovalov <[email protected]>

Rename init_stack_slab to depot_init_slab to align the name with
depot_alloc_stack.

No functional changes.

Signed-off-by: Andrey Konovalov <[email protected]>
---
lib/stackdepot.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/lib/stackdepot.c b/lib/stackdepot.c
index cddcf029e307..69b9316b0d4b 100644
--- a/lib/stackdepot.c
+++ b/lib/stackdepot.c
@@ -220,7 +220,7 @@ int stack_depot_init(void)
}
EXPORT_SYMBOL_GPL(stack_depot_init);

-static bool init_stack_slab(void **prealloc)
+static bool depot_init_slab(void **prealloc)
{
if (!*prealloc)
return false;
@@ -268,12 +268,12 @@ depot_alloc_stack(unsigned long *entries, int size, u32 hash, void **prealloc)
/*
* smp_store_release() here pairs with smp_load_acquire() from
* |next_slab_inited| in stack_depot_save() and
- * init_stack_slab().
+ * depot_init_slab().
*/
if (depot_index + 1 < STACK_ALLOC_MAX_SLABS)
smp_store_release(&next_slab_inited, 0);
}
- init_stack_slab(prealloc);
+ depot_init_slab(prealloc);
if (stack_slabs[depot_index] == NULL)
return NULL;

@@ -402,7 +402,7 @@ depot_stack_handle_t __stack_depot_save(unsigned long *entries,
* lock.
*
* The smp_load_acquire() here pairs with smp_store_release() to
- * |next_slab_inited| in depot_alloc_stack() and init_stack_slab().
+ * |next_slab_inited| in depot_alloc_stack() and depot_init_slab().
*/
if (unlikely(can_alloc && !smp_load_acquire(&next_slab_inited))) {
/*
@@ -438,7 +438,7 @@ depot_stack_handle_t __stack_depot_save(unsigned long *entries,
* We didn't need to store this stack trace, but let's keep
* the preallocated memory for the future.
*/
- WARN_ON(!init_stack_slab(&prealloc));
+ WARN_ON(!depot_init_slab(&prealloc));
}

raw_spin_unlock_irqrestore(&depot_lock, flags);
--
2.25.1



2023-01-31 11:35:00

by Alexander Potapenko

[permalink] [raw]
Subject: Re: [PATCH 10/18] lib/stackdepot: rename init_stack_slab

On Mon, Jan 30, 2023 at 9:50 PM <[email protected]> wrote:
>
> From: Andrey Konovalov <[email protected]>
>
> Rename init_stack_slab to depot_init_slab to align the name with
> depot_alloc_stack.
>
> No functional changes.
>
> Signed-off-by: Andrey Konovalov <[email protected]>
Reviewed-by: Alexander Potapenko <[email protected]>