2021-05-06 18:43:48

by Marco Elver

[permalink] [raw]
Subject: [PATCH] checkpatch: warn about direct use of send_sig_info and force_sig_info

Setting up siginfo and using send_sig_info() and force_sig_info()
directly is discouraged. Instead, new code wanting to generate signals
should use the appropriate helper specific to the signal.

Eric mentioned that he'd like to make these static at some point, but
until that can happen, let's try to avoid introducing new users of them.

Cc: Eric W. Biederman <[email protected]>
Signed-off-by: Marco Elver <[email protected]>
---
Eric,

While siginfo doesn't need changing often, when it does, it's quite the
adventure. We now have the various static asserts. The other thing is
usage of {send,force}_sig_info.

I think the best option right now is to teach checkpatch.pl about it
until they become static.

Fyi, I noticed one such new user here:
https://lkml.kernel.org/r/[email protected]

Thanks,
-- Marco
---
scripts/checkpatch.pl | 6 ++++++
1 file changed, 6 insertions(+)

diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
index ccb412a74725..3a86aafc3bcd 100755
--- a/scripts/checkpatch.pl
+++ b/scripts/checkpatch.pl
@@ -7153,6 +7153,12 @@ sub process {
"Where possible, use lockdep_assert_held instead of assertions based on spin_is_locked\n" . $herecurr);
}

+# check for direct use of send_sig_info(), force_sig_info()
+ if ($line =~ /\b((force|send)_sig_info)\(/) {
+ WARN("USE_SIGINFO_HELPER",
+ "Where possible, avoid using '$1' directly and use a signal-specific helper setting required siginfo fields (see include/linux/sched/signal.h).\n" . $herecurr);
+ }
+
# check for deprecated apis
if ($line =~ /\b($deprecated_apis_search)\b\s*\(/) {
my $deprecated_api = $1;
--
2.31.1.607.g51e8a6a459-goog


2021-05-06 18:59:16

by Dwaipayan Ray

[permalink] [raw]
Subject: Re: [PATCH] checkpatch: warn about direct use of send_sig_info and force_sig_info

On Thu, May 6, 2021 at 6:59 PM Marco Elver <[email protected]> wrote:
>
> Setting up siginfo and using send_sig_info() and force_sig_info()
> directly is discouraged. Instead, new code wanting to generate signals
> should use the appropriate helper specific to the signal.
>
> Eric mentioned that he'd like to make these static at some point, but
> until that can happen, let's try to avoid introducing new users of them.
>
> Cc: Eric W. Biederman <[email protected]>
> Signed-off-by: Marco Elver <[email protected]>
> ---
> Eric,
>
> While siginfo doesn't need changing often, when it does, it's quite the
> adventure. We now have the various static asserts. The other thing is
> usage of {send,force}_sig_info.
>
> I think the best option right now is to teach checkpatch.pl about it
> until they become static.
>
> Fyi, I noticed one such new user here:
> https://lkml.kernel.org/r/[email protected]
>
> Thanks,
> -- Marco
> ---
> scripts/checkpatch.pl | 6 ++++++
> 1 file changed, 6 insertions(+)
>
> diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
> index ccb412a74725..3a86aafc3bcd 100755
> --- a/scripts/checkpatch.pl
> +++ b/scripts/checkpatch.pl
> @@ -7153,6 +7153,12 @@ sub process {
> "Where possible, use lockdep_assert_held instead of assertions based on spin_is_locked\n" . $herecurr);
> }
>
> +# check for direct use of send_sig_info(), force_sig_info()
> + if ($line =~ /\b((force|send)_sig_info)\(/) {

I think this might be a little better as:
if ($line =~ /\b((?:force|send)_sig_info)\(/) {

Otherwise it's good as it is.
Tested-by: Dwaipayan Ray <[email protected]>

Thanks,
Dwaipayan.

> + WARN("USE_SIGINFO_HELPER",
> + "Where possible, avoid using '$1' directly and use a signal-specific helper setting required siginfo fields (see include/linux/sched/signal.h).\n" . $herecurr);
> + }
> +
> # check for deprecated apis
> if ($line =~ /\b($deprecated_apis_search)\b\s*\(/) {
> my $deprecated_api = $1;
> --
> 2.31.1.607.g51e8a6a459-goog
>

2021-05-06 19:00:31

by Marco Elver

[permalink] [raw]
Subject: [PATCH v2] checkpatch: warn about direct use of send_sig_info and force_sig_info

Setting up siginfo and using send_sig_info() or force_sig_info()
directly is discouraged. Instead, new code wanting to generate signals
should use the appropriate helper specific to the signal.

Eric mentioned that he'd like to make these static at some point, but
until that can happen, let's try to avoid introducing new users of them.

Cc: Eric W. Biederman <[email protected]>
Tested-by: Dwaipayan Ray <[email protected]>
Signed-off-by: Marco Elver <[email protected]>
---
v2:
* Use ?: because we don't need $2 (suggested by Dwaipayan Ray).

v1: https://lkml.kernel.org/r/[email protected]
---
scripts/checkpatch.pl | 6 ++++++
1 file changed, 6 insertions(+)

diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
index ccb412a74725..59f6eb3a2026 100755
--- a/scripts/checkpatch.pl
+++ b/scripts/checkpatch.pl
@@ -7153,6 +7153,12 @@ sub process {
"Where possible, use lockdep_assert_held instead of assertions based on spin_is_locked\n" . $herecurr);
}

+# check for direct use of send_sig_info(), force_sig_info()
+ if ($line =~ /\b((?:force|send)_sig_info)\(/) {
+ WARN("USE_SIGINFO_HELPER",
+ "Where possible, avoid using '$1' directly and use a signal-specific helper setting required siginfo fields (see include/linux/sched/signal.h).\n" . $herecurr);
+ }
+
# check for deprecated apis
if ($line =~ /\b($deprecated_apis_search)\b\s*\(/) {
my $deprecated_api = $1;
--
2.31.1.607.g51e8a6a459-goog

2021-05-06 21:43:40

by Joe Perches

[permalink] [raw]
Subject: Re: [PATCH v2] checkpatch: warn about direct use of send_sig_info and force_sig_info

On Thu, 2021-05-06 at 17:22 +0200, Marco Elver wrote:
> Setting up siginfo and using send_sig_info() or force_sig_info()
> directly is discouraged. Instead, new code wanting to generate signals
> should use the appropriate helper specific to the signal.
>
> Eric mentioned that he'd like to make these static at some point, but
> until that can happen, let's try to avoid introducing new users of them.
[]
> diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
[]
> @@ -7153,6 +7153,12 @@ sub process {
> ? "Where possible, use lockdep_assert_held instead of assertions based on spin_is_locked\n" . $herecurr);
> ? }
> ?
>
> +# check for direct use of send_sig_info(), force_sig_info()
> + if ($line =~ /\b((?:force|send)_sig_info)\(/) {

You want to be able to find uses like 'force_sig_info (<foo>...'
so you should add a \s* after the capture group.
And it's probably simpler and more readable to use
if ($sline =~ /\b(force_sig_info|send_sig_info)\s*\(/) {
instead of the more complex regex

(sline is stripped of comments, $line is not)

> + WARN("USE_SIGINFO_HELPER",
> + "Where possible, avoid using '$1' directly and use a signal-specific helper setting required siginfo fields (see include/linux/sched/signal.h).\n" . $herecurr);

A rather long and complex sentence.
How about
"Prefer signal-specific helpers over use of '$1' (see: include/linux/sched/signal.h)\n"

And in that signal.h file, there's no obvious reference to
these signal-specific helpers. Is there a better reference
in the Documentation/ tree?


2021-05-06 23:19:38

by Lukas Bulwahn

[permalink] [raw]
Subject: Re: [PATCH] checkpatch: warn about direct use of send_sig_info and force_sig_info

On Thu, May 6, 2021 at 5:02 PM Dwaipayan Ray <[email protected]> wrote:
>
> On Thu, May 6, 2021 at 6:59 PM Marco Elver <[email protected]> wrote:
> >
> > Setting up siginfo and using send_sig_info() and force_sig_info()
> > directly is discouraged. Instead, new code wanting to generate signals
> > should use the appropriate helper specific to the signal.
> >
> > Eric mentioned that he'd like to make these static at some point, but
> > until that can happen, let's try to avoid introducing new users of them.
> >
> > Cc: Eric W. Biederman <[email protected]>
> > Signed-off-by: Marco Elver <[email protected]>
> > ---
> > Eric,
> >
> > While siginfo doesn't need changing often, when it does, it's quite the
> > adventure. We now have the various static asserts. The other thing is
> > usage of {send,force}_sig_info.
> >
> > I think the best option right now is to teach checkpatch.pl about it
> > until they become static.
> >
> > Fyi, I noticed one such new user here:
> > https://lkml.kernel.org/r/[email protected]
> >
> > Thanks,
> > -- Marco
> > ---
> > scripts/checkpatch.pl | 6 ++++++
> > 1 file changed, 6 insertions(+)
> >
> > diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
> > index ccb412a74725..3a86aafc3bcd 100755
> > --- a/scripts/checkpatch.pl
> > +++ b/scripts/checkpatch.pl
> > @@ -7153,6 +7153,12 @@ sub process {
> > "Where possible, use lockdep_assert_held instead of assertions based on spin_is_locked\n" . $herecurr);
> > }
> >
> > +# check for direct use of send_sig_info(), force_sig_info()
> > + if ($line =~ /\b((force|send)_sig_info)\(/) {
>
> I think this might be a little better as:
> if ($line =~ /\b((?:force|send)_sig_info)\(/) {
>
> Otherwise it's good as it is.
> Tested-by: Dwaipayan Ray <[email protected]>
>

Dwaipayan, do you want to also document this new rule on the
checkpatch documentation?
Marco, maybe you can assist us here with some pointer (lore.kernel.org
link) to the original discussion you had.

Lukas

2021-05-07 15:09:26

by Marco Elver

[permalink] [raw]
Subject: Re: [PATCH v2] checkpatch: warn about direct use of send_sig_info and force_sig_info

On Thu, 6 May 2021 at 23:41, Joe Perches <[email protected]> wrote:
> On Thu, 2021-05-06 at 17:22 +0200, Marco Elver wrote:
> > Setting up siginfo and using send_sig_info() or force_sig_info()
> > directly is discouraged. Instead, new code wanting to generate signals
> > should use the appropriate helper specific to the signal.
> >
> > Eric mentioned that he'd like to make these static at some point, but
> > until that can happen, let's try to avoid introducing new users of them.
> []
> > diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
> []
> > @@ -7153,6 +7153,12 @@ sub process {
> > "Where possible, use lockdep_assert_held instead of assertions based on spin_is_locked\n" . $herecurr);
> > }
> >
> >
> > +# check for direct use of send_sig_info(), force_sig_info()
> > + if ($line =~ /\b((?:force|send)_sig_info)\(/) {
>
> You want to be able to find uses like 'force_sig_info (<foo>...'
> so you should add a \s* after the capture group.
> And it's probably simpler and more readable to use
> if ($sline =~ /\b(force_sig_info|send_sig_info)\s*\(/) {
> instead of the more complex regex
>
> (sline is stripped of comments, $line is not)

Done for v3.

> > + WARN("USE_SIGINFO_HELPER",
> > + "Where possible, avoid using '$1' directly and use a signal-specific helper setting required siginfo fields (see include/linux/sched/signal.h).\n" . $herecurr);
>
> A rather long and complex sentence.
> How about
> "Prefer signal-specific helpers over use of '$1' (see: include/linux/sched/signal.h)\n"

Sounds good.

> And in that signal.h file, there's no obvious reference to
> these signal-specific helpers. Is there a better reference
> in the Documentation/ tree?

Yeah, signal.h has their declarations, the definitions live in
kernel/signal.c. But otherwise, there's no better reference anywhere
AFAIK. The main thing here is to alert someone to double-check their
use of {send,force}_sig_info() -- when thinking what would have helped
me identify the problem earlier, I came to the conclusion that a
checkpatch.pl warning would have done exactly that. Like Eric said,
eventually these might become static, but it doesn't look trivial to
do this right now. When that happens, this check can then be removed
again. But since it might be a while, we can at least try to automate
this "trivial" review around siginfo.

I'll send v3 shortly.

Thanks,
-- Marco