2020-06-07 05:33:11

by Oded Gabbay

[permalink] [raw]
Subject: [PATCH] habanalabs: rename mmu_write() to mmu_asid_va_write()

The function name conflicts with a static inline function in
arch/m68k/include/asm/mcfmmu.h

Reported-by: kernel test robot <[email protected]>
Signed-off-by: Oded Gabbay <[email protected]>
---
drivers/misc/habanalabs/debugfs.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/misc/habanalabs/debugfs.c b/drivers/misc/habanalabs/debugfs.c
index 3c8dcdfba20c..fc4372c18ce2 100644
--- a/drivers/misc/habanalabs/debugfs.c
+++ b/drivers/misc/habanalabs/debugfs.c
@@ -480,7 +480,7 @@ static int mmu_show(struct seq_file *s, void *data)
return 0;
}

-static ssize_t mmu_write(struct file *file, const char __user *buf,
+static ssize_t mmu_asid_va_write(struct file *file, const char __user *buf,
size_t count, loff_t *f_pos)
{
struct seq_file *s = file->private_data;
@@ -1125,7 +1125,7 @@ static const struct hl_info_list hl_debugfs_list[] = {
{"command_submission_jobs", command_submission_jobs_show, NULL},
{"userptr", userptr_show, NULL},
{"vm", vm_show, NULL},
- {"mmu", mmu_show, mmu_write},
+ {"mmu", mmu_show, mmu_asid_va_write},
{"engines", engines_show, NULL}
};

--
2.17.1


2020-06-07 11:22:44

by Tomer Tayar

[permalink] [raw]
Subject: RE: [PATCH] habanalabs: rename mmu_write() to mmu_asid_va_write()

On Sun, Jun 7, 2020 at 8:31 AM, Oded Gabbay <[email protected]> wrote:
> The function name conflicts with a static inline function in
> arch/m68k/include/asm/mcfmmu.h
>
> Reported-by: kernel test robot <[email protected]>
> Signed-off-by: Oded Gabbay <[email protected]>

Reviewed-by: Tomer Tayar <[email protected]>