Make code more readable with list_for_each_reverse.
Signed-off-by: Domen Puncer <[email protected]>
Signed-off-by: Maximilian Attems <[email protected]>
---
linux-2.6.10-rc2-bk4-max/arch/um/drivers/chan_kern.c | 4 +---
1 files changed, 1 insertion(+), 3 deletions(-)
diff -puN arch/um/drivers/chan_kern.c~list-for-each-entry-drivers_chan_kern arch/um/drivers/chan_kern.c
--- linux-2.6.10-rc2-bk4/arch/um/drivers/chan_kern.c~list-for-each-entry-drivers_chan_kern 2004-11-19 17:14:47.000000000 +0100
+++ linux-2.6.10-rc2-bk4-max/arch/um/drivers/chan_kern.c 2004-11-19 17:14:47.000000000 +0100
@@ -218,7 +218,6 @@ void enable_chan(struct list_head *chans
void close_chan(struct list_head *chans)
{
- struct list_head *ele;
struct chan *chan;
/* Close in reverse order as open in case more than one of them
@@ -226,8 +225,7 @@ void close_chan(struct list_head *chans)
* state. Then, the first one opened will have the original state,
* so it must be the last closed.
*/
- for(ele = chans->prev; ele != chans; ele = ele->prev){
- chan = list_entry(ele, struct chan, list);
+ list_for_each_entry_reverse(chan, chans, list) {
if(!chan->opened) continue;
if(chan->ops->close != NULL)
(*chan->ops->close)(chan->fd, chan->data);
_
[email protected] said:
> Make code more readable with list_for_each_reverse.
> Signed-off-by: Domen Puncer <[email protected]>
> Signed-off-by: Maximilian Attems <[email protected]>
OK by me.
Jeff