2017-11-15 20:31:30

by Matthew Wilcox

[permalink] [raw]
Subject: RE: [PATCH RFC] lib: simplify bitmap_from_u32array API

I certainly approve. The name sucks too ????

> @@ -60,7 +60,7 @@
> * bitmap_find_free_region(bitmap, bits, order) Find and allocate bit region
> * bitmap_release_region(bitmap, pos, order) Free specified bit region
> * bitmap_allocate_region(bitmap, pos, order) Allocate specified bit region
> - * bitmap_from_u32array(dst, nbits, buf, nwords) *dst = *buf (nwords 32b
> words)
> + * bitmap_from_u32array(dst, buf, nbits) *dst = *buf (nwords 32b
> words)

I think this should read:
+ * bitmap_from_u32array(dst, buf, bits) Copy 'bits' from buf to dst

Also, on LE systems, shouldn't we just use memcpy() for the first bits/8 bytes?